Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Lolu chungechunge lwavalwa lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

get rid of AVG secure search from TABS

  • 9 uphendule
  • 1 inale nkinga
  • 15611 views
  • Igcine ukuphendulwa ngu Andrew

more options

I have searched high and low for how to get rid of this AVG Secure Search every time I click on a new tab, I have no arrow or search engine arrows to find Manage Search Engines, everything I try does NOT work. HELP I am ready to UNINSTALL my FIREFOX. Guess I am STILL not talking to a person just posting on another message board. Is there NO ONE who will help me with this?

Isisombululo esikhethiwe

I have been there, done that with all of that, BUT, I FINALLY found a solution that WORKED on another forum, so problem resolved:

How to stop AVG Secure Search in Firefox..

Besides all the standard attempts that people try, Try this.

Delete (or just store in another location ) a file called avgMozXPCOM.js . It is located in the Mozilla FireFox directory.

Here is the path on my system. C:\Program Files (x86)\Mozilla Firefox\browser\components

Worked for me.

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (9)

more options
more options

AVG Secure Search IS NOT listed in Manage Search Engines. I Reset Firefox, clicked on a tab, AVG Secure Search is STILL THERE.

more options

Please check for an AVG extension on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then review the list on the right.

You should be able to disable it, but if there is no Remove button, you probably need to use the Windows Control Panel, Uninstall a Program, to completely get it off your system.

Any luck?

more options

For future reference, here is how to change the hidden setting for what appears on the new tab:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box that appears above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter the desired value:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

If you still get something other than you specified, check your other extensions.

more options

Isisombululo Esikhethiwe

I have been there, done that with all of that, BUT, I FINALLY found a solution that WORKED on another forum, so problem resolved:

How to stop AVG Secure Search in Firefox..

Besides all the standard attempts that people try, Try this.

Delete (or just store in another location ) a file called avgMozXPCOM.js . It is located in the Mozilla FireFox directory.

Here is the path on my system. C:\Program Files (x86)\Mozilla Firefox\browser\components

Worked for me.

more options

I tried that earlier, I just posted what worked...

more options

Hi,

Removing so-called AVG secure search (aka, AVG Security Toolbar or AVG Search Toolbar) depends how you got it. Did you install it along with some purposive bundleware? Alongside the main virus protection from AVG company? Well, to cleanly get rid of the said AVG bar, you at least remove the main application in the programs list, then you restore the changed browser settings.

Detailed post: [Remove AVG Security Toolbar]

Okulungisiwe ngu James

more options

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

more options

Locking thread as solution has been found and, to prevent further spam.