X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Menu bar "Insert" option went missing - can no longer insert hyperlinks.

Kuphostiwe

Don't know what happened - I used to be able to insert hyperlinks! The option to do so has disappeared from the menu bar. I'm running Thunderbird 31.0 and I have already tried disabling all add-ons, restarting to safe mode, and a combination of the two, to no avail.

The add-ons I have installed are: 1. Enigmail 1.7a1pre ("OpenPGP message encryption and authentication") 2. FiltaQuilla 1.2.0 ("Mail filter custom actions and searches")

Enigmail was the most recent install, but I'm not using it right now because it doesn't support using digital signatures as email attachments instead of inline wrapping. I am instead using the built-in security setting in Thunderbird, allowing me to use a third-party digital certificate as an attachment. However, I don't know why either Enigmail or any digital signing/encryption service would remove an option from my menu bar, it just doesn't make sense.

Is it perhaps the version of Thunderbird I have? Is anyone else running 31.0 without an "Insert" option on their menu bar? Thanks in advance for any help you can give me.

Don't know what happened - I used to be able to insert hyperlinks! The option to do so has disappeared from the menu bar. I'm running Thunderbird 31.0 and I have already tried disabling all add-ons, restarting to safe mode, and a combination of the two, to no avail. The add-ons I have installed are: 1. Enigmail 1.7a1pre ("OpenPGP message encryption and authentication") 2. FiltaQuilla 1.2.0 ("Mail filter custom actions and searches") Enigmail was the most recent install, but I'm not using it right now because it doesn't support using digital signatures as email attachments instead of inline wrapping. I am instead using the built-in security setting in Thunderbird, allowing me to use a third-party digital certificate as an attachment. However, I don't know why either Enigmail or any digital signing/encryption service would remove an option from my menu bar, it just doesn't make sense. Is it perhaps the version of Thunderbird I have? Is anyone else running 31.0 without an "Insert" option on their menu bar? Thanks in advance for any help you can give me.

Eminye Imininingwane Yohlelo

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0

Eminye Imininingwane

Zenos 2265 izisombululo 12258 izimpendulo
Kuphostiwe

What else DO you have on your menus and toolbars? I'm trying to be clear as to whether you have specifically lost the Insert Link option, the whole Insert sub-menu, or the whole menu bar. (People often say that the Send button has gone, forgetting to mention that the toolbar it lives on has gone too!)

BTW you can just copy-n-paste URLs into the message text. Most email clients will render them as active links. You don't need the Insert option.

Another thought; some Enigmail users complain that it prefers plain text and so disables HTML entirely, which would lose all the Insert and other formatting options. I haven't experienced this myself with Enigmail.

What else DO you have on your menus and toolbars? I'm trying to be clear as to whether you have specifically lost the Insert Link option, the whole Insert sub-menu, or the whole menu bar. (People often say that the Send button has gone, forgetting to mention that the toolbar it lives on has gone too!) BTW you can just copy-n-paste URLs into the message text. Most email clients will render them as active links. You don't ''need'' the Insert option. Another thought; some Enigmail users complain that it prefers plain text and so disables HTML entirely, which would lose all the Insert and other formatting options. I haven't experienced this myself with Enigmail.

Okulungisiwe ngu Zenos

Umnikazi wombuzo

Here is a screenshot of my menu bar. I'll look into the Enigmail suggestion and check back in afterwards.

Here is a screenshot of my menu bar. I'll look into the Enigmail suggestion and check back in afterwards.
user01229325 2241 izisombululo 10216 izimpendulo
Kuphostiwe

You posted the Menu Bar. Attach is on the Composition Toolbar in the Write window.

Open the Write window Select View-Toolbars and turn the missing toolbar back on.

Sorry I misread Attach instead of Insert.

You posted the Menu Bar. Attach is on the Composition Toolbar in the Write window. Open the Write window Select View-Toolbars and turn the missing toolbar back on. Sorry I misread Attach instead of Insert.

Okulungisiwe ngu user01229325

Umnikazi wombuzo

That's okay, here is a more complete screenshot from the "write" window. I'm still looking into the Enigmail issue. Will report back a little later.

That's okay, here is a more complete screenshot from the "write" window. I'm still looking into the Enigmail issue. Will report back a little later.
stankbait 0 izisombululo 1 izimpendulo
Kuphostiwe

My Insert and Format Menu does not show in 31.0. It appeared twice but only after I click on the "Please confirm your Firefox Help question" link on the email where I registered to ask a question. If I close the window and open another message pane it disappears again. I can open the verification message and click on it and the Format and Insert menu will them appear in new pane, but only if I click on the verify message first. Second set of screen shots is after I open the registration email.

Does anyone know what to do if the View > Toolbars > and NO FORMATTING BAR appears on some of the mail accounts?????

My Insert and Format Menu does not show in 31.0. It appeared twice but only after I click on the "Please confirm your Firefox Help question" link on the email where I registered to ask a question. If I close the window and open another message pane it disappears again. I can open the verification message and click on it and the Format and Insert menu will them appear in new pane, but only if I click on the verify message first. Second set of screen shots is after I open the registration email. Does anyone know what to do if the View > Toolbars > and NO FORMATTING BAR appears on some of the mail accounts?????

Okulungisiwe ngu stankbait

ttocsmij 0 izisombululo 11 izimpendulo
Kuphostiwe

The INSERT | LINK function has been broken. It now only links external images. The ability to link a web page URL or an email address has been lost. I only noticed it today after version 31.3.0 installed. I hope this can be fixed PDQ as I will need this function to work properly when February rolls around.

[ No, I have no add-ons or other funky adjustments. Just a straight Windows install. ]

The INSERT | LINK function has been broken. It now only links external images. The ability to link a web page URL or an email address has been lost. I only noticed it today after version 31.3.0 installed. I hope this can be fixed PDQ as I will need this function to work properly when February rolls around. [ No, I have no add-ons or other funky adjustments. Just a straight Windows install. ]

Umnikazi wombuzo

Just an update: I'm running 34.0 on the Beta channel and the problem is still present. When I get some time, I think I'll poke around in the code and see if I can make sense of things. Has anyone else done this yet?

Just an update: I'm running 34.0 on the Beta channel and the problem is still present. When I get some time, I think I'll poke around in the code and see if I can make sense of things. Has anyone else done this yet?
ttocsmij 0 izisombululo 11 izimpendulo
Kuphostiwe

Sorry ... I missed that you said menu bar. Menu item INSERT | LINK does appear on my menu bar ... it's just broken, so to speak (see my first post above). Should I start a new topic or do you think these will converge anyhow at some point? Wow. Lost / intermittent and broken! What a mess this poor function is in. ^_^

HP m7357c / Windows XP Media SP3 / TB 31.3.0

Sorry ... I missed that you said menu bar. Menu item INSERT | LINK '''does''' appear on my menu bar ... it's just ''broken'', so to speak (see my first post above). Should I start a new topic or do you think these will converge anyhow at some point? Wow. Lost / intermittent and broken! What a mess this poor function is in. ^_^ HP m7357c / Windows XP Media SP3 / TB 31.3.0
hifromnz 4 izisombululo 46 izimpendulo
Kuphostiwe

Format and insert both missing from my compose window toolbar.

Oh, now it is there, in another compose window????

It is in NEW compose window but not in REPLY window! (See screenshot of both) I need it in reply window as well!

I need to insert pictures and format text. THERE IS NO WAY TO DO THIS NOW. No option in composition toolbar items.

Format and insert both missing from my compose window toolbar. Oh, now it is there, in another compose window???? It is in NEW compose window but not in REPLY window! (See screenshot of both) I need it in reply window as well! I need to insert pictures and format text. THERE IS NO WAY TO DO THIS NOW. No option in composition toolbar items.

Okulungisiwe ngu hifromnz

user01229325 2241 izisombululo 10216 izimpendulo
Kuphostiwe

Impendulo Ewusizo

That is what the menu bar looks like when replying to a Plain Text message and not a HTML message. You cannot Format or Insert in plain text.

That is what the menu bar looks like when replying to a Plain Text message and not a HTML message. You cannot Format or Insert in plain text.
hifromnz 4 izisombululo 46 izimpendulo
Kuphostiwe

Thank you airmail, that's it! I think my settings are to reply to plain text in plain text - so I want to change it to reply in html. I have looked for the option but can't find it, does anyone know where it is?

It must have replied in html automatically in my last TB but not in the rebuild I've just done.

Thank you airmail, that's it! I think my settings are to reply to plain text in plain text - so I want to change it to reply in html. I have looked for the option but can't find it, does anyone know where it is? It must have replied in html automatically in my last TB but not in the rebuild I've just done.

Okulungisiwe ngu hifromnz

user01229325 2241 izisombululo 10216 izimpendulo
Kuphostiwe

In the write window it is Options-Delivery Format

You can set a preference per contact on their entry in the address book.

In the write window it is Options-Delivery Format You can set a preference per contact on their entry in the address book.
hifromnz 4 izisombululo 46 izimpendulo
Kuphostiwe

Thanks for that, but delivery format does not appear in my compose window? The account has always been set to send in html in <tools/account settings>, and I cant find any option to choose reply in text or html in the <tools/options/composition> window - it must be somewhere else? (Screenshots attached)

Its not practical to make settings for each recipient, these are internet inquiries.

Holding the shift key when I click reply makes no difference.

SOLUTION! I HAD TICKED SAME REPLY FORMAT IN QUOTE AND COMPOSE MANAGER!

Thanks

Thanks for that, but delivery format does not appear in my compose window? The account has always been set to send in html in <tools/account settings>, and I cant find any option to choose reply in text or html in the <tools/options/composition> window - it must be somewhere else? (Screenshots attached) Its not practical to make settings for each recipient, these are internet inquiries. Holding the shift key when I click reply makes no difference. SOLUTION! I HAD TICKED SAME REPLY FORMAT IN QUOTE AND COMPOSE MANAGER! Thanks

Okulungisiwe ngu hifromnz

user01229325 2241 izisombululo 10216 izimpendulo
Kuphostiwe

Interesting. I wonder what the difference is? I am still running version 24.6.

Interesting. I wonder what the difference is? I am still running version 24.6.
Zenos 2265 izisombululo 12258 izimpendulo
Kuphostiwe

I thought the Option item appeared only when you're already in HTML mode.

Hold down shift whilst clicking reply to open the Compose window in its alternative mode.

One of the Kaosmos add-ons (Quote And Compose Manager?) offers a setting to make HTML the default, rather than following the mode of the message being replied to.

https://nic-nac-project.org/~kaosmos/quoteandcomposemanager-en.html

I thought the Option item appeared only when you're already in HTML mode. Hold down shift whilst clicking reply to open the Compose window in its alternative mode. One of the Kaosmos add-ons (Quote And Compose Manager?) offers a setting to make HTML the default, rather than following the mode of the message being replied to. https://nic-nac-project.org/~kaosmos/quoteandcomposemanager-en.html