Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox cannot play mp4 files on windows 7

  • 11 uphendule
  • 36 zinale nkinga
  • 3094 views
  • Igcine ukuphendulwa ngu nancyjahn

more options

I'm using firefox 30 on Windows 7. I was under the impression Firefox supported mp4 playback in this configuration as described at https://developer.mozilla.org/en-US/docs/Web/HTML/Supported_media_formats but I can't get it to work anywhere.

webm and ogg theora work fine but mp4 playback doesn't. Some sites I've tested: http://www.quirksmode.org/html5/tests/video.html - top video does not load www.quirksmode.org/html5/tests/video.html - left side videos do not load https://vine.co/ - video playback fails completley youtube with html5 player- video playback fails completely

Does anyone have any solutions?

All Replies (11)

more options

Do you have a Windows version that comes with Windows Media Foundation and this enabled?

You can also check these prefs on the about:config page.

  • media.windows-media-foundation.enabled
  • media.directshow.enabled
more options

thanks for your response

I am using Windows 7 Ultimate which has windows media foundation to my knowledge.

both media.windows-media-foundation.enabled and media.directshow.enabled are set yo true

more options

You can open the Web Console (Firefox/Tools > Web Developer) and check for issues with loaded media files.

more options

To rule out extensions as a possible culprit, could you try the test pages in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions, some advanced features, and some custom settings. More info: Diagnose Firefox issues using Troubleshoot Mode.

You can restart Firefox in Safe Mode using either

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

Note: Flash and other plugins still run

After Firefox closes, a small dialog should appear: click "Start in Safe Mode" (not Reset)

Any difference?

more options

With the last Firefox upgrade, some plugins are no longer enabled until you enable it.

Open the Add-ons Manager. Press the <Alt> or <F10> key to bring up the tool bar. Followed by;

Tools' Add-ons.

Hot key; <Control> (Mac: <Command>) <Shift> A)

On the left side of the page, select Plugins.

BTW; At the top right is a link to check your plugins.

Okulungisiwe ngu James

more options

In the console I see this for each video: Media resource <file path> could not be decoded.

Starting in safe mode gives the same result. I've tried enabling/disabling all browser plugins and also disabling plugin scanning but I get the same error regardless.

more options

Are you using any kind of blocking software in Firefox or your computer?

more options

No blocking software, all addons/plugins disabled and still the same problem.

more options

It is likely that you do not have the codec to play such a file via the HTML5 media player.

Does Firefox use another player if you disable the HTML5 media player?

As a test you can disable the HTML5 media player by toggling these prefs to false on the about:config page.

  • media.directshow.enabled
  • media.windows-media-foundation.enabled
more options

Firefox uses flash when those settings are disabled.

Is there a way to install the codec? I thought Firefox could play mp4 on Windows 7.

Okulungisiwe ngu homunyan

more options

Maybe your mp4 file has some problem. You can try another mp4 file to have a test. Change your mp4 file to webm also is fine to have a try. http://www.firecoresoft.com/convert-mp4/convert-mp4-to-webm.html