Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Autocomplete/Autofill passwords stopped working after Firefox 30 update

  • 13 uphendule
  • 59 zinale nkinga
  • 3 views
  • Igcine ukuphendulwa ngu shape5

more options

after updating, sites that have autocomplete set to "off" no longer fill in passwords even though the autocomplete prefs in about:config are still set to "true". everything was working fine before updating to Firefox 30.

does this have something to do with it?

i'm unable to view "bug 956906" if i click on the link. [update: if i copy/paste the link into a new tab it loads fine - strange.]

thanks

Okulungisiwe ngu shape5

All Replies (13)

more options

You should be able to view the bug. It is however effectively closed for comments.

There may have been site changes,or the Firefox change could have had unexpected consequences with some sites.

The intention of the change is that password completion should be possible. Note this is with passwords that are stored in the password manager.

I will repeat one of the bug comments here

Summary of the change, so people don't have to wade through a long discussion:

- This change makes it so that `autocomplete=off` does not stop the Password Manager from working. Normal form autofill can be disabled as usual.
- The password manager *always* prompts if it wants to save a password. Passwords are not saved without permission from the user.
- We are the third browser to implement this change, after IE and Chrome.
- This can be undone locally by flipping the `signon.storeWhenAutocompleteOff` pref (from about:config) off.
- The rationale behind this change was the widespread abuse of the `autocomplete` attribute to prevent password saving where no prevention is required. This change gives users full control over password saving, without compromising on security (again, the user is always prompted). 

It may be rather difficult to test problems with this as private sites are involved, but what happens on the current forum ? You need a password and a login to post on this forum can you login ok here using the password manager ?

more options

Note that this is only about Firefox asking to store a new password in the Password Manager and not about filling this stored data automatically on a next visit. I've seen more reports that Firefox isn't filling this data automatically when autocomplete="off" is being used if the web form.

What prefs(s) are you talking about? See also:

  • Bug 946549 - Remove dead code obsoleted by bug 355063 to fill passwords on load
more options

if i click on that bug link, the page doesn't load - no response. but if i copy/paste it into a new tab then it does actually load. strange. looks like it was fixed. but it's definitely not working after the update to v30. and yes, these sites are saved in password manager, and they autocompleted just before updating to 30.

yes, logging into this forum is fine. it saves my login info everytime. it only happens on sites that have it set to autocomplete=off b/c those same sites did not work before i changed 'signon.overrideAutocomplete' pref to true, like bank and credit card sites. after changing this to true they filled in the pw data, after upgrading to v30, they no longer fill in the pw data saved in password manager.

the autocomplete prefs meaning that if i search for 'autocomplete' in about:config, all of the prefs that have a true/false option are set to true. as default they were set to true, except 'signon.overrideAutocomplete' which i changed to true upon suggestion in order to make autocomplete work in the first place.

yes, this topic seems to cover my issue: https://support.mozilla.org/questions/1005673

more options

There is something wrong with "passwords" in Nightly. I can no longer use it.

off-topic for a discussion about Firefox 30 - moderator edited this posting

Okulungisiwe ngu the-edmeister

more options

Firefox 32 and later builds store the passwords in the logins.json file in the profile folder.

You can try to force Firefox to reimport the passwords from the signons.sqlite file.

  • reset the signon.importedFromSqlite pref on the about:config page to the default value via the right-click context menu
  • delete the logins.json file in the Firefox profile folder with Firefox closed

When you restart Firefox then you should have the signon.importedFromSqlite pref with the value set to true.

Okulungisiwe ngu cor-el

more options

is the default value true for signon.importedFromSqlite? mine was set to this already and i have not changed it before.

i tried closing FF Nightly, deleting the logins.json file, relaunching FF Nightly (v33.0a1), loaded sites with login screens, and they still would not autofill passwords. same behavior as before.

also, does anyone know what these new config files are in about:config?

  • dom.forms.autocomplete.experimental
  • dom.forms.requestAutocomplete

Okulungisiwe ngu shape5

more options
more options

I have what appears to be a similar problem (not sure if it needs a new thread or not). Since update to FF30 (I think this is when it started, tho it's possible it's some time later than that, i.e., that instead an add-on update is messing with me), my save passwords option is turned off, and autocomplete doesn't seem to be working either. When I go into Tools|Options|Security, or through about:config to the signon.RememberSignons setting, either one, I find the setting for remembering passwords to be turned off, When I set it to true, however, that doesn't stick. As soon as I actually do anything - eg reload a tab, open a new one, etc. - it reverts to false. Sometimes it seems I don't even have to actively do anything at all - I can sit and look at the about:config file, seeing it the setting be true, and all of a sudden the page will refresh and the setting is back to false, without my having done anything (though there are some autoactions happening in various loaded tabs). Any thoughts? Anyone else having this trouble that the setting won't stick?

more options

Never mind, I withdraw the question. Turned out to be the FastAccess (a login security program) plugin was doing it, they just updated it to make it work with FF, which it's not for some time, and apparently one of the things they did in addition to just making FA's own password management functional.again was also make it actively turn off FF's password and user ID remembering, Sorry for any inconvenience.

Okulungisiwe ngu mtpmd

more options

Hi, Yesterday, my ubuntu 14.04 upgraded firefox to version 32, since that upgrade none of my remembered passwords form will fill anything, not even the google accounts page!

Followed instructions from cor-el to reset logins.json but no luck.

Really need some help on this! souch a basic feature may never be broken...at all!

Thanks!

more options

Well, spoke too soon, in my case, it was a conflicting extension called "Super Start" that caused the issue...after a lot of tryal and error disabling and enabling extensions and testing on dozens of sites, I get to the conclusion that in my case, that was te issue.

Uninstalling "Super Start" solved the issue for me.

This is the extension URL https://addons.mozilla.org/es/firefox/addon/super-start/

more options

For those who have problems: Go to Extras, Preferences, Security and check if "save passwords" is checked. The flag might have been lost up update. In that case just tick the checkbox and it will work again. Please note that if the checkbox is not checked, FF will neither store new passwords nor fill in passwords that have already been collected.

more options

thanks for the suggestion but this doesn't actually relate to the problem in my case. that pref has been checked all along. also, it's saving passwords fine - the passwords are stored ok on these sites that have autocomplete set to OFF but they can only be filled in by first entering the username. on sites that don't have autocomplete set to OFF, both the user+pw fields are filled in automatically.

if i search for 'autocomplete' on the about:config page, everything that can be is set to true.