X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Despite setting History settings to all history and all data, Firefox does clear all history. After quitting I find last session can be restored.

Kuphostiwe

My Clear History settings are all checked, yet when I quit FF my history is not cleared. Additionally, FF hangs up and I must quit manually, but wouldn't expect manually quitting to overcome history settings.

After quitting whether manually or on the occasion FF does fulfill the quit command, I find I am able to restore the last session.

Is this a bug in FF, an incompatibility with MAC OS 10.6.8, or something else? I have not found my question answered sufficiently in the forum where a similar question was asked.

My Clear History settings are all checked, yet when I quit FF my history is not cleared. Additionally, FF hangs up and I must quit manually, but wouldn't expect manually quitting to overcome history settings. After quitting whether manually or on the occasion FF does fulfill the quit command, I find I am able to restore the last session. Is this a bug in FF, an incompatibility with MAC OS 10.6.8, or something else? I have not found my question answered sufficiently in the forum where a similar question was asked.

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • Shockwave Flash 13.0 r0
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • iPhoto6

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:29.0) Gecko/20100101 Firefox/29.0

Eminye Imininingwane

FredMcD
  • Top 10 Contributor
4229 izisombululo 59021 izimpendulo
Kuphostiwe

Impendulo Ewusizo

From what I have been reading from other posts on this forum, the issue may be caused by the clear history settings.

Press the <Alt> or <F10> key to bring up the tool bar. Then Tools > Options > Privacy. The button next to History, select Use Custom Settings.

At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

From what I have been reading from other posts on this forum, the issue may be caused by the clear history settings. Press the '''<Alt>''' or '''<F10>''' key to bring up the tool bar. Then '''Tools > Options > Privacy'''. The button next to '''History''', select '''Use Custom Settings'''. At the bottom of the page, turn on '''Clear History When Firefox Closes.''' At the far right, press the '''Settings''' button. Turn on ONLY '''Cache''' and '''Form And Search History''' leaving the others off.

Umnikazi wombuzo

FredMcD, thank you for your reply. My question omitted the word "not" between does and clear - Firefox does not clear history as I wish, and as the previous iteration of FF did.

My settings are to automatically clear all history and data - yet upon quitting FF and restarting it, I find last session history has been saved. Also, FF 29.0.1 hangs up more often than not when quitting, such that I must force quit.

As you can see from the attached screen shots, I have all my settings properly chosen, yet FF ignores them.

Thanks so much for taking a look this.

FredMcD, thank you for your reply. My question omitted the word "not" between does and clear - Firefox does '''not''' clear history as I wish, and as the previous iteration of FF did. My settings are to automatically clear all history and data - yet upon quitting FF and restarting it, I find last session history has been saved. Also, FF 29.0.1 hangs up more often than not when quitting, such that I must force quit. As you can see from the attached screen shots, I have all my settings properly chosen, yet FF ignores them. Thanks so much for taking a look this.
FredMcD
  • Top 10 Contributor
4229 izisombululo 59021 izimpendulo
Kuphostiwe

Because of a bug, Firefox has problems closing using the settings you are using now. If you change them to my previous post, FF should close properly.

Wait for the next upgrade that is suppose to fix this. Meanwhile, you can go to the Mozilla Add-ons Web Page {web link} (There’s a lot of good stuff here) and search for clear history.

Because of a bug, Firefox has problems closing using the settings you are using now. If you change them to my previous post, FF should close properly. Wait for the next upgrade that is suppose to fix this. Meanwhile, you can go to the '''''[https://addons.mozilla.org/en-US/firefox/ Mozilla Add-ons Web Page]''''' {web link} (There’s a lot of good stuff here) and search for ''clear history''.

Umnikazi wombuzo

Thank you FredMcD for your kind assistance. I have tried the settings you suggested to no avail. I even tried choosing the Private Browsing mode and that didn't solve the problem either. As a result I decided to uninstall F29 and use F28 instead, the version I had no problems with.

I realize there are a few security issues with F28, but those are less disturbing to me than the very many problems with F29 that make it so inconvenient to me that I considered going back to Safari - eek!. As long as Mozilla intends to fix the bugs in F29 I'll wait and check it out when it's ready.

Meanwhile, I'll voice my concerns to Mozilla about F29, adding I believe to other users' complaints about this newest version.

Again, thank you very much.

Thank you FredMcD for your kind assistance. I have tried the settings you suggested to no avail. I even tried choosing the Private Browsing mode and that didn't solve the problem either. As a result I decided to uninstall F29 and use F28 instead, the version I had no problems with. I realize there are a few security issues with F28, but those are less disturbing to me than the very many problems with F29 that make it so inconvenient to me that I considered going back to Safari - eek!. As long as Mozilla intends to fix the bugs in F29 I'll wait and check it out when it's ready. Meanwhile, I'll voice my concerns to Mozilla about F29, adding I believe to other users' complaints about this newest version. Again, thank you very much.
FredMcD
  • Top 10 Contributor
4229 izisombululo 59021 izimpendulo
Kuphostiwe

I'm sorry I could not help you more.

I'm sorry I could not help you more.