Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwavalwa lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Firefox from F-Droid on Replicant Android not responding on launch

more options

Even after uninstalling and reinstalling, Firefox for Android from F-Droid on Replicant on Samsung Galaxy Tab 2 7.0 won't work at all. On launch it gives a message box "Firefox is not responding. Would you like to close it? [Wait] [OK]" so I can't even change any settings or go to any URL, even an about: URL. It once worked on this device and version of Replicant. I'm wondering if there are files I need to manually delete that may remain after uninstalling and cause the problem? Any help much appreciated!

Isisombululo esikhethiwe

I found the answer, which is specific to Replicant Android:

http://redmine.replicant.us/boards/9/topics/855?r=4983

Funda le mpendulo ngokuhambisana nalesi sihloko 👍 0

All Replies (6)

more options
more options

Thanks but I don't have Google Play on this device. The point of the Replicant version of Android is that it is entirely free and open source software - nothing proprietary. F-Droid is its alternative to Google Play and has versions 27, 28, and 29 of Firefox.

Additional information is that versions 28 and 29 have this problem, but version 27 has a different problem - pages supposedly load but display as entirely blank, although they are actually shown correctly in the thumbnails on "top sites".

more options

Download from Firefox FTP - http://ftp.mozilla.org/pub/mozilla.org/mobile/releases/29.0/

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. The Firefox cache temporarily stores images, scripts, and other parts of websites while you are browsing.
Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies, do the following:

  1. Tap the menu icon located at the top right corner. This is the icon with 3 bars. On older Android devices you'll have to press the hardware menu key and then tap More.
  2. Tap Settings.
  3. After that, you will be taken to the settings screen. In the settings screen, look under the section Privacy & Security and select Clear private data.
  4. You will then be taken to a list of what can be cleared. Select the following 2 for deletion:
    • Cookies & active logins
    • Cache
  5. After those have been selected, tap the Clear data button to actually clear the cache and cookies.


Did this help you with your problems? Please let us know!

more options

I tried the direct download from Firefox FTP and had the same problem. With versions 28 and 29 I cannot access Settings because Firefox goes into "not responding" immediately on launch. However, I have now tried clearing its data through the Android Settings / Apps, and that did not help either.

Is there any more complete way I can uninstall it so it's truly the same as if I'd never installed it at all on this device? I can use file manager as root, so I could delete any files that may be left over if I knew their location.

(With version 27, I tried "Clear private data" and that did not help with the problem of everything being displayed as a blank page. In version 27, the pages are loading but not displaying. I can even select text on the page, and save the page as a PDF. It's just that nothing on the page is visible in the browser.)

more options

Isisombululo Esikhethiwe

I found the answer, which is specific to Replicant Android:

http://redmine.replicant.us/boards/9/topics/855?r=4983

more options

Since Siep found an answer (and it's a replicate bug in its graphic drivers not a Firefox one), I am locking this question.