Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Flash is up-to-date, but Plugin won't work

  • 7 uphendule
  • 15 zinale nkinga
  • 1527 views
  • Igcine ukuphendulwa ngu Trishwish

more options

Hi! I'm using Firefox 29.0.1 on Windows 8, (also up-to-date), and Flash plug-in won't work. I re-downloaded & installed Adobe Flash 13.0.0.214...I verified it on their website, but I can't get the plugin to work. I had no problem with it earlier today, but for some reason it won't work anymore. PLEASE HELP! Thank you, Nuts4Mutts  :(

All Replies (7)

more options

Hello,

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.

more options

Hi, I tried to follow your instructions, but when I get the Flash "Settings" box it's on the amount of storage tab & no matter how many times I tried to change the tab to the one you indicated it won't change! The only way I can get rid of the "Settings" box is to refresh the page...I cant even get the box to close! Any suggestions...I'm desperate! Thanks again for your help! Nuts4Mutts :(

more options

Does the Adobe test page confirm that the Flash plugin is installed?


If you use extension (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extension aren't blocking content.

Start Firefox in Safe Mode to check if one of the extension (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Hi! Yes, I checked on Adobe's site THREE TIMES & I have the latest version, & the animations they have on their site worked fine...I saw them perfectly, (both the red cube bouncing around & the cartoon tree with the animated yellow & orange colored leaves). I'm at a loss why on most sites I have no problem watching streaming video, but on 2 of the other sites that I watch EVERY day, I suddenly get the "Error loading plugin" message on a black screen. It's driving me nuts, as I was watching these sites earlier this morning & everything was fine. The confusing part, to me at least, is why is this plug-in problem is ONLY affecting 2 of the sites I watch AND why did it happen out of the blue...I was watching them without any problem early this morning, just like I do ALL DAY...EVERY DAY!!! (I watch several wildlife live-cams, so it's important that I keep up with changes in the birds I normally watch). None of the other sites I watch are affected...what would cause this to happen? I even did a complete shut-down of my laptop, waited, then re-started. Usually, this would fix just about anything...for some reason, I can't get the video stream on 2 cams...I can still view the other cams I watch, though. I DID install MS's weekly updates, but it didn't affect my ability to see streaming video on most of the sites I watch; so far only on 2 of them. I only have the pop-up blocker that comes with Firefox, but other than that there's nothing else in my add-ons that could interfere. I checked my plugins several times, just to make sure Flash was up-to-date & they're fine, too. The mystery is why I can see my wildlife cams on 4 of the sites I watch but not on the other 2, especially when I was watching them early this morning!!! I feel like I've been dropped-off in some sort of cyber-space time warp, or in the twilight zone & I'm ready to scream! If there are any other suggestions, please post them...I'm very behind in my cam-watching! On another Firefox-related problem...where do I post a question about some add-ons not working or being visible AND not being able to customize since the last update? I know...I'm just having a very confusing, frustrating day! Thanks again for your ideas...I need all the help I can get! Nuts4Mutts :(

more options

Your System Details list shows the Ghostery 5.2.1 extension, so you need to make sure that this extension isn't blocking content.

more options

Hi! I haven't made ANY changes to my system that would explain why suddenly I can't view streaming video that I WAS watching. That's the "mystery". Any extensions or add-ons that were in effect are the same, so disabling anything, especially when live, streaming content is available on other sites, would be unnecessary. As far as Ghostery, I've been using it for years, AND it was enabled this morning, (and for years prior), when there was no issue with the Flash plug-in, AND it doesn't cause this problem on all the other sites I use to view wildlife cams. My question is why is the plug-in only an issue on certain sites when everything is the same & everything is up-to-date?

more options

Okay, this was driving me crazy as well. Out of nowhere, flash was not working properly. I tried everything. I uninstalled shockwave and abobe flash multiple times and reinstalled. I researched online for hours trying to figure out what could be causing it. The main thing is that video was not working on Facebook or Youtube. I did some more research, and came upon the suggestion that the flash plug-in may need to be manually installed. I went to the Adobe Flash Player Distribution page at http://www.adobe.com/products/flashplayer/distribution3.html and I downloaded and installed both the EXE and the MSI Installer for plug-in based browsers. I restarted Firefox, and boom, everything worked fine! I hope this helps people and prevents you the hours of frustration I went through!