Firefox keeps redirecting http to https, and I need to tell it not to for a specific site

I have an ssh tunnel that I am using to access an AWS ElasticSearch instance running in AWS, so that I can see Kibana in my browser. The tunnel is necessary because acce… (閱讀更多)

I have an ssh tunnel that I am using to access an AWS ElasticSearch instance running in AWS, so that I can see Kibana in my browser. The tunnel is necessary because access is only allowed through a specific jump/gateway host that we have setup (this is very standard).

I used to be able to access this just fine with http://localhost:9200/_plugin/kibana But then ElasticSearch updated something to require that the 'HOST' header contain the original host, ie: search-blahblahblahblah.us-east-1.es.amazonaws.com

Ok, no matter, I'll just add an entry to my hosts file: 127.0.0.1 search-blahblahblahblah.us-east-1.es.amazonaws.com

Now, I can curl just fine, and using Chrome works just fine too: http://search-blahblahblahblah.us-east-1.es.amazonaws.com:9200/_plugin/kibana

But every time I try to use Firefox, it replaces the http with https, which obviously doesn't work because the tunnel is to port 80.


Yes, I realize that *.amazonaws.com is owned by Amazon and they have an SSL cert.

I have read a similar ticket, here: https://support.mozilla.org/en-US/questions/1209387 The acceptable answer in that ticket seemed to be to use a different domain for local development, which shouldn't be too hard to do, but in my case this is not a usable answer.

I should be able to override Firefox and tell it not to change a URL that I have put into it, at least for specific sites.

veqryn 於 4 天前 詢問

veqryn 最近回覆 於 4 天前

Facebook and/or firefox issue

All was good until sometime today. FF 84.0.2 W10 up to date. Previously, when browsing FB marketplace, i could send a message about an item for sale. That send messag… (閱讀更多)

All was good until sometime today. FF 84.0.2 W10 up to date. Previously, when browsing FB marketplace, i could send a message about an item for sale. That send message button is now greyed out. The messenger button on the top right of my screen used to open a dropdown/popup that gave me a summary of my messages. That no longer works. I have been thru all kinds of settings randomly on FF and FB to try and correct the issue but i cannot figure out what is going on. I have tried turning Ublock on and off but that has not helped either. The only access i now have to messenger is to open it separately. I have not changed any FB settings. I did not change any FF settings myself other than trying to find out what could be doing this and exploring ublock for possibilities as that seemed the most likely culprit. Can anyone shed some light on what the issue is.

callwill 於 2 天前 詢問

callwill 最近回覆 於 1 天前