How to disable SafeSearch

Hi My government has enabled SafeSearch over our internet. we cant disable or turn it off. we had a solution to disable it by changing DNS in our browsers to CloudFlare.… (閱讀更多)

Hi My government has enabled SafeSearch over our internet. we cant disable or turn it off.

we had a solution to disable it by changing DNS in our browsers to CloudFlare. but unfortunately, it's not working anymore, so the SafeSearch is back online again...

now, how can we disable it?

A.R.B.N 於 1 小時前 詢問

I need to hide my email from the right side menu.

I've the same problem as https://support.mozilla.org/bm/questions/1317794#question-reply but after following the steps for the solution, it doesn't work for me. Does it h… (閱讀更多)

I've the same problem as https://support.mozilla.org/bm/questions/1317794#question-reply but after following the steps for the solution, it doesn't work for me. Does it have to do with all updates since this question was answered? I've created the chrome folder. I've created userChrome.css file and added the following without "`" marks in it and saved it and restarted firefox after changing the toolkit.legacyUserProfileCustomizations.stylesheets = true . ``` @namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

  1. appMenu-fxa-label > .toolbarbutton-text { visibility:hidden !important; }

```

It doesn't work for me. Please have a look.

r33sch 於 1 小時前 詢問

Site not recognizing my browser, even after registering it

Because of ongoing long-covid I have a couple of websites that I log into for medical purposes on a regular basis. I have registered this laptop through Firefox, and yet … (閱讀更多)

Because of ongoing long-covid I have a couple of websites that I log into for medical purposes on a regular basis. I have registered this laptop through Firefox, and yet I still need to get a code from them every time. I have Browser Privacy set to Standard; Delete Cookies and Site Data box is unchecked; Firefox will Remember History. What am I missing? Also, I use ExpressVPN. Might this be the culprit? If so, I will live with the 2FA. I realize this is health data, but the sites do offer to register my device and it never leaves the house.

Many thanks!!

Art 於 15 小時前 詢問

Problem with my bank 2FA and firefox

Am using FF 109.01 (64) and the latest Windows 10 (64) ver. I uses their Virus program. With my bank security settings I have check marked to not use 2FA Bank home page… (閱讀更多)

Am using FF 109.01 (64) and the latest Windows 10 (64) ver. I uses their Virus program.

With my bank security settings I have check marked to not use 2FA Bank home page asks for a security code anyway.

This has happened to me months ago and all of a sudden everything was OK. ... and now it has happened again. When I use Edge, Bank home page does not ask for a security code. This is the way I would like FF to perform.

I have phoned the Bank IT Help desk and they are bafflled. They had me try a bunch of acrobats but nothing works.

Obviously there is something in FF to tweak. I am using

I have searched and searched on internet, but no solution. I have used FF since it was a baby, and I want to stick with it. Thanks

tsb 於 2 天前 詢問

tsb 最近回覆於 19 小時前

Fingerprinting - Websites Detecting Multiple OS - (false positives)

There should be a guide by now or easy settings built into the browser to change these settings. I'm having trouble with websites that think I'm a Bot, because they are … (閱讀更多)

There should be a guide by now or easy settings built into the browser to change these settings.

I'm having trouble with websites that think I'm a Bot, because they are detecting multiple operating systems/ OS, due to my settings and privacy extensions.

Is there anything in About:Config that I can change to set my OS to Windows??

Common methods for websites detecting someone's OS is by using Javascript, User Agent, and TCP/IP fingerprinting.

How do I fake the Javascript test? There's extensions that block Scripts but that leaves people unable to use websites, is there any command I can put in and set as default?

User Agent test - There's a few extensions that will work to change this, though if I can change this through About:config or other settings I would like to know.

The TCP/IP protocol controls how data is sent between computers and how the sender and receiving computers are identified. Mostly this is done identically by every computer, but some small parameters are implemented differently by different operating systems, creating a ‘fingerprint’.

I'm told this is very difficult to fake, but has a larger error rate anyway.

RedFoX 於 2 天前 詢問

RedFoX 最近回覆於 1 天前

Local storage event listener not working in Firefox

I have a sandbox iframe which is hosted by various websites. Lets assume that this iframe is loaded like this: <script src="https://example.com/wie.js"></script… (閱讀更多)

I have a sandbox iframe which is hosted by various websites. Lets assume that this iframe is loaded like this: <script src="https://example.com/wie.js"></script> I have already added 'allow-scripts allow-forms allow-modals allow-same-origin allow-popups allow-popups-to-escape-sandbox allow-storage-access-by-user-activation' at sandbox. I also use document.requestStorageAccess() from inside the iframe and I set event listeners for the storage like this:

window.addEventListener('storage', onStorageFunc, false);. From the iframe a popup window is presented when user clicks a specific button and the popup opens at lets say at this url "https://paypal.com". After user navigation on popup, paypal at the end of the flow redirects user to this url "https://example.com/success". At this point when user is navigated to /success I add some data to local storage which I expect to trigger the storage event listener and the onStorageFunc to run. This doesn't happen, while in other browsers it works as expected.

Since both popup and iframe are under the same url (https://example.com) and I have used requestStorageAccess, I would expect this to work normally. Can you please help me to find out what is going wrong here? In the past I had the same problem but it was fixed when I added 'requestStorageAccess' and 'allow-storage-access-by-user-activation'. Now I can see it happening again.

wolfskinn 於 1 天前 詢問

wolfskinn 最近回覆於 1 天前

2FA login on web sites does not work with Firefox (Linux)

2FA login on sites works with Chromium but NOT WITH Firefox (Linux) Present setup: Does NOT work firefox 102.7.0esr on debian 11.6 bullseye 5.10.162-1 (x86-64) firefox … (閱讀更多)

2FA login on sites works with Chromium but NOT WITH Firefox (Linux)

Present setup:

Does NOT work firefox 102.7.0esr on debian 11.6 bullseye 5.10.162-1 (x86-64) firefox 110.0 on Ubuntu MATE 22.04 LTS 5.15.0-58 (x86-64)

Works chromium 109.0.5414.119 on debian 11.6 bullseye 5.10.162-1 (x86-64)

I am able to register and authenticate with security devices Yubikey NEO (without FIDO2) and Yubikey 5 NFC (FIDO2 compliant) on several sites (eg. pypi, google..) using Chrome or Chromium but now not with Firefox at all. It has not worked for at least the last few updates. Changing settings in about:config or plugging/unplugging keys, stopping every Firefox plugin etc. don't help. Neither does a fresh Firefox install without any super-security-settings.

Testing sites like Yubico's own or Okta's works fine using Chromium but not Firefox.

From what I can see this is not especially related to FIDO2 (Webauthn). pypi seems to use U2F which should work just fine with Firefox since way back.

I haven't tested Firefox for Windows but Chrome browser for Windows 10 works fine (which I tested first when Firefox didn't cut the mustard), I therefore expect it to work also on Chrome browser for Linux. Just to check if this was related to a debian bullseye package, I tested it on Ubuntu MATE too, which didn't do the trick. Haven't done any more testing than that on MATE.

This seems like a strictly firefox problem. -What to do?

Yours, Kaare

kaare 於 1 天前 詢問

Firefox flooding event log with connection errors at boot up

I was looking at my event log tracking down one issue when I noticed hundreds of audit failures (outbound connection blocked) in my event log. Firefox is not even runni… (閱讀更多)

I was looking at my event log tracking down one issue when I noticed hundreds of audit failures (outbound connection blocked) in my event log.

Firefox is not even running. I've just started my computer. It's trying to make a connection to google @ 34.107.221.82.

Fortunately something is blocking the connection attempt, but why is Firefox making hundreds of connection attempts when I haven't even opened firefox? How do I stop it?

I looked in task scheduler and couldn't see anything there. Looked at group policy, couldn't see anything there.

FF91.13.0esr

citizen1138x 於 3 週前 詢問

citizen1138x 最近回覆於 2 天前

what prevents from accessing the site https://www.googleadservices.com/

Regardless of the OS or Browser , trying to access the site https://www.googleadservices.com/ results with a failure described as "We can’t connect to the server at www.… (閱讀更多)

Regardless of the OS or Browser , trying to access the site https://www.googleadservices.com/ results with a failure described as "We can’t connect to the server at www.googleadservices.com."

Specifically this error message was just obtained on macOS Ventura 13.1 on my Intel based MacBook Pro using Firefox 109.0.1. It happens on all Windows machines I tried, on my iPad and iPhone.

I saw at least a million similar questions similar to this one, even more advices on how to address it - and no answer helps.

nik23 於 1 週前 詢問

nik23 最近回覆於 6 天前

Closing firefox window does not perform the settings actions specified "when Firefox is closed"

Former versions of Firefox browser for windows would treat closing the firefox windows as exiting the app. However in the current version, closing the windows does not ap… (閱讀更多)

Former versions of Firefox browser for windows would treat closing the firefox windows as exiting the app. However in the current version, closing the windows does not appear to perform the actions (such as clear cookies, site data, and history) that should occur when closing the browser. For example, I closed the browser window (X at top right of window) with a gmail account logged in and displaying the inbox. When I reopened Firefox, it did not go to my start url (gmail login), instead, it returned to my email inbox, and the email was active - logged in. This seems like a security problem to me. My settings specify: Delete cookies and site data when firefox is closed Clear history when Firefox closes I have no saved passwords in Firefox

joenuke981 於 6 天前 詢問