顯示問題標籤 顯示所有問題
  • 封存

Proxy authentication (Zscaler) and Firefox Sync

Hallo, my company's network as been recently upgraded with the Zscaler proxy solution. I was able to regain internet access by following that thread Firefox: This connect… (閱讀更多)

Hallo, my company's network as been recently upgraded with the Zscaler proxy solution. I was able to regain internet access by following that thread Firefox: This connection is untrusted + Behind corporate firewall (https://superuser.com/questions/115349/firefox-this-connection-is-untrusted-behind-corporate-firewall) . Unfortunately that dind't worked out for Firefox Sync. I'm able to log-in (verified by getting a mail from Firefox Accounts) but Firefox isn't stil able to sycn. I suspect that is somehow related to the certification signing process/getting token8gaining access what is properly blocked by zscaler:

Code:

   1443703953083  FirefoxAccounts ERROR   error POSTing /certificate/sign: {"code":401,"errno":109,"error":"Unauthorized","message":"Missing authentication","info":"https://github.com/mozilla/fxa-auth-server/blob/master/docs/api.md#response-format"}

Before FF 29 it seems it was possible to solve that issue see here: http://www.discourse.net/2010/12/how-to-solve-the-dreaded-firefox-sync-error-while-signing-in-problem/#comment-1358006

Asking IT to allow Firefox Sync/adding an exception is not an option. I'm glad that FF runs instead using the outdated IE 9. I'm fully aware of IT policies etc, that hasn't been a problem for some years.

PackElend 於 5 年前 詢問

PackElend 最近回覆 於 5 年前

  • 封存

I upgraded my computer to windows 8.1 and now the user accounts can't access https sites on forefox

I am using firefox 39, and I have tried the "netsh winsock reset" fix. It works fine on my admin account, but the user accounts cannot reach https sites. It also works i… (閱讀更多)

I am using firefox 39, and I have tried the "netsh winsock reset" fix. It works fine on my admin account, but the user accounts cannot reach https sites. It also works in IE.

david84 於 5 年前 詢問

FredMcD 最近回覆 於 5 年前

  • 封存

We have difficulty trying to connect to our server using a browser. Google Chrome can connect, but Mozilla Firefox cannot.

Problem: # We have difficulty trying to connect to our server using a browser. Google Chrome can connect, but Mozilla Firefox cannot. This problem is related to the "We… (閱讀更多)

  1. Problem: #

We have difficulty trying to connect to our server using a browser. Google Chrome can connect, but Mozilla Firefox cannot. This problem is related to the "Weak Diffie-Hellman and the Logjam Attack" (https://weakdh.org/)


  1. Activity log, sequence of actions we have conducted to try and fix the problem, and things we already know: #
1. Everything was fine
2. Firefox complained about the Weak Diffie-Hellman ephemeral key
3. Firefox can no longer access our server
4. But, Google Chrome CAN STILL access
5. Found out about "Weak Diffie-Hellman and the Logjam Attack"
   (https://weakdh.org/)
6. Tested Firefox using their website, and responded "Good News! Your browser is safe against the Logjam attack."
7. Tested Chrome using their website, and it responded that Chrome was vulnerable.
8. This explained why we could still access our server using Chrome
9. Updated Chrome to the latest version.
10. Tested Chrome using weakdh.org, and responded "Good News! Your
    browser is safe against the Logjam attack."
11. Tried accessing our site using Chrome, and it has the same error
    with Firefox.
12. Both Chrome and Firefox can no longer access the site at this
    point.
13. We followed the instruction located at
    https://weakdh.org/sysadmin.html for Apache Tomcat servers.

`ciphers="TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256,TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256,TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384,TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384,TLS_DHE_RSA_WITH_AES_128_GCM_SHA256,TLS_DHE_DSS_WITH_AES_128_GCM_SHA256,TLS_ECDHE_RSA_WITH_AES_128_SHA256,TLS_ECDHE_ECDSA_WITH_AES_128_SHA256,TLS_ECDHE_RSA_WITH_AES_128_SHA,TLS_ECDHE_ECDSA_WITH_AES_128_SHA,TLS_ECDHE_RSA_WITH_AES_256_SHA384,TLS_ECDHE_ECDSA_WITH_AES_256_SHA384,TLS_ECDHE_RSA_WITH_AES_256_SHA,TLS_ECDHE_ECDSA_WITH_AES_256_SHA,TLS_DHE_RSA_WITH_AES_128_SHA256,TLS_DHE_RSA_WITH_AES_128_SHA,TLS_DHE_DSS_WITH_AES_128_SHA256,TLS_DHE_RSA_WITH_AES_256_SHA256,TLS_DHE_DSS_WITH_AES_256_SHA,TLS_DHE_RSA_WITH_AES_256_SHA"`

14. Fix did not work both for Chrome and Firefox, still the same error.
15. We followed the instruction at
    http://stackoverflow.com/questions/30931692/diffie-hellman-public-key-error-with-tomcat-7

`ciphers="TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256,TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA,TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384,TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA,TLS_RSA_WITH_AES_128_CBC_SHA256,TLS_RSA_WITH_AES_128_CBC_SHA,TLS_RSA_WITH_AES_256_CBC_SHA256,TLS_RSA_WITH_AES_256_CBC_SHA"`

16. Fix WORKED for Chrome BUT NOT for Firefox.
17. Firefox has error code: ssl_error_bad_cert_alert
18. We experimented on lesser number of ciphers but none worked
19. `ciphers="TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256,TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA,TLS_RSA_WITH_AES_128_CBC_SHA256,TLS_RSA_WITH_AES_128_CBC_SHA"`
20. Same error for Firefox, still OK for Chrome.


  1. **TECHNICAL DETAILS** #
    1. Certificate: ##
   Signature algorithm: sha256RSA
   Signature hash algorithm: sha256
   Public key: RSA (2048 Bits)
   Thumbprint algorithm: sha1
    1. Environment: ##
   Apache Tomcat 6.0
   Java 1.6.0_34
    1. Current server configuration: ##
   <Connector port="443" SSLEnabled="true" maxThreads="150" scheme="https" 
   secure="true" clientAuth="true" sslProtocol="TLS" 
   keystoreFile="********.pfx" 
   keystoreType="PKCS12" 
   keystorePass="********" 
   ciphers="TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256,TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA,TLS_RSA_WITH_AES_128_CBC_SHA256,TLS_RSA_WITH_AES_128_CBC_SHA"/>

VicCebedo 於 5 年前 詢問

jscher2000 最近回覆 於 5 年前

  • 封存

2000 macs running firefox, need to add an exception to popup blocker or turn it off all together. this need to be done remotely. help.

i have 2000 macs in a k - 12 environment. i need to turn off firefox's popup blocker or just add an exception. this needs to be something that can be run remotely lik… (閱讀更多)

i have 2000 macs in a k - 12 environment. i need to turn off firefox's popup blocker or just add an exception. this needs to be something that can be run remotely like a script or something that could be deployed with casper or ARD.

thanks

wombatsandwich 於 5 年前 詢問

FredMcD 最近回覆 於 5 年前

  • 封存

firefox works at mcdonalds with windows but not with linux

I have Windows 7 Pro and Ubuntu 14.04 LTS on my laptop. I use firefox browser on both OS's. I am able to connect to internet when I use Windows OS and run firefox at Mc… (閱讀更多)

I have Windows 7 Pro and Ubuntu 14.04 LTS on my laptop. I use firefox browser on both OS's. I am able to connect to internet when I use Windows OS and run firefox at McDonalds. But, when I try to use firefox and Ubuntu OS it will not connect while at McDonalds. Otherwise, the Ubuntu distro and firefox work fine everywhere else.

bsluss 於 5 年前 詢問

bsluss 最近回覆 於 5 年前

  • 封存

Firefox disconnect from the internet- wont load pages

This is my second problem with Firefox, like my first, only happens on this computer and its driving me insane. Every now and again, in a seemingly random time, Firefox w… (閱讀更多)

This is my second problem with Firefox, like my first, only happens on this computer and its driving me insane. Every now and again, in a seemingly random time, Firefox will stop loading all web pages. It simply acts as though I am not connected to the internet. Everything else on my computer is connected to the internet but not Firefox. Restarting the browser fixes this until the next time it happens but it simply should not be happening in the first place.

My compute specs are: Windows 8.1 Pro x64

Intel i7-4500U

8GB of DDR3 @ 1600Mhz

Nvidia GeForce GT 745M

WD 750GB 7200RPM Scorpio Black

DeathShot 於 4 年前 詢問

DeathShot 最近回覆 於 4 年前

  • 封存

FireFox Is Dead: This 1 Will Stump You All!

Okay. Firefox quit loading web pages. Even saved ones. Chrome is fine on this workstation anf FF works just as blazing on my laptops and phone. I've done e-v-e-r-y singl… (閱讀更多)

Okay. Firefox quit loading web pages. Even saved ones. Chrome is fine on this workstation anf FF works just as blazing on my laptops and phone. I've done e-v-e-r-y single thing I could find on the web including reset, manually removing profiles, crawling the registry, installing and going after identified folders, clean reinstall, (clean except that all plug ins still show in the 'fresh' install while my add-ons (ABP, Ghostery, Scrapbook) are absent:

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can#firefox:winxp:fx35 https://support.mozilla.org/en-US/questions/956139 http://www.ghacks.net/2013/01/31/firefox-is-slow-try-these-fixes/

Also tried this reset via safe mode and apparently I only get a single chance to choose between Safe Mode and Reset Firefox because after getting the choices pop up as indicated the first time (I chose safe mode), I now am no longer 'allowed' to have the choice or enter safe mode! http://kb.mozillazine.org/Safe_Mode

Kind of "ARRGHHHHHH!" inducing..... NOTHING works. It is worse than dial up. I tried speedetest.net: It just pinged for ever. I've run PFPort Checker app (portforward.com) and it reports "Your port is not open or reachable!" even though Chrome and Thunderbird work. (tho Thunderbird is exhibiting it's own bug lately: The "You don't have enough space! Continue" and "You don't have admin privileges" scenario. Though, despite reading on the fixes, I've not bothered and just click "get mail" after that message window pops up.)

So yeah: Mozilla is REALLY banging me hard lately but I really need FF running in order to have my laptop synched and ready for work out in areas where I don't have web access... Anyone want to try something I've not already tried, multiple times, from those links? I dare ya's!

P

yowzarific 於 5 年前 詢問

FredMcD 最近回覆 於 5 年前

  • 封存

If I whitelist this URL my proxy "download-installer.cdn.mozilla.net".

I have users trying to download firefox updates, but they are being blocked by the proxy. If I whitelist download-installer.cdn.mozilla.net. Will that give users the ab… (閱讀更多)

I have users trying to download firefox updates, but they are being blocked by the proxy. If I whitelist download-installer.cdn.mozilla.net. Will that give users the ability to download other installs like add-ons?

lisser7 於 5 年前 詢問

guigs 最近回覆 於 5 年前

  • 封存

how do I stop the "Network connection" window from pooping up when I disconnect from wireless connected Internet

how do I stop the "Network connection" window from pooping up when I disconnect from wireless connected Internet Windows 7 Firefox 37.0.2 (could be the latest version as… (閱讀更多)

how do I stop the "Network connection" window from pooping up when I disconnect from wireless connected Internet


Windows 7 Firefox 37.0.2 (could be the latest version as 29 April 2015

dabatt 於 5 年前 詢問

FredMcD 最近回覆 於 5 年前

  • 封存

"A copy of Firefox is already open. Only one copy of Firefox can be open at a time." using mulitple logins

We use some dumb terminals to log multiple users onto a Windows Server machine. All the terminals login using the same account (and profile). However only one of the lo… (閱讀更多)

We use some dumb terminals to log multiple users onto a Windows Server machine. All the terminals login using the same account (and profile). However only one of the logins is able to use Firefox, everyone else gets the message saying its already open. We don't have any issues with IE, but... its IE... ugh.

Is there a way around this? I understand a lock file is created in the profile (which would then apply to all users logged in on that account). Is there a way to make them unique in some way? Please don't suggest we have to change browsers :(

SubaruImpreza 於 5 年前 詢問

cor-el 最近回覆 於 5 年前

  • 封存

FireFox is soooooooooooooo slow displaying pages on any and all websites

Basically it takes minutes to display a single page on any and all websites . Even Google Most of the time even after minutes of waiting , the page will display without i… (閱讀更多)

Basically it takes minutes to display a single page on any and all websites . Even Google Most of the time even after minutes of waiting , the page will display without images. I have to close and reopen FF to view that page and even that doesn't resolve the issue

mark7773 於 5 年前 詢問

mark7773 最近回覆 於 5 年前

  • 封存

Firefox Hangs when profile location is Offline Files

Hi all, We are having some problems with custom profile locations on windows 7 "C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -Profile "U:\Firefox\Profile" We use t… (閱讀更多)

Hi all,

We are having some problems with custom profile locations on windows 7

"C:\Program Files (x86)\Mozilla Firefox\firefox.exe" -Profile "U:\Firefox\Profile"

We use the above command to launch firefox. The u drive is a drive that is ALWAYS available for all users. This drive is redirected to the home folder of the user. To sync these folders we use Offline files.

During our testing fase we had no problems at all with this method. But in the last week we receive more and more people complaining that firefox hangs. (Read: no error specific error just stops responding and windows asks to close firefox) In my troubleshooting quest i found that as long as i don't use internet ( so not using our proxy server squid) it all works. But from the moment i try using for example google, firefox stops responding.

The tricky part is that sometimes it happens after 5 minutes, couple of hours, few days. Once it happened after 5 minutes, the only way to solve it is to delete the profile folder on the U Drive and start over.

So any help on identifying this problem is welcome. If more info is needed let me know what you need.

Michiel Cornille 於 5 年前 詢問

the-edmeister 最近回覆 於 5 年前

  • 封存

FF won't load. It asks for a user name to install then goes no where.

Am on a corporate laptop. Have always been able to load FF, IE, Chrome, etc., onto the laptop. FF stated an update was available, but when it tried to automatically upda… (閱讀更多)

Am on a corporate laptop. Have always been able to load FF, IE, Chrome, etc., onto the laptop. FF stated an update was available, but when it tried to automatically update, it kept saying that there was already another rev of FF in existence, so it would not load update. So I figured I would delete the old version and simply download the most current.

Wrong-o, Bucky. It gave me a "Run as...." window. Since I am not the corp Admin, I chose 'Current user (NAMCK\emxxxx'. I hit OK and it just does nothing. Zippo. Zilch. Nada. Less-than-none. Anyone have any ideas WHY this used to work, well, but is not working, NOW? I have using the other browsers, so sure hope some FF-smart person can provide a solution.

Much grass, Bill

bconde 於 5 年前 詢問

FredMcD 最近回覆 於 5 年前

  • 封存

can't get "watch espn" video to load or stream in firefox

Last week I was able to get the watch espn site to work fine in firefox. Now it just chugs on the loading circle in the pop up window. The only difference is that I updat… (閱讀更多)

Last week I was able to get the watch espn site to work fine in firefox. Now it just chugs on the loading circle in the pop up window. The only difference is that I updated to the newest version 40.0.3. It works in MS edge. yes I am a comcast subscriber.

congaman59 於 5 年前 詢問

FredMcD 最近回覆 於 5 年前

  • 封存

Recent versions of Firefox not working properly under Linux (Ubuntu 14.04) when $HOME is a NFS mounted file system

I am managing a group of network booted Ubuntu 14.04 workstations at a small town (public) library and the current version of Firefox for Ubuntu 14.04 crashes. The machi… (閱讀更多)

I am managing a group of network booted Ubuntu 14.04 workstations at a small town (public) library and the current version of Firefox for Ubuntu 14.04 crashes. The machine have all of the file systems NFS mounted. Installing an older version (Firefox 52.6.0 ESR) works however. The new version of Firefox works just fine on the pair library owned laptops, that also run Ubuntu 14.04, but the laptops are self-contained -- they boot off their local disks. Why is this? I have pretty much determined that the only definable issue is that the network booted machines are using NFS for their file systems. No, the workstations are not sharing logins -- each machine auto-logins to a *different* user, each with their own *separate* $HOME directory and they are *not* trying to share firefox configuration trees ($HOME/.mozilla/firefox/...). But all of these directories are NFS mounted. Oh, the server for the /home file system is running CentOS 6.

RobertHeller 於 2 年前 詢問

cor-el 最近回覆 於 2 年前

  • 封存

Firefox browser won't open and doesn't show in task manager

All of my browsers will not open, but Firefox is my main browser. I've tried pretty much everything to get it to work (re-install, start in safe mode, entered ping 4.2.2… (閱讀更多)

All of my browsers will not open, but Firefox is my main browser. I've tried pretty much everything to get it to work (re-install, start in safe mode, entered ping 4.2.2.2 then www.firefox.com into the command box thing - did this with all the browsers- but they all come back with not recognised as an internal or external command, operable program or batch file) . It just won't launch, and does not appear in task manager at all. I'm at a loss for what to do. Please help!

clobi89 於 5 年前 詢問

jscher2000 最近回覆 於 5 年前

  • 封存

Firefox keeps going into offline mode

Firefox goes into offline mode on a regular basis - not always, but usually several times per day. I've already set network.manage-offline-status to false (actually, it w… (閱讀更多)

Firefox goes into offline mode on a regular basis - not always, but usually several times per day. I've already set network.manage-offline-status to false (actually, it was already set that way when I checked it). It appears to happen more when I move off of a tab and then come back to it. I've uninstalled and wiped all traces for Firefox and re-installed - same result.

How can this mode be completely disabled?

delerium 於 5 年前 詢問

cor-el 最近回覆 於 5 年前

  • 封存

How to I set up Firefox to work with At&t u-verse high speed internet?

I just moved to At&t u-verse high speed internet service ... 48 Mbps. I've gone to the At&t web site and check the speed for download and upload, which are match… (閱讀更多)

I just moved to At&t u-verse high speed internet service ... 48 Mbps. I've gone to the At&t web site and check the speed for download and upload, which are matching or exceeding the 48 Mbps. I couldn't find any recommendations for setting up Firefox to work with at&t. However, web pages seem to load really slow for 48 Mbps. The Samsung web site is terrible ... it always times out before a page loads. Is there some preference settings I need to change under Advance > Network settings? I'm using an iMac with Mavericks 10.9.5, 64 GB memory and 1TB HD. Oh, At&t site did recommend not having two firewalls on at the same time. My at&t modem/router defaults to firewall on, so I turned of my max fire wall.

Thanks for your help in advance!

Dennis

zeetoe25 於 5 年前 詢問

FredMcD 最近回覆 於 5 年前

  • 封存

Installing and managing firefox in an enterprise environment using a third party desktop managment system (Novell ZEN)

We want to deploy Firefox in our enterprise environment and need to figure out a way to have the install run silently, no user interaction. We use Novell's ZEN to central… (閱讀更多)

We want to deploy Firefox in our enterprise environment and need to figure out a way to have the install run silently, no user interaction. We use Novell's ZEN to centrally manage our desktops and how we've done this with other installs is to create a response file, but I guess Firefox will not use response files. So, how would we accomplish this?

Any help would be greatly appreciated.

Ken

kenwmax 於 5 年前 詢問

guigs 最近回覆 於 5 年前

  • 封存

Application is not working as expected in firefox while in production

Hi, We are developing an application, In application we are showing a popup which consist checkboxs. User have to select a checkbox and click on continue. Based on select… (閱讀更多)

Hi, We are developing an application, In application we are showing a popup which consist checkboxs. User have to select a checkbox and click on continue. Based on selected checkbox, values are setting in page.

Issue : Application is working fine in all the browser in development region, but in production region after selecting a value when we click on continue, popup is opening again and doesn't take selection. Its happening only in Firefox and in Production Region.

Please review, any pointer to resolve this will be appreciated. Thanks


Vaibhav

vaibhav_NB 於 5 年前 詢問

guigs 最近回覆 於 5 年前