顯示問題標籤 顯示所有問題
  • 已解決
  • 封存

How do I fix incorrectly displaying fonts?

Some fonts aren't displayin correctly on webpages. Most noteably, in code boxes and stuff. Instead of legible text, all I see are shapes of triangles, squares, and stars.… (閱讀更多)

Some fonts aren't displayin correctly on webpages. Most noteably, in code boxes and stuff. Instead of legible text, all I see are shapes of triangles, squares, and stars.

Asked by jeff28 3 年前

Answered by jeff28 3 年前

  • 已解決
  • 封存

Why my default fonts in Firefox looks so ugly?

Why the default fonts are looking so ugly? It is working fine on Edge. I am on Windows 10. Please find the screenshots bellow. https://imgur.com/a/Gke2K … (閱讀更多)

Why the default fonts are looking so ugly? It is working fine on Edge. I am on Windows 10.

Please find the screenshots bellow.

https://imgur.com/a/Gke2K

Asked by iAmSaugata 2 年前

Answered by iAmSaugata 2 年前

  • 已解決
  • 封存

Font appears messed up only on Mozilla, only on one PC

Hello! So, I was working on a new blog on which I'm using the Rubik font from Google fonts. Everything was fine for several days, but today, after working for some time o… (閱讀更多)

Hello!

So, I was working on a new blog on which I'm using the Rubik font from Google fonts.

Everything was fine for several days, but today, after working for some time on it, the font just got messed up randomly (see attached image).

I added the font on a different, testing site and it shows messed up there as well, so it's not something website related.

Now, the shocking part is that it gets messed up only on Mozilla and only on the Mozilla browser that's on my Desktop PC.

I asked a friend to check it out and I also checked it out on my laptop, and the font is fine on other Mozilla browsers, as well as other browsers.

Other fonts from other websites are fine as well.

What troubleshooting I performed:

- Checked the font with Inspect Element, as it's shown here: https://developer.mozilla.org/en-US/docs/Tools/Page_Inspector/How_to/Edit_fonts and the font is set up correctly;

- Deleted the whole history since the beginning of time (cookies, cache, everything);

- Closed and opened Firefox again;

- Opened Mozilla in Safe Mode (hardware acceleration is disabled by default in safe mode);

- Restarted my PC;

- Uninstalled Mozilla as it shows here - https://support.mozilla.org/en-US/kb/uninstall-firefox-from-your-computer. Deleted the profile folder and everything.

- Installed a fresh copy again with no add-ons, no nothing.

Nothing worked. That font is still messed up on Mozilla, on this PC.

It doesn't make any sense, especially since it went nuts randomly without a particular reason.

Does anyone have an idea of what could be the problem and how to fix it?

Any help would be appreciated!

Thanks!

Asked by Radu_B 1 年前

Answered by jscher2000 1 年前

  • 已解決
  • 封存

Greek letters don't display anymore when I use fontname-"Symbol" in html/javascript. They work in Microsoft Edge.

I am writing code in javascript for astronomers and it uses symbol font for Greek letters. When I display the report on FireFox browser, the Greek letters do not appear … (閱讀更多)

I am writing code in javascript for astronomers and it uses symbol font for Greek letters. When I display the report on FireFox browser, the Greek letters do not appear instead they are in a different font. My report display fine with Microsoft Edge but I like FF better.

Asked by john02813 3 年前

Answered by cor-el 3 年前

  • 封存

fonts displaying as 'A' in a box

On lots of websites text appear as an 'A' in a box (see screenshot - i've blurred some content due to privacy). I've gone through my preferences and checked 'Allow pages … (閱讀更多)

On lots of websites text appear as an 'A' in a box (see screenshot - i've blurred some content due to privacy). I've gone through my preferences and checked 'Allow pages to choose their own fonts, instead of your selections above'. When I uncheck this box using my font selections things display fine however when I check it I get this problem. I'm a web developer so I can't override site fonts, I need them to display as intended. I've checked Chrome and Safari on my machine and they are fine so this problem is isolated to FireFox. I've tried restarting FF in safe mode but it made no difference, I went to the config page and changed network and gfx references back to 'reset' and again it doesn't make a difference.

System details: FF = 56.0 (64 bit) OSX = 10.9.5

Asked by sanch3z 2 年前

Last reply by cor-el 2 年前

  • 已解決
  • 封存

firefox blurry ui

hi windows xp and after update 51.0 any version will get a blurry user interface. see the attached screen shots I have toyed around with all the gfx.font_rendering.cleart… (閱讀更多)

hi

windows xp and after update 51.0 any version will get a blurry user interface. see the attached screen shots

I have toyed around with all the gfx.font_rendering.cleartype_params parameters to no avail.

blurry firefox windows xp

blurry firefox ui

blurry firefox

blurred firefox

Asked by NesteaZen 2 年前

Answered by philipp 2 年前

  • 已解決
  • 封存

unchecking "Allow pages to choose their own fonts, instead of your selections above" has no effect

MSI GE72 2QF Apache Pro notebook (stock) Windows 10 Pro Firefox 63.0.3 I recently reinstalled Windows 10 and Firefox. Before the reinstall, unchecking this box had an imm… (閱讀更多)

MSI GE72 2QF Apache Pro notebook (stock) Windows 10 Pro Firefox 63.0.3

I recently reinstalled Windows 10 and Firefox. Before the reinstall, unchecking this box had an immediate visible effect. Now, as can be seen in the screenshot, it doesn't.

So far I've tried: - "refreshing" Firefox to defaults and unchecking the box again, - going into "about:config" and changing the value of "browser.display.use_document_fonts" to "0"

Neither of these things worked.

On my other two computers, one of which was bought new less than three weeks ago, unchecking the box does what it's supposed to do.

Asked by rontarrant 1 年前

Answered by cor-el 1 年前

  • 已解決
  • 封存

secondary pages not displaying right fonts

Hello, I hope this is the right place to post this question. I apologize if it's not. Please tell me if I am posting in a wrong section. Firefox is not displaying right … (閱讀更多)

Hello, I hope this is the right place to post this question. I apologize if it's not. Please tell me if I am posting in a wrong section.

Firefox is not displaying right fonts on a site I am working on. • I am working with files locally on my Mac so I can't provide url. • I am using @font-face rule and index page displays the right fonts that are in my folders. I am not using link to Google. • Problem is that all the other pages display only default browser fonts. But all the other CSS styling, on those pages, works just fine. • My index page is in the root folder, fonts have their own folder, and all the other pages have their own folder.

   - root folder 
                       |- index.html
                       |- styles folder - css folder, etc…
                       |- media folder - fonts folder, etc…
                       |- pages folder - about.html, page2.html, etc…

• I have added fonts in ttf, woff, woff2, eot, and svg formats. Technically, I only care about at least making ttf files work. • I am using the latest Firefox. • I cleared all of the history. • And I tried Firefox in safe mode, so far nothing works.

Does anyone have any idea what am I doing wrong? I very much appreciate your help.

Asked by liamcoded 3 年前

Answered by liamcoded 3 年前

  • 封存

when I type to reply to email in my Gmail account the format of the text disappears

In the last month( i think after updating to frfx 58) when I type to reply to email in my Gmail account in my browser ( firefox 58.0.2) I get to see the standard formatti… (閱讀更多)

In the last month( i think after updating to frfx 58) when I type to reply to email in my Gmail account in my browser ( firefox 58.0.2) I get to see the standard formatting of the text (blue, comic sans etc) but when I actually send it, the sent email has the format disappeared and is standard format instead (in black plain font for example). This also happens in my other Gmail accounts too. I tried in MS IntExplorer and there is not a problem (meaning it is NOT my GMAIL's account settings)

Any suggestion/help?

Asked by akmsupport 2 年前

Last reply by guigs 2 年前

  • 已解決

Font rendering on a specific website

Hello, I have a trouble with font rendering on one specific website - https://www.checkpoint.com. Text on this site looks quite ugly (see font01.png). But if I open "Web … (閱讀更多)

Hello,

I have a trouble with font rendering on one specific website - https://www.checkpoint.com.

Text on this site looks quite ugly (see font01.png).

But if I open "Web Developer" -> "Inspector" -> "Fonts" -> "All fonts on page", then I can see the text renderred correctly in the preview field (see font02.png).

So text uses "DIN WXX Regular" font, but I do not understand, why Firefox cannot render it on the web page in the same manner as in the Developer tools?

Any clue how to fix it?

Browser: Firefox 68.2.0esr (64-bit) OS: Debian Bullseye

Thanks Zbynek

Asked by Zbynek Michl 5 個月前

Answered by Zbynek Michl 4 個月前

  • 封存

text get scrambled when scroling, and hover (firefox quantum 58.0b16)

I have noticed that on some page the text get scrambled when you hower over it, and text low on paget get scrambled. Ill attach a pictures to show you what i meen. Ill ha… (閱讀更多)

I have noticed that on some page the text get scrambled when you hower over it, and text low on paget get scrambled. Ill attach a pictures to show you what i meen. Ill have tryed with other browsers, and this problem does not appear on those. only with firefox quantum

Page you could explore to se this problem is (https://www.komplett.no/category/10111/datautstyr/pc-komponenter/hovedkort?nlevel=10000%C2%A728003%C2%A710111&hits=72)

try scrolling down the page, and hower over text.

Asked by plingplong 2 年前

Last reply by plingplong 1 年前

  • 封存

Firefox dont work normally

I cant say what is it but i cant use firefox at all. Some pages it open but some not, on google it works as it is shown in the picture. Please help i cant use another br… (閱讀更多)

I cant say what is it but i cant use firefox at all. Some pages it open but some not, on google it works as it is shown in the picture. Please help i cant use another browser. Thanks

Asked by Saki1015 2 年前

Last reply by Saki1015 2 年前

  • 封存

Greek font characters in website are not displayed properly, but when i refresh any page then Greek characters are displayed correctly

Hi everyone ! I'm currently using Mozilla Firefox v.49.0.2. I'm quite desperate after spending over 45 hours in working around to resolve the following specific problem t… (閱讀更多)

Hi everyone !

I'm currently using Mozilla Firefox v.49.0.2.

I'm quite desperate after spending over 45 hours in working around to resolve the following specific problem that's appeared only with Mozilla browser:

My website address is: "www.visvikisbarlou.gr/index.asp" The main page is loaded perfectly and shows Greek font text, but when i click-follow any of the menu links, the Greek font characters are shown in little boxes with hex code in all pages !

I would like to mention the following crucial facts: 1) This problem exists only with Mozilla. In Chrome and IE the Greek font characters are rendered perfectly in all pages. 2) If i reload any of the pages in Mozilla, then suddenly the page works and shows up the Greek font text ! It's really weird. 3) I've declared and <meta charset="windows-1253"> in the header of all pages and when i check the encoding in Mozilla browser it looks that Mozilla clearly understands that -Mozilla shows as encoding Greek (Windows) in all of my pages. But in the pages the Greek text is shown up as little boxes with hex code. 4) If i enter directly the address of a page e.g. http://www.visvikisbarlou.gr/news.asp then the page shows Greek characters correctly without any issue. I really can't figure out why this is happening. Any help on resolving this problem will be much appreciated !! Thanks everyone in advance. Kind regards, George

Asked by georgei13 3 年前

Last reply by georgei13 3 年前

  • 封存

Accented characters appear with extra accent mark: ´á ´é ´í ´ó ´ú (intermittently).

After Firefox has been open more than a few minutes, usually with at least two or three windows and/or tabs open, when I try to type accented characters (á, é, í, ó, ú Á … (閱讀更多)

After Firefox has been open more than a few minutes, usually with at least two or three windows and/or tabs open, when I try to type accented characters (á, é, í, ó, ú Á É Í Ó Ú) they come out with an extra accent mark preceding the accented letter (´á ´é ´í ´ó ´ú). I usually have a WebWhatsApp window open.

This doesn't happen in other browsers or other programs that take text.

At the same time, the Ctrl+F (for find) function stops working. If I close all of the windows, and attempt to reopen Firefox, I get an error that says that Firefox is still running, and do I want to close it? I say yes, and it closes. And for a short or longer while, the problems go away. Then they come back.


Using Spanish (Mexico) language and Latin American keyboard, with Español (Mexico) language pack installed.

Lenovo Flex 3 -1570 laptop, Windows 10 Home v. 1803 . Updated Firefox Quantum 66.0.5. Had Firefox "optimized" a few times by my Lenovo tech support subscription service. No effect.

Asked by bergepet 1 年前

Last reply by FredMcD 1 年前

  • 封存

Text not rendering properly on some websites

I know this question has been asked multiple times and it usually ends in the solution: Some font rendering issues are caused by graphics driver incompatibilities. Could… (閱讀更多)

I know this question has been asked multiple times and it usually ends in the solution: Some font rendering issues are caused by graphics driver incompatibilities. Could you try disabling Firefox's use of hardware graphics acceleration?

orange Firefox button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"


However my hardware acceleration has been disabled for a long time. I've had this problem for many months and every now and then it annoys me enough to search for solutions. I've tried increasing and changing the fonts in my Content Settings. I've uninstalled and reinstalled firefox. I've checked multiple websites fonts to see where it happens since it seems to pick and choose what sites it happens on. I've even cross checked sites on Google Chrome as well to verify that this only happens with Firefox.

This leads me to think there is a bigger problem/bug in play within Firefox's Rendering Engine, Gecko.

Asked by unscodst 3 年前

Last reply by unscodst 3 年前

  • 已解決
  • 封存

Firefox keeps crashing

Since a week I can no longer open firefox, without crashing. I have tried it several times in safe mode or to rebuild FF. Also a clean install did not work r may not impo… (閱讀更多)

Since a week I can no longer open firefox, without crashing. I have tried it several times in safe mode or to rebuild FF.

Also a clean install did not work r may not import data at the clean install, is all. To do this, I had my firefox profile and also the folder which was just created rebuilding FF. What can I do now to make sure I get it working again?

Asked by F33nstr2 4 年前

Answered by F33nstr2 4 年前

  • 已解決
  • 封存

One website has a menu that doesn't display the font correctly.

I believe I went through the list of prescribed solutions. Safe mode, cache cleaning, history, etc. Browser is up to date Windows is up to date Other browsers seem to di… (閱讀更多)

I believe I went through the list of prescribed solutions. Safe mode, cache cleaning, history, etc. Browser is up to date Windows is up to date Other browsers seem to display the website (and menu) just fine. Screenshot attached should show extra large menu items following "NEW". https://www.cabelas.ca/

Sorry for being a pain. :)

Asked by Douglas Dickson 1 年前

Answered by cor-el 1 年前

  • 封存

My fonts are getting displayed oversaturated only on Firefox, anyone knows how to fix this?

Hi, I'm just working on a new website, and I noticed something odd that happens only when I open the site via Firefox. On browsers like Safari and Chrome the rgb hex colo… (閱讀更多)

Hi, I'm just working on a new website, and I noticed something odd that happens only when I open the site via Firefox. On browsers like Safari and Chrome the rgb hex colour looks identical as in Adobe Photoshop or Apple Pages, where I created content, but Firefox seems to oversaturate the fonts quite nasty for some reason.

I attachted you a screenshot where it should be very visible. If this is a bug, is it possible to get this fixed soon? I don't really want to put a warning on my website for Firefox users if possible.

Asked by benjamin.kepinger 9 個月前

Last reply by cor-el 9 個月前