WebGL creation failed after reinstalling lbgl1* libegl*

I am using the apt version of firefox v125.0.2 (64-bit). I do not have a dedicated GPU - I use my intel core's internal gpu only Intel Corporation HD Graphics 620 (rev 02… (閱讀更多)

I am using the apt version of firefox v125.0.2 (64-bit). I do not have a dedicated GPU - I use my intel core's internal gpu only Intel Corporation HD Graphics 620 (rev 02).

I used to play this game named narrow.one, which before I reinstalled the mentioned libraries, was working fine except for crashing a few times. I thought these libraries were causing some issue, so I tried reinstalling them.

I reinstalled the libraries using: `sudo apt install --reinstall --fix-missing libgl1* libegl*`

After installation, I start getting that error. So, I tried reinstalling firefox (using the same command), and then restarting the laptop - but of no use. Chrome seems to be running WebGL, including the game.

In firefox, on the https://get.webgl.org/ page, I see Hmm. While your browser seems to support WebGL, it is disabled or unavailable. If possible, please ensure that you are running the latest drivers for your video card.

After that, I also tried reinstalling `libopengl0` and `libglu1-mesa` and `intel-microcode`, but of no use. Running although, `sudo intel_gpu_top` and then chrome, it seems that the GPU is in use by chrome as well.

I then go to about:support. It shows me the images I have attached. Reading the logs, there several `blocklisted` values in `Decision Log` section. I suspect that's the cause of this issue, but then I don't know how can I un-blocklist the blocklisted things, and even after that, why does Chrome runs webgl if these are blocklisted?

Running `glxinfo -B`, I get the following: `name of display: :0 display: :0 screen: 0 direct rendering: Yes Extended renderer info (GLX_MESA_query_renderer):

   Vendor: Intel (0x8086)
   Device: Mesa Intel(R) HD Graphics 620 (KBL GT2) (0x5916)
   Version: 23.2.1
   Accelerated: yes
   Video memory: 7697MB
   Unified memory: yes
   Preferred profile: core (0x1)
   Max core profile version: 4.6
   Max compat profile version: 4.6
   Max GLES1 profile version: 1.1
   Max GLES[23] profile version: 3.2

OpenGL vendor string: Intel OpenGL renderer string: Mesa Intel(R) HD Graphics 620 (KBL GT2) OpenGL core profile version string: 4.6 (Core Profile) Mesa 23.2.1-1ubuntu3.1 OpenGL core profile shading language version string: 4.60 OpenGL core profile context flags: (none) OpenGL core profile profile mask: core profile

OpenGL version string: 4.6 (Compatibility Profile) Mesa 23.2.1-1ubuntu3.1 OpenGL shading language version string: 4.60 OpenGL context flags: (none) OpenGL profile mask: compatibility profile

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 23.2.1-1ubuntu3.1 OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20`

I do not know much about OpenGL, but reading the above stuff, I suppose my GPU is in use and also has a compatible driver (although I am not sure).

Also, running `glxdemo`, `glxheads`, and `glxgears` seems to be rendering stuff.

Should I reinstall firefox after purging it first? Please help.

Thanks!

Lakshay Rohila 於 21 分鐘前 詢問

Deleted passwords are being restored

I have 3 computers (2 desktops, 1 laptop). I want to permanently delete approx 300 unused/unneeded passwords. I deleted them from computer #1, then logged out of Firefox… (閱讀更多)

I have 3 computers (2 desktops, 1 laptop). I want to permanently delete approx 300 unused/unneeded passwords. I deleted them from computer #1, then logged out of Firefox. The new count was 346 passwords.

I went to the second computer, deleted approx the same number from computer #2. The new count was 324 passwords I returned to computer # 1 and logged back into Firefox.

Within a short time, computer #1 is at 759 passwords, and computer 2 is at 691 passwords.

How do I get the deletions to be permanent? It's the second pass at doing this and I'm FRUSTRATED.

Steve Katz 於 22 分鐘前 詢問

Dont know why some pages shows me in russian language

Hello. I have put my language everywhere on the settings which is latvian. For possible translations i have only put english. Some pages, for example, whatsapp web is sho… (閱讀更多)

Hello. I have put my language everywhere on the settings which is latvian. For possible translations i have only put english. Some pages, for example, whatsapp web is showing in russian ( i mean the app data for sure, not the messages), also some homepages i use open automatically in russian. How can i put latvian by default or if its not available for the homepage, put english automatically?

Edgars Rudzītis 於 7 小時前 詢問

Edgars Rudzītis 最近回覆於 37 分鐘前

Connection failed ("Seiten-Ladefehler")

Hello everyone, since my last update (125.0.2 (64-bit)), an additional website always opens when I open a website in Firefox. This is called "Page load error" in the tab… (閱讀更多)

Hello everyone,

since my last update (125.0.2 (64-bit)), an additional website always opens when I open a website in Firefox. This is called "Page load error" in the tab; the content of the page is as follows:

Error: Connection failed

An error occurred while connecting to 0.0.0.1.

   The website may be temporarily unavailable, please try again later.
   If you are also unable to access another website, please check the network/Internet connection.
   If your computer or network is protected by a firewall or proxy, please make sure that Firefox is allowed to access the Internet.

How can I prevent this additional page from opening?

Thank you in advance for your help!

Greetings from Maria

maria.kageneck 於 58 分鐘前 詢問

Do you have the IBM Trusteer Rapport add on

I use the Rapport Add-on to protect my personal info especially when doing on-line banking at the moment I have to use Chrome but I would rather stay with Firefox but you… (閱讀更多)

I use the Rapport Add-on to protect my personal info especially when doing on-line banking at the moment I have to use Chrome but I would rather stay with Firefox but you dont have this extension why?

Chipeto 於 4 小時前 詢問

Chipeto 最近回覆於 1 小時前

PDF loading is very slow

I am using Firefox v125.0.2. When I open a PDF in Firefox it takes a lot of time to load. But, when the same PDF opened in the Edge browser it loads normally and scrollin… (閱讀更多)

I am using Firefox v125.0.2. When I open a PDF in Firefox it takes a lot of time to load. But, when the same PDF opened in the Edge browser it loads normally and scrolling through PDF pages renders fast. I have shared the screenshot of a single-page pdf loading taking quite a long time.

Could someone please help me with this.

avisekn 於 4 小時前 詢問

avisekn 最近回覆於 1 小時前

How to use Advanced Preferences (about:config) to select 'Manual proxy configuration' setting

I want to use the Advanced Preferences (about:config) to select 'Manual proxy configuration' setting. I have been able to set the HTTP Proxy and associated port but I am… (閱讀更多)

I want to use the Advanced Preferences (about:config) to select 'Manual proxy configuration' setting. I have been able to set the HTTP Proxy and associated port but I am unable to find the setting in Advanced Preferences that will select Manual proxy configuration. Could someone please help. Thanks

jon.christian 於 19 小時前 詢問

zeroknight 最近回覆於 1 小時前

App Firefox auf Android Handy

Meine Android App Firefox ist gestern eingefroren und ließ sich nur neu installieren, nun sind alle Firefox Lesezeichen und offenen Tabs weg. Wie bekomme ich diese wieder… (閱讀更多)

Meine Android App Firefox ist gestern eingefroren und ließ sich nur neu installieren, nun sind alle Firefox Lesezeichen und offenen Tabs weg. Wie bekomme ich diese wieder???

jan.liebisch72 於 1 小時前 詢問

jan.liebisch72 最近回覆於 1 小時前

latest Firefox (125) locks up when typing to address bar in new tab while VPN is active

Since the update to version 125 Firefox on Windows 11 (all updates installed), when I open a new tab and start typing to the address bar WHILE the VPN to the office is ac… (閱讀更多)

Since the update to version 125 Firefox on Windows 11 (all updates installed), when I open a new tab and start typing to the address bar WHILE the VPN to the office is active, Firefox locks up and can not be used anymore.

In taskmanager, there is no spike in memory or cpu usage visible. All I can do at this point is to kill Firefox via taskmanager.

I can enter anything in the address bar of an already open tab with an other website open, I can open new tab from the bookmarks, but I can not open a new tab and start typing in the address bar while the VPN is active.

Once I disable the VPN to the office, everything goes back to normal.

I never had this issue on a previous version of Firefox.

Any ideas whats causing this?

maniac 於 3 小時前 詢問

zeroknight 最近回覆於 1 小時前

Repetitive update request

I keep getting this message that pops up in a private window to restart to keep using firefox. Everytime I click restart Firefox, it closes my tabs and opens them again. … (閱讀更多)

I keep getting this message that pops up in a private window to restart to keep using firefox. Everytime I click restart Firefox, it closes my tabs and opens them again. However, 5 minutes later the window pops up again. Even after repeated attempts of updating, even doing a full restart on the computer, Firefox continues to send this window to me. The private window in the bar says about:restartrequired.

I've tried uninstalling Firefox with a fresh install as well as doing a Refresh of Firefox. Neither seem to solve this problem.

rxs621 於 1 週前 詢問

NoahSUMO 最近回覆於 1 小時前

having to clear my cookies every day or pages wont load properly

I have attached images of what slowly occurs when I don't clear my cookies, websites start to slowly and slowly load less and less until they eventually completely break … (閱讀更多)

I have attached images of what slowly occurs when I don't clear my cookies, websites start to slowly and slowly load less and less until they eventually completely break and wont load and I have to clear my cookies, resign into everything. and rinse and repeat every few days or a week, I also attached an image of what the purchase screen is supposed to look like. Looking at this via Microsoft edge

superkitty914 於 10 小時前 詢問

zeroknight 最近回覆於 2 小時前

YouTube Advanced Bitrate Not Playing in Firefox

Firefox is not permitting videos from YouTube that other browsers easily play. This needs to be fixed. YouTube offers their Premium subscribers videos which can be played… (閱讀更多)

Firefox is not permitting videos from YouTube that other browsers easily play. This needs to be fixed. YouTube offers their Premium subscribers videos which can be played at a higher bitrate, which means even 1080p can play at a higher quality. When setting quality on a video, in addition to the 1080p, you can choose "1080p Advanced bitrate" as an option. Firefox has trouble playing these files, whereas Safari and other browsers don't have a problem with YouTube. Please fix this.

Larry Silverman 於 11 小時前 詢問

zeroknight 最近回覆於 2 小時前

Frequently visited sites no longer recognize me.

Starting with my bank's web site, my user name/password is being challenged. I can't bank. Elsewhere, where my desk top has always been recognized, I'm now forced to log … (閱讀更多)

Starting with my bank's web site, my user name/password is being challenged. I can't bank. Elsewhere, where my desk top has always been recognized, I'm now forced to log in each time...and I receive an email that a new device has just logged into my account. All of this suspiciously coincides with a recent browser update. On my bank feedback it's showing as Firefox "125"...when all previous logins were recorded as Firefox "124". Help!

donmacneil 於 16 小時前 詢問

donmacneil 最近回覆於 2 小時前

firefox does not respond to mouse clicks after update on MacOS

After Firefox updates itself, the restarted browser session is unresponsive to mouse clicks - can't follow links, can't respond to UI dialog boxes, the browser is unusabl… (閱讀更多)

After Firefox updates itself, the restarted browser session is unresponsive to mouse clicks - can't follow links, can't respond to UI dialog boxes, the browser is unusable for practical purposes. It's fixed after another manual restart. This unfortunately breaks all the streamlining Firefox has done to restore the session after an update, because none of that stuff works the same after a manual quit and restart. This is happening on MacOS, and it happens across multiple computers.

uqrcobgezp 於 4 小時前 詢問

Can I install Firefox version 124.0.2 beside version 125.0.2 (already installed) ?

Hi I wish to have Firefox 125.0.2 and 124.02 'separate instances', not different profiles... I already have 125.0.2 installed with various Profiles. I found a 'few' lin… (閱讀更多)

Hi I wish to have Firefox 125.0.2 and 124.02 'separate instances', not different profiles...

I already have 125.0.2 installed with various Profiles.

I found a 'few' links and they were quite 'cloudy' and also since Firefox (now) does not have the 'ask you WHERE to' install... I vaguely remember years ago, it was possible.

I do not mid doing tweaking, I also already have backups of profiles, just in case!

Thank you in advance M

PS it seems Mozilla does not want us to install multiple instances (perception)!

Mozzed 於 1 天前 詢問

Mozzed 最近回覆於 4 小時前

Where is this path?

hi guys, i want to change my default favicons but i cant find this path on my mac. .bookmark-item { list-style-image: url("chrome://global/skin/icons/defaultFavicon.sv… (閱讀更多)

hi guys, i want to change my default favicons but i cant find this path on my mac.

.bookmark-item {

 list-style-image: url("chrome://global/skin/icons/defaultFavicon.svg");

Tuğrul 於 5 小時前 詢問

Hyperallergic Magazine won't load in Firefox

When I click on the link for Hyperallergic Magazine, the page doesn't load. I don't have it blocked in Notifications. I have allowed pop-up windows for it. I can't figure… (閱讀更多)

When I click on the link for Hyperallergic Magazine, the page doesn't load. I don't have it blocked in Notifications. I have allowed pop-up windows for it. I can't figure out what else might be preventing it from loading. It is free. I don't have this problem with any other website that I know of. I'm running the latest version of Firefox & have Windows 11 on a one-year-old PC. I didn't have this problem in my old computer, which ran Windows 7. Please help. Thanks.

deborahfeller 於 1 天前 詢問

jonzn4SUSE 最近回覆於 6 小時前