• 已解決
  • 封存

Why is my XSL file no longer being applied to my XML file?

This morning Firefox upgraded to version 68.0 and several XML files that each reference a corresponding XSL file stopped loading as they always have. One example follows:… (閱讀更多)

This morning Firefox upgraded to version 68.0 and several XML files that each reference a corresponding XSL file stopped loading as they always have. One example follows:

The file ASTest_Appl_Events..xml contains the following

<?xml version="1.0" encoding="ISO-8859-1"?>
<?xml-stylesheet type="text/xsl" href="ASTest_Appl_Events.xsl"?>
<ASTestApplEvents>
<Event xmlns='http://schemas.microsoft.com/win/2004/08/events/event'><System><Provider Name='Report Server Windows Service (MSSQLSERVER)'/><EventID Qualifiers='0'>107</EventID><Level>2</Level><Task>5</Task><Keywords>0x80000000000000</Keywords><TimeCreated SystemTime='2019-07-08T10:01:35.000000000Z'/><EventRecordID>270493</EventRecordID><Channel>Application</Channel><Computer>ASTest</Computer><Security/></System><EventData><Data>Report Server Windows Service (MSSQLSERVER)</Data></EventData></Event>
<Event xmlns='http://schemas.microsoft.com/win/2004/08/events/event'><System><Provider Name='Microsoft-Windows-User Profiles Service' Guid='{89B1E9F0-5AFF-44A6-9B44-0A07A7CE5845}'/><EventID>1530</EventID><Version>0</Version><Level>3</Level><Task>0</Task><Opcode>0</Opcode><Keywords>0x8000000000000000</Keywords><TimeCreated SystemTime='2019-07-08T10:00:10.973301100Z'/><EventRecordID>270438</EventRecordID><Correlation/><Execution ProcessID='848' ThreadID='524'/><Channel>Application</Channel><Computer>ASTest</Computer><Security UserID='S-1-5-18'/></System><EventData Name='EVENT_HIVE_LEAK'><Data Name='Detail'>1 user registry handles leaked from \Registry\User\S-1-5-21-659900985-4002748794-950523200-1002:
Process 300 (\Device\HarddiskVolume3\Windows\System32\conhost.exe) has opened key \REGISTRY\USER\S-1-5-21-659900985-4002748794-950523200-1002\Control Panel\International
</Data></EventData></Event>
</ASTestApplEvents>

The file ASTest_Appl_Events.xsl contains:

<?xml version="1.0" encoding="ISO-8859-1"?>
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
				xmlns:MSEvent="http://schemas.microsoft.com/win/2004/08/events/event">

<xsl:template match="/">
	<html>
	<body>
	<title>ASTest Appl Events</title>
	
	<table><tr>
		<td><h3>ASTest Application Events</h3></td>
		<td width="100"> </td>
	</tr></table>
	
	<table border="1" style="border-collapse:collapse;font-size:14px;" cellpadding="4">
		<tr bgcolor="black" style="color:white">
			<td>Server</td>
			<td>Event Type</td>
			<td>Provider</td>
			<td>Event ID</td>
			<td>Time (Mar-Oct subtract 4 hours, Nov-Feb subract 5 hours)</td>
			<td>Level</td>
			<td>Event Data</td>
			<td>User Data</td>
		</tr>
		<xsl:for-each select="ASTestApplEvents/MSEvent:Event">
			<xsl:sort select="MSEvent:System/MSEvent:TimeCreated/@SystemTime" order="descending" />
			<tr bgcolor="lightgray">
				<td><xsl:value-of select="MSEvent:System/MSEvent:Computer"/></td>
				<td><xsl:value-of select="MSEvent:System/MSEvent:Channel"/></td>
				<td><xsl:value-of select="MSEvent:System/MSEvent:Provider/@Name"/></td>
				<td><xsl:value-of select="MSEvent:System/MSEvent:EventID"/></td>
				<td><xsl:value-of select="MSEvent:System/MSEvent:TimeCreated/@SystemTime"/></td>
				<xsl:choose>
					<xsl:when test="MSEvent:System/MSEvent:Level=1">
						<td style="color:orange;">CRITICAL<br></br>(
							<xsl:value-of select="MSEvent:System/MSEvent:Level"/>)
						</td>
					</xsl:when>
					<xsl:when test="MSEvent:System/MSEvent:Level=2">
						<td style="color:red;">ERROR<br></br>(
							<xsl:value-of select="MSEvent:System/MSEvent:Level"/>)
						</td>
					</xsl:when>
					<xsl:when test="MSEvent:System/MSEvent:Level=3">
						<td style="color:green;">WARNING<br></br>(
							<xsl:value-of select="MSEvent:System/MSEvent:Level"/>)
						</td>
					</xsl:when>
					<xsl:otherwise>
						<td>(<xsl:value-of select="MSEvent:System/MSEvent:Level"/>)</td>
					</xsl:otherwise>
				</xsl:choose>
				<td><xsl:for-each select="MSEvent:EventData/MSEvent:Data">
					<img src="Blue_dot(sm).jpg"/> <strong><em><xsl:value-of select="./@Name"/>:</em></strong> <xsl:value-of select="."/><br></br>
				</xsl:for-each></td>
				<td><xsl:for-each select="MSEvent:UserData">
					<img src="Blue_dot(sm).jpg"/> <strong><em><xsl:value-of select="./@Name"/>:</em></strong> <xsl:value-of select="."/>
				</xsl:for-each></td>
			</tr>
		</xsl:for-each>
	</table>
	
	</body>
	</html>
</xsl:template>

</xsl:stylesheet> 

Screen shots of what I used to see (html generated by an Online XSL Transformer) and currently see are attached.

Any assistance would be appreciated.

Thanks, Kurt H

Kurt H 於 1 年前 詢問

Kurt H 於 1 年前 解答

  • 已解決
  • 封存

network error on local webpage, ok on website

I have a website (oakmontwx.eu5.net) and the front page shows up properly, but when I open the front page locally I get a network error. I am not using localhost on my c… (閱讀更多)

I have a website (oakmontwx.eu5.net) and the front page shows up properly, but when I open the front page locally I get a network error. I am not using localhost on my computer, but I have a javascript routine which reads a text file every 10 seconds. The network error occurs when the page tries to read the file, and only half the webpage appears. On the website there is no problem.

This only started occurring today after Firefox did an auto update. I have refreshed FF and also reinstalled it but the problem persists. The page shows up properly in MS Edge and Safari.

john17 於 1 年前 詢問

jscher2000 於 1 年前 解答

  • 已解決
  • 封存

Firefox local development "CORS request not http"

As of update to v68 I get errors like these: Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at file:///D:/website/fonts/fontaw… (閱讀更多)

As of update to v68 I get errors like these: Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at file:///D:/website/fonts/fontawesome-webfont.woff?v=4.2.0. (Reason: CORS request not http).

What the heck is this? Why did silly mozila messed up the development of local files? How can I bypass that WITHOUT ALTERING my code? It broke fontawesome functionality! Very stupid!

Office Desktop PC 於 1 年前 詢問

philipp 於 1 年前 解答

  • 已解決
  • 封存

Is anyone else finding that new (as of couple days ago) Firefox isn't displaying embedded fonts correctly?

I have an embedded font on my website that I use for the header, and it displays fine. I have a development copy of the website on my hard disk, and that displayed fine t… (閱讀更多)

I have an embedded font on my website that I use for the header, and it displays fine. I have a development copy of the website on my hard disk, and that displayed fine too until Firefox 68.0; but now it uses the second font in my list, instead of the first.

So: some bug in the code of the copy on my disk, I thought. But when I open it in Safari, Chrome or Brave, it displays correctly.

The W3C CSS validation service finds no error in the code.

I'm stumped. Any ideas?

Paul Magnussen 於 1 年前 詢問

philipp 於 1 年前 解答