• 已解決

Most sites will not connect due to security issues

I am running Firefox 126.0-1 on an Arch Linux system. Most websites are failing to connect for security reasons. Some sites, including google.com and nytimes.com, fail w… (閱讀更多)

I am running Firefox 126.0-1 on an Arch Linux system. Most websites are failing to connect for security reasons.

Some sites, including google.com and nytimes.com, fail with an "SEC_ERROR_UNKNOWN_ISSUER" error, and their certificates confirm that they are respectively issued by Google Trust Services LLC and DigiCert Inc.

The website archlinux.org errors with "MOZILLA_PKIX_ERROR_MITM_DETECTED", stating that "Software is Preventing Firefox From Safely Connecting to This Site", citing in particular ISRG Root X1 as the problem. The certificate confirms that it is issued by Let's Encrypt.

The website duckduckgo.com simply errors with "SEC_ERROR_PATH_LEN_CONSTRAINT_INVALID" and states "Secure Connection Failed"

I have confirmed in preferences that my proxy settings are set to "No proxy" and the problem persists across troubleshooting mode and making a new profile. I have also tried removing the cert9.db file in a given profile folder.

david.carlip 於 1 週前 詢問

david.carlip 於 1 週前 解答

  • 已解決

Dead keys not working only in a specific profile

Today I noticed that typing characters with accents like á, ã, â, etc. doesn't seem to work at all from firefox, they all end up ignoring the dead key and just typing the… (閱讀更多)

Today I noticed that typing characters with accents like á, ã, â, etc. doesn't seem to work at all from firefox, they all end up ignoring the dead key and just typing the letter itself. It can render them just fine and I can paste them from another app normally too, but actually typing them is impossible from firefox.

After trying to troubleshoot, I eventually found out a few things: - iBus is not at fault, since it works in every other app and I even restarted it, but the problem persists - This only happens in my main profile, newly created profiles don't have that problem - The problem still happens on troubleshoot mode (as long as it is my main profile) - Compose key also doesn't work (I don't want to use compose key anyway, because my keyboard has specialized dead keys, but I at least tried it)

I suspect the problem lies in a setting on about:config that's different from newly created profiles, but I have no idea which and Ctrl+F searching this site doesn't show any relevant configuration that might be the culprit.

Kazuma 於 1 週前 詢問

Kazuma 於 1 週前 解答

  • 已解決

"Failed to check for updates" et al

Hey, so, I've seen this question a couple times when I searched, but (a) there didn't seem to be any solution and (b) they were all regarding Macs and I'm on Windows 11 v… (閱讀更多)

Hey, so, I've seen this question a couple times when I searched, but (a) there didn't seem to be any solution and (b) they were all regarding Macs and I'm on Windows 11 v 23H2. I keep getting bubbles saying that Firefox wasn't able to check for updates- not that it couldn't download or install updates, but it couldn't search for one. I also did the "about Firefox" thing and it gives me the same message. Both of these have been going on for a couple days and I have attempted restarting Firefox multiple times and did a manual update [125.0.1 (64-bit)] just in case there was a problem there. Now, I've tried the tips from the other threads (turning off the proxy, checking any anti-update policies, and checking the add.update.url in the config settings) with no luck. So in an effort to either bump the question or get any Windows oriented answers... Thanks muchly

xheavenlybodiesx 於 1 個月前 詢問

NoahSUMO 於 1 個月前 解答

  • 已解決

Taking webpage screenshot from command line

Hi. i have no results while doing this: https://dpaste.com/FTXPQ46ZL# No error, no screenshot. "Screenshot" flags in default state, about:policies - inactive. … (閱讀更多)

Hi. i have no results while doing this: https://dpaste.com/FTXPQ46ZL# No error, no screenshot. "Screenshot" flags in default state, about:policies - inactive.

qwertikator 於 2 週前 詢問

cor-el 於 2 週前 解答

  • 已解決

Sync Not working

Sync just does NOT work. I installed FF on my Mac brand new and fresh... brand new machine. Signed into Sync. NOTHING. After 6-7 HOURS... nothing. It just gets NOTHING A… (閱讀更多)

Sync just does NOT work. I installed FF on my Mac brand new and fresh... brand new machine. Signed into Sync. NOTHING. After 6-7 HOURS... nothing. It just gets NOTHING AT ALL from my Windows Desktop.

I've signed out of ALL Firefox/Mozilla sync sessions... signed in clean- all browsers are up to date. And the about:sync-log page shows a LONG streak of errors... NON STOP ERRORS.

Why?! Why can't we just sync extensions to install and bookmarks across machines? How is this that hard for Mozilla?!

The sync-log page list: File:error-sync-1714085057059.txt 6 KB 4/25/2024 17:44:17 File:error-sync-1714088658041.txt 18 KB 4/25/2024 18:44:18 File:error-sync-1714189161327.txt 6 KB 4/26/2024 22:39:21 File:error-sync-1714498425099.txt 13 KB 4/30/2024 12:33:45 File:error-sync-1714588968223.txt 10 KB 5/1/2024 13:42:48 File:error-sync-1714589121080.txt 9 KB 5/1/2024 13:45:21 File:error-sync-1714600674960.txt 7 KB 5/1/2024 16:57:55 File:error-sync-1714604277834.txt 24 KB 5/1/2024 17:57:57 File:error-sync-1714838021899.txt 24 KB 5/4/2024 10:53:41 File:error-sync-1714839602488.txt 11 KB 5/4/2024 11:20:02 File:error-sync-1714839613709.txt 10 KB 5/4/2024 11:20:13 File:error-sync-1714844303035.txt 16 KB 5/4/2024 12:38:23 File:error-sync-1714844919123.txt 15 KB 5/4/2024 12:48:39 File:error-sync-1714846872373.txt 17 KB 5/4/2024 13:21:12 File:error-sync-1714846956569.txt 12 KB 5/4/2024 13:22:36 File:error-sync-1714941772713.txt 15 KB 5/5/2024 15:42:52 File:error-sync-1714941774043.txt 14 KB 5/5/2024 15:42:54 File:error-sync-1714941849730.txt 14 KB 5/5/2024 15:44:09 File:error-sync-1714942633097.txt 14 KB 5/5/2024 15:57:13 File:error-sync-1714942674714.txt 48 KB 5/5/2024 15:57:54

Day after day and attempt after attempt of failures for a basic function of the browser.

Here is the text of the latest log and showing constant connection errors- mind you NOTHING is breaking on my internet as I'm often streaming things and watching stuff while surfing, or others in the house are. Our connection, and Firefox getting online, are all working fine. I am at a loss. I don't understand how this is so terribly broken out of the box that you can't just sign in and let it talk to their servers. I know Google has billions behind Chrome, but this shouldn't be so 1990's bad by comparison to Chrome sync.

1714081299909 Sync.SyncScheduler DEBUG Next sync in 3600000 ms. (why=schedule) 1714081300746 Sync.SyncScheduler DEBUG Network link status changed to "changed". Offline?: false 1714082945349 Sync.SyncScheduler DEBUG Network link status changed to "changed". Offline?: false 1714082945373 Sync.SyncScheduler DEBUG Network link status changed to "down". Offline?: false 1714082945373 Sync.SyncScheduler DEBUG Clearing sync triggers and the global score. 1714082945374 Sync.SyncScheduler DEBUG Next sync in 3600000 ms. (why=schedule) 1714085055761 Sync.SyncScheduler DEBUG Woke from sleep. 1714085056643 Sync.SyncScheduler DEBUG Network link status changed to "changed". Offline?: false 1714085056786 Sync.SyncScheduler DEBUG Network link status changed to "up". Offline?: false 1714085056786 Sync.SyncScheduler DEBUG Network link looks up. Syncing. 1714085056899 Sync.SyncScheduler DEBUG Network link status changed to "changed". Offline?: false 1714085056902 Sync.Service DEBUG User-Agent: Firefox/125.0.2 (Windows NT 10.0; Win64; x64) FxSync/1.127.0.20240419144423.desktop 1714085056902 Sync.Service INFO Starting sync at 2024-04-25 17:44:16 in browser session V0xN5aUmAS9A 1714085056902 Sync.SyncScheduler DEBUG Clearing sync triggers and the global score. 1714085056904 Sync.Status INFO Resetting Status. 1714085056904 Sync.Status DEBUG Status.service: success.status_ok => success.status_ok 1714085056904 FirefoxAccounts DEBUG FxAccountsProfileClient: Requested profile 1714085056904 FirefoxAccounts DEBUG getOAuthToken enter 1714085056905 FirefoxAccounts TRACE getCachedToken returning cached token 1714085056905 FirefoxAccounts DEBUG getOAuthToken returning a cached token 1714085056905 Services.Common.RESTRequest DEBUG GET request to https://profile.accounts.firefox.com/v1/profile 1714085056905 Sync.SyncAuthManager INFO Getting sync key 1714085056905 FirefoxAccounts DEBUG getOAuthToken enter 1714085056905 FirefoxAccounts TRACE getCachedToken returning cached token 1714085056905 FirefoxAccounts DEBUG getOAuthToken returning a cached token 1714085056905 Sync.SyncAuthManager INFO Getting a sync token from: https://token.services.mozilla.com/1.0/sync/1.5 1714085056905 Sync.SyncAuthManager DEBUG Getting a token using OAuth 1714085056905 Services.Common.TokenServerClient DEBUG Beginning OAuth token exchange: https://token.services.mozilla.com/1.0/sync/1.5 1714085056906 Services.Common.RESTRequest DEBUG GET request to https://token.services.mozilla.com/1.0/sync/1.5 1714085057025 Services.Common.RESTRequest DEBUG GET https://profile.accounts.firefox.com/v1/profile failed: 2152398878 - NS_ERROR_UNKNOWN_HOST 1714085057025 FirefoxAccounts ERROR Background refresh of profile failed: {"name":"FxAccountsProfileClientError","code":null,"errno":998,"error":"NETWORK_ERROR","message":"[Exception... \"NS_ERROR_UNKNOWN_HOST\" nsresult: \"0x804b001e (NS_ERROR_UNKNOWN_HOST)\" location: \"JS frame :: resource://services-common/rest.sys.mjs :: onStopRequest :: line 478\" data: no]"} 1714085057031 Services.Common.RESTRequest DEBUG GET https://token.services.mozilla.com/1.0/sync/1.5 failed: 2152398878 - NS_ERROR_UNKNOWN_HOST 1714085057031 Sync.SyncAuthManager ERROR Non-authentication error in _fetchTokenForUser: TokenServerClientNetworkError({"error":{}})(resource://services-common/tokenserverclient.sys.mjs:28:36) JS Stack trace: TokenServerClientNetworkError@tokenserverclient.sys.mjs:51:16 _tokenServerExchangeRequest@tokenserverclient.sys.mjs:235:13 1714085057031 Sync.Status DEBUG Status.login: success.login => error.login.reason.network 1714085057031 Sync.Status DEBUG Status.service: success.status_ok => error.login.failed 1714085057031 Sync.SyncAuthManager ERROR Failed to fetch a token for authentication: TokenServerClientNetworkError({"error":{}})(resource://services-common/tokenserverclient.sys.mjs:28:36) JS Stack trace: TokenServerClientNetworkError@tokenserverclient.sys.mjs:51:16 _tokenServerExchangeRequest@tokenserverclient.sys.mjs:235:13 1714085057032 FirefoxAccounts TRACE not checking freshness of profile as it remains recent 1714085057055 Sync.Resource WARN GET request to https://sync-1-us-west1-g.sync.services.mozilla.com/1.5/209631697/info/collections failed: [Exception... "The lookup of the hostname failed" nsresult: "0x804b001e (NS_ERROR_UNKNOWN_HOST)" location: "<unknown>" data: no] No traceback available 1714085057056 Sync.Status DEBUG Status.sync: success.sync => error.login.reason.network 1714085057056 Sync.Status DEBUG Status.service: error.login.failed => error.sync.failed 1714085057056 Sync.ErrorHandler ERROR Sync encountered an error: [Exception... "The lookup of the hostname failed" nsresult: "0x804b001e (NS_ERROR_UNKNOWN_HOST)" location: "<unknown>" data: no] No traceback available 1714085057056 Sync.SyncScheduler DEBUG Next sync in 3600000 ms. (why=reschedule) 1714085057057 Sync.Telemetry INFO Early submission of sync telemetry due to changed IDs/NodeType 1714085057059 Sync.Service DEBUG Exception calling anonymous function: [Exception... "The lookup of the hostname failed" nsresult: "0x804b001e (NS_ERROR_UNKNOWN_HOST)" location: "<unknown>" data: no] No traceback available

Zor 於 2 週前 詢問

jonzn4SUSE 於 2 週前 解答

  • 已解決

Why did my firefox profile jump from 120MB to 745MB suddenly?

The increase happened here: /storage/permanent/chrome/idb/3870112724rsegmnoittet-es.files/ 79 files taking 590MB created in 3 minutes, out of nowhere. Why were all these… (閱讀更多)

The increase happened here: /storage/permanent/chrome/idb/3870112724rsegmnoittet-es.files/

79 files taking 590MB created in 3 minutes, out of nowhere. Why were all these large files created?

Using Linux Mint, Firefox 125.0.2

Tony 於 3 週前 詢問

zeroknight 於 3 週前 解答

  • 已解決

Mouse-click + modifier key to open a link in private mode?

I'd like to be able to open a link in private mode by holding down some modifier key, then clicking on the link. There are many times that I want to open a link in privat… (閱讀更多)

I'd like to be able to open a link in private mode by holding down some modifier key, then clicking on the link. There are many times that I want to open a link in private mode, and a keypress + click would be the quickest way to do it given that one hand typically remains at the keyboard while I use the mouse/trackpad.

I've even added a toolbar button to open a new private browsing window, then dragged and dropped a link onto the button, but that gets a circle with slash icon and nothing more.

Others have asked this question, so, to be clear, none of the following address my question: copying the link then opening the private browsing window & pasting the link, using a customized shortcut/bookmark, opening Firefox in private mode via command line, right-clicking the link then selecting "Open link in new private window".

Thanks for any advice and thank you, Mozilla, for Firefox!

TAP 於 3 週前 詢問

zeroknight 於 3 週前 解答

  • 已解決

4K YouTube Videos Stuttering One One Specific Channel

So I'm having issues playing 4K videos fully on one YouTube channel: https://www.youtube.com/@ClearviewDriving For some reason anything above 1080p gives me bad stutteri… (閱讀更多)

So I'm having issues playing 4K videos fully on one YouTube channel: https://www.youtube.com/@ClearviewDriving

For some reason anything above 1080p gives me bad stuttering but on other channels videos don't stutter or freeze when playing 1440p or 4K quality.

Firefox is updated, I don't use Extensions other than Ad Blocker and I have that off on YouTube anyway. Seems strange that it'd only affect one specific channel.

I have a very good gaming PC too so the hardware isn't the issue.

Mattt_PC 於 4 週前 詢問

zeroknight 於 3 週前 解答

  • 已解決

PDF Downloads

When I download PDFs on my MacBook using Firefox (currently 124.0.2 (64-bit)), they are always blank - I have attached a screen shot. But if I download the same PDF usin… (閱讀更多)

When I download PDFs on my MacBook using Firefox (currently 124.0.2 (64-bit)), they are always blank - I have attached a screen shot.

But if I download the same PDF using Safari, it opens straightaway - 2nd screen shot.

Is there something I need to adjust in Firefox to allow PDFs to open?

tammymcminn 於 1 個月前 詢問

zeroknight 於 1 個月前 解答

  • 已解決

Amazon Parent Dashboard not functioning on Firefox (but works on Chrome)

Anyone else had the problem of not being able to sign in to the Amazon Parent Dashboard via Firefox? But works on Chrome. Same on desktop and android versions of Firefox.… (閱讀更多)

Anyone else had the problem of not being able to sign in to the Amazon Parent Dashboard via Firefox? But works on Chrome. Same on desktop and android versions of Firefox.

Amazon chat support not helpful and just told me to use Chrome!

benshakespeare 於 1 個月前 詢問

zeroknight 於 1 個月前 解答

  • 已解決

remove search from new tab page (not search from address bar)

Just updated a friend's computer from Windows 7 to 10. Installed firefox over previous ESR and now there's no way to remove the search bar from the new tab page. On my … (閱讀更多)

Just updated a friend's computer from Windows 7 to 10. Installed firefox over previous ESR and now there's no way to remove the search bar from the new tab page. On my W10 system, the search bar isn't there, not sure how or why, but on her's there's no option NOT to show it as there used to be.

I found some VERY old (2014) info on this but doesn't seem to be up to date.

PLEASE give us our options back and stop taking them away, sheesh, getting as bad as Microsoft.

Is there a workaround for this to remove the redundant search bar from the new tab page since you can search from the address bar?

Thanks!

firefoxsync52 於 1 個月前 詢問

zeroknight 於 1 個月前 解答

  • 已解決

Import Data from older Version

My system broke during an update. Now I want to import my old Firefox userdata, but everytime I try to use the old data firefox just forces the creation of a new profile?… (閱讀更多)

My system broke during an update. Now I want to import my old Firefox userdata, but everytime I try to use the old data firefox just forces the creation of a new profile?

Is it completely impossible to recover data not created with the same firefox version?

ff124 於 1 個月前 詢問

cor-el 於 1 個月前 解答

  • 已解決

Recaptcha Not Working in Firefox Specifically.

Recaptcha isn't working in Firefox. It works in Chrome, Opera, and Edge with no issues, it will either just go to a check mark or open the window with the pictures to cho… (閱讀更多)

Recaptcha isn't working in Firefox. It works in Chrome, Opera, and Edge with no issues, it will either just go to a check mark or open the window with the pictures to choose, on both regular pages and on the Google Recaptcha Demo site Google Recaptcha Demo site. But when I load a page that requires Recaptcha in Firefox, it just spins forever. It was working fine a few hours ago, and I didn't change any settings or anything in Firefox. I was filling out a job application and it worked fine, then I went to another job application and Recaptcha won't work at all, even on the Recaptcha Demo site.

I'm on version 125.0.3 (64-bit), on Windows 10. Not using a VPN or anything like that, just a standard Ethernet connection, with whatever Charter gives me.

Steps I've tried, none of which have helped:

1. Cleared Cookies. 2. Restart Browser. 3. Restart Computer. 4. Restart Modem and Router. 5. Opening Firefox in troubleshooting mode. 6. Ensured Firefox was up to date. 7. Reinstalling Firefox. 8. Turned Connection Settings to no proxy. 9. Turned off Enhanced Tracking Protection. (It's set on standard otherwise, and I didn't change it) 10. Release/Renew IP via Command Prompt.

I'm genuinely at a loss of what to do, after a couple of hours of searching around for solutions. I don't get how it just stopped working in the span of like ten minutes when I didn't change any settings or anything. Firefox is my main browser and it would be a tremendous pain to have to use another browser for any pages that require Recaptcha.

Any assistance or advice to solve this problem would be greatly appreciated!

coolman50002001 於 3 週前 詢問

cor-el 於 3 週前 解答

  • 已解決

When opening a new tab, why can't I automatically search?

When I open a new tab, I can't automatically start searching anymore. Here's a video: https://www.loom.com/share/ebcc8685187a4e2284cf40b75f7e134e?sid=9b0a3db3-fcac-4bae… (閱讀更多)

When I open a new tab, I can't automatically start searching anymore.

Here's a video: https://www.loom.com/share/ebcc8685187a4e2284cf40b75f7e134e?sid=9b0a3db3-fcac-4bae-9ff9-cdbe2b8b955b

Now, I have to click into the search bar to type. That's annoying.

Anyone know how to fix this?

Kevin George 於 1 週前 詢問

jscher2000 - Support Volunteer 於 1 週前 解答

  • 已解決
  • 被鎖定

Mozilla Firefox NIGHTLY 127.0a1

Hi, Why is it so much updates all the time with Mozilla Firefox NIGHTLY Browser for the 127.0a1 version that was released 15th of April 2024? I don't even see the benefi… (閱讀更多)

Hi,

Why is it so much updates all the time with Mozilla Firefox NIGHTLY Browser for the 127.0a1 version that was released 15th of April 2024? I don't even see the benefits of the updates or any information and what the content is in them. by clicking on "What new" doesn't show anything other than this from 15th of April.

https://www.mozilla.org/en-US/firefox/127.0a1/releasenotes/?utm_source=firefox-browser&utm_medium=firefox-desktop&utm_campaign=about-dialog

Regards, MrCitizenUnknown

MrCitizenUnknown 於 1 週前 詢問

NoahSUMO 於 1 週前 解答

  • 已解決

Google Sheets Cells Turn Black

This randomly happened over the past few months but last couple days it's bad. The Google Sheets cells I have open on Firefox turn black. You can scroll and they will com… (閱讀更多)

This randomly happened over the past few months but last couple days it's bad. The Google Sheets cells I have open on Firefox turn black. You can scroll and they will come back but just briefly and back to black. Very annoying as these are shared sheets for my business with other employees. It's not happening in Vivaldi Browser or Edge. I hate Chrome so not even trying it there but guessing it's fine. Seems to just be Firefox all of a sudden. See pic. Help please as I have no clue what's causing this.

Keith Robinson 於 1 週前 詢問

Keith Robinson 於 1 週前 解答

  • 已解決

Suggestons cover the address bar.

Whenever I try to write anything into the address bar the suggestions cover it completely and I can't see what I am writing, see Picutre1! However when I launch the brow… (閱讀更多)

Whenever I try to write anything into the address bar the suggestions cover it completely and I can't see what I am writing, see Picutre1!

However when I launch the browser in troubleshoot mode from the help menu, everything works fine, see Picture2.

The only addon I have installed is Youtube adBlock. There are two plugins running, a codec by sisco systems and a decrypt module by google.

Could somebody help me with this problem?

Nevesincs 於 1 週前 詢問

Nevesincs 於 1 週前 解答

  • 已解決

Firefox url and search bar display issue since last update (126)

There is a display issue when I search anything in the url bar. It goes up the window, and disappears completely if many suggestions are made. The issue disappears when i… (閱讀更多)

There is a display issue when I search anything in the url bar. It goes up the window, and disappears completely if many suggestions are made. The issue disappears when in troubleshooting mode. I disabled all plugins, changed the theme to no avail.

jacquessanson 於 1 週前 詢問

cor-el 於 1 週前 解答

  • 已解決

Waterfox Facebook Glitch

Hello, while using Waterfox, recently, while on Facebook, the time a post was made on any given page stopped being shown except for the most recent - newest - one. Per th… (閱讀更多)

Hello, while using Waterfox, recently, while on Facebook, the time a post was made on any given page stopped being shown except for the most recent - newest - one. Per the attached screenshots, the newest post shows that it was put up 26 mins before I got the screenshot, the post prior to that one does not show how long it's been since it was made. This is only in Waterfox. Not a problem with Firefox, Chrome or Edge. Waterfox is my browser of choice for all social media, so this is particularly problematic. Thanks for any help in resolving this.

~ Bruce in Hawai'i

Bruce Wheeler 於 1 週前 詢問

jonzn4SUSE 於 1 週前 解答