顯示問題標籤 顯示所有問題
  • 已解決

Firefox windows could not be dragged now.

Maximizing and minimizing are still normal, but Firefox windows could not be dragged now. $ lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Descriptio… (閱讀更多)

Maximizing and minimizing are still normal, but Firefox windows could not be dragged now.

$ lsb_release -a No LSB modules are available. Distributor ID: Ubuntu Description: Ubuntu 22.04.1 LTS Release: 22.04 Codename: jammy

$ firefox --full-version Mozilla Firefox 102.0.1 20220707183149 20220707183149

$ firefox --help Usage: /snap/firefox/1551/usr/lib/firefox/firefox [ options ... ] [URL]

$ which firefox /usr/bin/firefox

larry 於 5 天前 詢問

larry 於 4 天前 解答

Gaming via Firefox: broken audio in Fedora 34 but it works on Debian 10

Hi. I have been experiencing audio problems in Fedora's Firefox when gaming in some web sites like <kbhgames.com>. An example happpens in <https://kbhgames.com/g… (閱讀更多)

Hi.

I have been experiencing audio problems in Fedora's Firefox when gaming in some web sites like <kbhgames.com>. An example happpens in <https://kbhgames.com/game/dragon-ball-advanced-adventure>.

All goes well on a 64-bit Debian Buster's Firefox 78.14.0esr. The problem is about a 64-bit Fedora's Firefox 94.0. And yes, the issue is there even when all permissions are loosen.

Besides optional troubleshooting Information being shared, common specs are below for convenience:

* user agent Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:94.0) Gecko/20100101 Firefox/94.0; and

* Kernel (according to uname) Linux charger-rt 5.14.18-200.fc34.x86_64 #1 SMP Fri Nov 12 16:48:10 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux.

Plus, the <about:support>'s Media table

Media Audio Backend pulse-rust Max Channels 2 Preferred Sample Rate 48000 Roundtrip latency (standard deviation) 77.89ms (21.60) Output Devices Name Group Vendor State Preferred Format Channels Rate Latency Built-in Audio Analog Stereo Enabled All default: F32LE, support: S16LE S16BE F32LE F32BE 2 default: 48000, support: 1 - 384000 0 - 0 Input Devices Name Group Vendor State Preferred Format Channels Rate Latency Monitor of Built-in Audio Analog Stereo Enabled None default: F32LE, support: S16LE S16BE F32LE F32BE 2 default: 48000, support: 1 - 384000 0 - 0 Built-in Audio Analog Stereo Enabled All default: F32LE, support: S16LE S16BE F32LE F32BE 2 default: 48000, support: 1 - 384000 0 - 0

Regards.

Bea 於 5 天前 詢問

Clicking in the URL or Search field automatically selects existing text (how to disable this behaviour?)

Hi everyone, a long time ago, Firefox on GNU/Linux didn't have this default behaviour I've described in the title of my question (but FF on Windows had this behaviour at … (閱讀更多)

Hi everyone,

a long time ago, Firefox on GNU/Linux didn't have this default behaviour I've described in the title of my question (but FF on Windows had this behaviour at the time, so I believe it was decided to unify the behaviour on all platforms).

The thing is: I truly dislike having the existing text selected automatically. When I click a precise location in the URL or Search field (where some text already exists), I expect the text cursor to locate at this exact spot, NOT the existing text to be entirely selected! With this "new" default behaviour, it now requires 2 clicks to achieve the same task (not what I'd call an improvement) and makes it really PAINFUL to construct a list of search terms (one by one) by copying/pasting them from the current web page (funnily, it proves to be less painful when copying text from another application, since the automatic selection of previously pasted search terms does NOT happen when pasting an additional term -> this is exactly the behaviour I'm expecting).

Historically, whenever I was willing to have the existing text SELECTED (I agree this can be useful from time to time), I used keyboard shortcuts Ctrl+L or Ctrl+K to move the text cursor to the URL or Search field (respectively).

All in all, the historical behaviour of FF on GNU/Linux was just fine (at least to me).

So my QUESTION today is: how to get this historical behaviour back? How to prevent the existing text from being selected when I just CLICK in the URL or Search field?

I've not been able to find a hidden option to configure this behaviour since FF on Linux changed the rule. So I'm afraid it doesn't exist... But if so, would it be possible to add such an option?

Thank you :)

GNU/V 於 2 週前 詢問

GNU/V 最近回覆 於 6 天前

firefox-104.0b6 has the error while loading shared libraries: libatomic.so.1 error

firefox-104.0b6 has the "......error while loading shared libraries: libatomic.so.1" error on recent debian versions/current stable kernels Debian 5.10.28. firefox-102 a… (閱讀更多)

firefox-104.0b6 has the "......error while loading shared libraries: libatomic.so.1" error on recent debian versions/current stable kernels Debian 5.10.28.


firefox-102 and 103 got rid of this error but about a two years ago the newest ff developer editions had this problem also.

x0digi 於 6 天前 詢問

Asking to save credit card number

I can't recall if this problem occurs all of the time or not. The problem is this.............when buying something online or donating online using a credit card I often… (閱讀更多)

I can't recall if this problem occurs all of the time or not. The problem is this.............when buying something online or donating online using a credit card I often get the message...."Save credit card number-choose Yes or No" or something to that effect. Is there a way to modify the settings on my browser so that I do not get this question about saving my credit card number? Or is this an issue with how the website I am browsing at works and therefore I cannot make a one-time fix? Thanks.

I am using Linux and the latest browser 103.0.1

jogger60 於 1 週前 詢問

RobertJ 最近回覆 於 1 週前

  • 已解決

Just upgraded 100 → 103 : how to disable <Ctrl><W> now ?

Until FF100, I used to disable <Ctrl><W> (close tab) by modifying browser/omni.ja, commenting the following line out in chrome/browser/content/browser/browser… (閱讀更多)

Until FF100, I used to disable <Ctrl><W> (close tab) by modifying browser/omni.ja, commenting the following line out in chrome/browser/content/browser/browser.xhtml :

<key id="key_close" data-l10n-id="close-shortcut" command="cmd_close" modifiers="accel" reserved="true"/>

It worked until FF100, but doesn't work anymore in FF103 : commenting that line out seems to have no effect on <Ctrl><W>.

Does anybody know why ? Or does anybody know a way to disable <Ctrl><W> ?

Background : on French keyboards, the <W> key is right next to <X>, so when I try to do a cut/paste (<Ctrl><X> → <Ctrl><V>) I sometimes end up doing <Ctrl><W> by mistake, thus closing the tab. Re-opening the tab doesn't always do the trick, sometimes the latest work is lost.

chentaocredungtao 於 1 週前 詢問

Terry 於 1 週前 解答

Firefox 102&103 in Ubuntu 22.04 STOPs frequently. Need to restart Firefox!

Firefox just locks up. The mouse cursor can be used to resize the window, but is otherwise unresponsive, except to to minimize, maximize or close the window. If I click m… (閱讀更多)

Firefox just locks up. The mouse cursor can be used to resize the window, but is otherwise unresponsive, except to to minimize, maximize or close the window. If I click minimize and then restore the window, Firefox will have executed the last mouse-click before minimizing. This happens after five minutes or so after starting Firefox, whether I have only 4 or 5 tabs open, or a whole pile of tabs. All I can do is click X in top RHS, and then restart Firefox. Then click the "recently closed tabs" to get back to where I was. I have tried clearing the cache and (most of) the cookies. As well I did a complete refresh of Firefox, and disabled all the add-ons, but the problem is still there Running on a (old) Lenovo Thinkpad E545 with 16GB, Ubuntu in a SSD using a 50 GB partn with 30GB free. This problem occurs only in Firefox- all other apps continue to run!

aqk 於 1 週前 詢問

jonzn4SUSE 最近回覆 於 1 週前

When trying to access local files, sometimes get 'Access to the file was denied'

Hi, I'm trying to access locally-installed help files that are in /usr/share. When I try accessing anything starting with "file:///usr" in Firefox, I get "Access to the f… (閱讀更多)

Hi,

I'm trying to access locally-installed help files that are in /usr/share. When I try accessing anything starting with "file:///usr" in Firefox, I get "Access to the file was denied".

I've already set "security.fileuri.strict_origin_policy = false", which now let me access "file:///tmp", "file:///media" and "file:///home", but anything under "file:///usr" (and serveral other top-level directories) still returns the access denied error.

I'm running Firefox 102.0.1 (64-bit) on Ubuntu 22.04.1 LTS.

henry41 於 1 週前 詢問

henry41 最近回覆 於 1 週前

The new update removed lines between the tabs. How do I get them back?

Same as question 1337885, which was marked "solved", despite never being solved. (Solved for a few months is not solved!) Does every user seriously have to go through the… (閱讀更多)

Same as question 1337885, which was marked "solved", despite never being solved. (Solved for a few months is not solved!)

Does every user seriously have to go through the rigmarole of manually editing a CSS file in order to have a usable UI? (as per https://ourtechroom.com/tech/get-back-old-tab-design-firefox/, for example)

craig83 於 1 週前 詢問

jscher2000 - Support Volunteer 最近回覆 於 1 週前

Automatic updates not updating

OS: Pop!_OS 22.04 LTS Firefox: 102.0.1 I have the above version of firefox installed on my machine. I had noticed that automatic updates weren't being installed and did a… (閱讀更多)

OS: Pop!_OS 22.04 LTS Firefox: 102.0.1

I have the above version of firefox installed on my machine. I had noticed that automatic updates weren't being installed and did a little digging. I removed the policies.json file, ran `sudo apt update` and `sudo apt upgrade`, and checked the software update store on my machine. None of these suggestions resolved the issue. I then noticed that whenever I would select `Automatically install updates (recommended)` and close firefox that the change would not persist.

I'm not entirely certain what the issue is at this point and any guidance would be much appreciated. Thanks in advance for your help!

surfninjas 於 1 週前 詢問

jonzn4SUSE 最近回覆 於 1 週前

Accessing Unsynced settnings or content

Hi there, I've been using firefox as my main browser and I've created a account and using it all the time for syncing the settings, bookmarks, logins, extensions etc. BUT… (閱讀更多)

Hi there,

I've been using firefox as my main browser and I've created a account and using it all the time for syncing the settings, bookmarks, logins, extensions etc.

BUT due to some unwanted (really irritating) search suggestion were being shown to me by firefox, I had to uninstall firefox from my system.

    • Throughout the process, I'd kept syncing ON always!!

But when I installed firefox again and after loggedin, I'm syncing everything but this is restoring (syncing) very old data which doesn't have my latest bookmarks, extenstions & saved logins!!

How DO I get my all data???

URGENT PLEASE!! THANK YOU


    • Note : I'm using default "Firefox-ESR" in Kali linux 2022

deep8394yaduvanshi 於 1 週前 詢問

deep8394yaduvanshi 最近回覆 於 1 週前

WebRTC communication failure

Hi, We are using firefox as the browser client for a webrtc based video streaming application. The other client is Gstreamer webrtcbin. The communication works fine with … (閱讀更多)

Hi,

We are using firefox as the browser client for a webrtc based video streaming application. The other client is Gstreamer webrtcbin. The communication works fine with FIPS mode disabled, but it fails when we enable FIPS as part of security. The Gstreamer client sends an SDP offer to the firefox browser client, but it fails to create an answer and respond back. The WebAPI (RTCPeerConnection.createOffer) fails with below exception at application code.

"UnknownError: The operation failed for an unknown transient reason"

Also, tried to check some failure message in browser log and found as below. Not sure if it is related to the failure.

NS_ERROR_ILLEGAL_VALUE: Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsICryptoHash.init]


System setup:


OS - OpenSUSE 15 SP3 Firefox version - 78.13.0esr (we also tried with version 91.10.0esr)


Any quick help will be much appreciated as we are stuck with this.

Thanks, Saurav

saurav.tce 於 1 週前 詢問

saurav.tce 最近回覆 於 1 週前

Pending snap update

What does the popup message 'Pending update of Firefox snap. Please close the app to avoid disruptions.', mean because that message doesn't give enough information to fi… (閱讀更多)

What does the popup message 'Pending update of Firefox snap. Please close the app to avoid disruptions.', mean because that message doesn't give enough information to figure out what it means. I got that before when the last update happened and after that update every time I boot FF can't restore my tabs but I just click try again and it always works. Since I am getting the message again I thought I would try asking on the FF forums to find out what it means and maybe get the boot problem where FF can't restore the tabs when it first starts up fixed.

Kubuntu 22.04 last updated yesterday from all official Kubuntu/Ubuntu repos.

Steve7233 於 1 週前 詢問

jonzn4SUSE 最近回覆 於 1 週前

Controls in a game, that use the Alt key, aren't working?

On this page with an Atari emulator, I am unable to use its controls that use the Alt key, such as Alt+P to pause. It works with another browser, or with a fresh profile… (閱讀更多)

On this page with an Atari emulator, I am unable to use its controls that use the Alt key, such as Alt+P to pause.

It works with another browser, or with a fresh profile.

I've tried disabling add-ons and trying it again, but it fails even after disabling each of them. It also doesn't even work in troubleshooting mode, and that seems kinda odd?

It may be some modified settings in my Firefox profile? Though if it is, I don't know what settings, nor how to fix it. What sorts of settings are retained even in troubleshooting mode?

Sterrence 於 2 週前 詢問

Sterrence 最近回覆 於 1 週前

about:preferences#privacy "Delete cookies ... when Firefox is closed" not saved

The setting "Delete cookies and site data when Firefox is closed" is not saved. Every time I reopen Firefox the setting is unset again. Also my list of exceptions to this… (閱讀更多)

The setting "Delete cookies and site data when Firefox is closed" is not saved. Every time I reopen Firefox the setting is unset again. Also my list of exceptions to this is not used, thus all the loging cookies that I had for the sites on the exception list are deleted and I have to re-login again.

icollect 於 1 週前 詢問

Terry 最近回覆 於 1 週前

Temporary bypass of cookie-removal-at-exit

Hi, I have always used a "clear mostly everything" at exit approach to privacy. Before using FF I'd set exceptions for cookies that I prefer to keep (like search engine p… (閱讀更多)

Hi,

I have always used a "clear mostly everything" at exit approach to privacy. Before using FF I'd set exceptions for cookies that I prefer to keep (like search engine preferences) but I understand that isn't possible in FF, so I ended up using a different approach. On Unix-based systems I'd "quit" FF by with `pkill -9 -f firefox` (or waterfox). Somehow that worked (e.g. when restarting after an update) despite the obvious loophole it created but it was a welcome way to restart the browser without having to log in. Recently it stopped working though, and I find myself logged off every site I was logged in to, including Google and e.g. Whatsapp's web interface. Extremely annoying now that so many sites use 2FA.

Can you confirm this impression that the loophole has been closed, and security+privacy-related data is now removed at startup (too)?

Is there an way to quit/restart the browser without clearing this data, e.g. after an update or to release build-up RAM usage back to the system, while keeping the default "clear everything"? Is there an option not to lose logins etc. after a crash?

FWIW, the other reason I used this approach is because the open windows+tabs restore tended to be more reliable after a crash than after a normal shutdown (which would often miss a few tabs that I would not always miss at once).

Thanks in advance!

RJVB 於 1 週前 詢問

Firefox all of a sudden redirects specific subdomain to https

Hello, as the title suggest, all of a sudden, firefox redirects all requests to https for a certain subdomain (I haven't found any other domains yet, this one I'm checkin… (閱讀更多)

Hello,

as the title suggest, all of a sudden, firefox redirects all requests to https for a certain subdomain (I haven't found any other domains yet, this one I'm checking daily and noticed this). Subdomain I'm referring to is hosting prometheus, alertmanager and grafana, all on different ports on same subdomain. Only grafana is configured to use TLS, prometheus and alertmanager was never configured and was using plain http.

All of a sudden, this morning, alertmanager and prometheus are being redirected to https. Their configuration was unchanged for months. When i open Developer Tools and visit the alertmanager or prometheus page, i get no HTTP status code (literally i get blank value under "Status", GET is trying to use https without any 302 or other redirect requests. Which gives me thinking - this redirection comes from firefox for some reason..

When opening same URLs under Private Browsing i get no issues, also , i get no issues when accessing the URLs from other browsers.

What might've happened for firefox to trigger this behavior , and how to fix it and prevent it from ever happening again.

Things I've tried: - Clear site preferences from History - network.stricttransportsecurity.preloadlist to false - browser.fixup.fallback-to-https to false - dom.security.https_first - was already false - I haven't installed any new extensions and I'm not using DuckDuckGo Extension - Enable DNS over HTTPS was already disabled

What i haven't tried: - Clearing entire history with cache and cookies. Seems like an overkill for something that should not've even happen and for something that previous options should already fix.

Please help me out.

maretodoric 於 2 週前 詢問

cor-el 最近回覆 於 1 週前

Network Response not formated on devtools

I want to see a response in a formated/pretty way to check for errors on my work. According to this link https://firefox-source-docs.mozilla.org/devtools-user/network_mon… (閱讀更多)

I want to see a response in a formated/pretty way to check for errors on my work. According to this link https://firefox-source-docs.mozilla.org/devtools-user/network_monitor/request_details/index.html#network-monitor-request-details-response-tab it should be possible to do so, clicking a button which formats the response in the network part of the devtools, however this button does not exist on my devtools. In chrome there is the preview tab that shows the response in the way I need, and also as the button to format the response in the response tab. Is it a bug on my end? If not, why is it that way?

felippemda 於 2 週前 詢問

jscher2000 - Support Volunteer 最近回覆 於 2 週前