Firefox takes 10+ times longer to load websites than Edge or Chrome

I'm at my wits end. I've tried every fix I could find and Firefox is dramatically slower then Edge or Chrome. This happens with loading sites, like Amazon. Also, it of… (閱讀更多)

I'm at my wits end. I've tried every fix I could find and Firefox is dramatically slower then Edge or Chrome. This happens with loading sites, like Amazon. Also, it often locks up/stops when typing (like right now) and it takes about 15 seconds for it to repond again.

First, I doubt it's a hardware or network issue, since it's happened on both my old archaic PC and now on my new PC (i9 CPU, Nvidia 2070 graphics card, 64gb RAM).

Here's some highlights of what I've tried so far: • Refreshing multiple times • Rebooting the PC • Doing all the Quick Tips on this website • Eliminating all extensions • Clearing all cookies and cash • ...

Also, I don't get any error codes. The tab icon just spins for a long time.

I'm hoping I'm missing something obvious, since I love Firefox.

Thanks and any help!

Olliesshop 於 2 週前 詢問

Olliesshop 最近回覆 於 4 天前

Some text is covered with black diamonds and question marks

On FoxNews.com, some articles include a section at the bottom for user comments. First-level comments frequently receive additional second- and third-level comments. Fir… (閱讀更多)

On FoxNews.com, some articles include a section at the bottom for user comments. First-level comments frequently receive additional second- and third-level comments.

First-level comments are working fine, but lower-level comments are partially obliterated with a string of black diamonds with question marks �?U��N�@?�.

This is not an issue when I use Safari, but it is on Firefox.

Prentice3 於 2 週前 詢問

Prentice3 最近回覆 於 1 天前

Cannot change color of tabs

Firefox - Add Colored tabs I had Firefox version 81 and after installing version 82 in a new install on a new hard drive, I cannot change the color of my tabs anymore. I … (閱讀更多)

Firefox - Add Colored tabs

I had Firefox version 81 and after installing version 82 in a new install on a new hard drive, I cannot change the color of my tabs anymore. I should see white tabs for the current tab but no longer when I added my userChrome.css file. I see instead a thin blue color strip along the top of the tab and the rest is grey. This shows up without any userChrome.css file.

In Firefox address field type: about:support It shows my Profile. vwy0y5ix.default-release I also have under the Profile folder this: jcueuz5y.default

I put the userChrome.css file here in my Chrome folder: C:\Users\David\AppData\Roaming\Mozilla\Firefox\Profiles\vwy0y5ix.default-release

What it contains: /* USE THIS ONE. It works in version 65 https://github.com/Aris-t2/CustomCSSforFx/releases/tag/2.3.4

  • /

@import "./css/tabs/tabs_below_navigation_toolbar_fx65.css"; /**/ /* <-- tabs not on top - Fx65+ - Windows/Linux */

/* Colored tab */ .tab-background:not([selected]) {

   background-color: #E3E0DB !important;

}

.tab-background[selected="true"] {

   background-color: white!important;

}

/*** Sidebar Color / Font Size Formatting ***/ /* 14px black text */ .sidebar-placesTree treechildren::-moz-tree-cell-text {

 font-size: 14px !important;
 color: #000 !important;

} /* Pale blue background on hover or selected */ .sidebar-placesTree treechildren::-moz-tree-row(hover), .sidebar-placesTree treechildren::-moz-tree-row(selected) {

 background-color: #bdf !important;

}

/* Main Toolbar */

  1. nav-bar {
 font-size: 14px !important;

davidhelp 於 1 週前 詢問

davidhelp 最近回覆 於 3 天前

Jagged fonts after 83 update.

Installed 83.0 update for my Firefox a few days ago and noticed that fonts in browser looks worse. It bacame jagged (sharp) as if Clear Type was disabled in my system but… (閱讀更多)

Installed 83.0 update for my Firefox a few days ago and noticed that fonts in browser looks worse. It bacame jagged (sharp) as if Clear Type was disabled in my system but I checked it and it is turned on. Also I don't see this problem in other browsers, Edge or IE, only in Firefox. Could it be a bug with latest update or what is it?

Vitaliy1993 於 1 週前 詢問

Vitaliy1993 最近回覆 於 4 天前

Firefox Hanging Then Speeding

Hello, I'm a Windows 7 user. For the past 3 weeks my Firefox browser (83.0) has been slowing down and then speeding up while visiting sites. I tried Safe Mode, Refresh, … (閱讀更多)

Hello,

 I'm a Windows 7 user. For the past 3 weeks my Firefox browser (83.0) has been slowing down and then speeding up while visiting sites. I tried Safe Mode, Refresh, and Reinstall but nothing seems to help. It's not being caused by anything on my computer (malware, viruses, etc) because I ran several scans using Malwarebytes Premium, CCleaner Premium, Microsoft Security Essentials, even Microsoft Safety Scanner and nothing turns up.
 Is there any other way to fix this issue on the browser?

purpledove 於 2 週前 詢問

purpledove 最近回覆 於 5 天前

Firefox 83

Okay I just uploaded the new version of firefox I think 83, and every time I restart my computer or anything like that I have to re-log back into EVERYTHING. All my googl… (閱讀更多)

Okay I just uploaded the new version of firefox I think 83, and every time I restart my computer or anything like that I have to re-log back into EVERYTHING. All my google accounts everything that require a password. It has for the most part my passwords saved but it i a huge hassle especially since I work from home it eats up a lot of time.

It doesn't save my tabs I had left open either. I can get them back when I go to sync tabs but I have to do it one at a time. It literally takes me back to the "Important News: Changes to your Firefox" page every time and its been days and its super frustrating. If I have to do this every time I will have to switch over to chrome which would be a bummer. I have tried fixing it in my preferences section of firefox and made sure everything is lining up there so it should be saving my info but no matter what I do it just takes me back to that page along with my ad blocker and honey page as if it was my first time signing in

Please help I can't do this every time I log in

Raquel 於 1 週前 詢問

Raquel 最近回覆 於 5 天前

Firefox opens previous tabs on startup even though this setting is turned off

Whenever I open Firefox it opens a new tab for a brief moment then closes it and opens my previous tabs from my last session. I have this setting unchecked in the setting… (閱讀更多)

Whenever I open Firefox it opens a new tab for a brief moment then closes it and opens my previous tabs from my last session. I have this setting unchecked in the settings. I think that it is crashing and trying to restore my pages because of that, but there are no crash reports when I visit about:crash. I am running the latest version of Firefox and windows 10.

Luke Shuttleworth 於 2 週前 詢問

Luke Shuttleworth 最近回覆 於 6 天前

How do I get obsolete info out of a typing box?

Recently, I had to change my username at my bank's website because somebody was trying a brute force attack on my password. Now, the site still shows my old username, al… (閱讀更多)

Recently, I had to change my username at my bank's website because somebody was trying a brute force attack on my password. Now, the site still shows my old username, although I've gone to my Saved Logons in Preference and removed all logons for that site except for the correct one. I have to delete the old username from the typing box every time I log in there, after which I can select the correct (and only) saved username/password.

sideburns 於 5 天前 詢問

sideburns 最近回覆 於 3 天前

Problem - the "sub-window" prompts in FireFox Browser

Hello, The problem that occurs to me can be seen at the picture in the attachment. I have cleaned cash and cookies, but it did not solve the problem. Any idea how to sol… (閱讀更多)

Hello,

The problem that occurs to me can be seen at the picture in the attachment. I have cleaned cash and cookies, but it did not solve the problem. Any idea how to solve this??

mica_lekic 於 6 天前 詢問

mica_lekic 最近回覆 於 5 天前

Dual boot (Win7 & openSUSE TW) ZBook-17-G2-Tumbleweed

The machine name ZBook-17-G2-Tumbleweed is not showing in Sync Tabs. Firefox has lost all my tabs a few time in the past 2 weeks and when I opened the sync tab to bring … (閱讀更多)

The machine name ZBook-17-G2-Tumbleweed is not showing in Sync Tabs. Firefox has lost all my tabs a few time in the past 2 weeks and when I opened the sync tab to bring the tabs back the machine name is not there and all my open tabs are gone.

Firefox 82.0 (64-bit) Operating System: openSUSE Tumbleweed 20201104 KDE Plasma Version: 5.20.2 KDE Frameworks Version: 5.75.0 Qt Version: 5.15.1 Kernel Version: 5.9.1-1-default OS Type: 64-bit Processors: 8 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa DRI Intel® HD Graphics 4600

jonzn4SUSE 於 3 週前 詢問

jonzn4SUSE 最近回覆 於 2 天前

Anyway to disable "A script from the extension" "is running on this page"

I am getting sick of the message "A script from the extension...is running on this page" It relates to Adblock Plus which is the extension. I watch a YouTube video and th… (閱讀更多)

I am getting sick of the message "A script from the extension...is running on this page" It relates to Adblock Plus which is the extension. I watch a YouTube video and then this message comes up on another YouTube tab I have open and Firefox switches to that tab and ruins my watching the video I was watching.

Is there anyway of disabling the message from ever coming up? I increased the values in dom.max_script_run_time and dom.max_script_run_time_without_important_user_input which was a possible solution I read but that does nothing.

davebesag 於 1 週前 詢問

davebesag 最近回覆 於 3 天前

How Do I Get FireFox to Open a Link in a New Window

I feel ridiculous but I have always set FireFox to open a new window when I clicked on a link. For some reason it stopped doing that today. It just follows the link in th… (閱讀更多)

I feel ridiculous but I have always set FireFox to open a new window when I clicked on a link. For some reason it stopped doing that today. It just follows the link in the existing window. I cannot find the option to get the old action. Searches bring up methods from many obsolete versions. Even this site brings up over 2800 hits but I can't find the one I need.

petejc 於 1 週前 詢問

petejc 最近回覆 於 6 天前

YouTube player preferences not being saved.

Just recently I noticed that Firefox 83.0 is no longer retaining my viewer settings in YouTube. Specifically the theater mode and autoplay settings. I can set it to theat… (閱讀更多)

Just recently I noticed that Firefox 83.0 is no longer retaining my viewer settings in YouTube. Specifically the theater mode and autoplay settings. I can set it to theater mode, and turn off autoplay, and the next time I start Firefox, they are back to their defaults (autoplay on, compact viewer). At first I thought it was a YouTube issue but have tried it on Chrome and Chromium and both browsers save my settings. I'm running ArcoLinux 5.9.10 with I3 WM on both my desktop and laptop. I have both reset and re-installed FF with no change.

erik45 於 5 天前 詢問

erik45 最近回覆 於 2 天前

Saved logins and passwords for websites.

Hi, I am wondering why Firefox removed all logins and passwords. It used to be all in settings, now I am getting message: No logins found When you save a password in Fi… (閱讀更多)

Hi, I am wondering why Firefox removed all logins and passwords. It used to be all in settings, now I am getting message: No logins found When you save a password in Firefox, it will show up here Any help, thanks in advance.

Dziambis 於 5 天前 詢問

Dziambis 最近回覆 於 7 小時前

Firefox crashing frequently with Mozilla Crash Reporter

Firefox has been crashing daily. Need to reinstall every time it crashes. Have tried different versions of Firefox but it still crashes. The latest Crash ID: bp-aea83dc… (閱讀更多)

Firefox has been crashing daily. Need to reinstall every time it crashes. Have tried different versions of Firefox but it still crashes.

The latest Crash ID: bp-aea83dc4-ed3d-4298-8686-b149b0201126

Would appreciate help in fixing the problem. Thanks!

yuenhome 於 6 天前 詢問

yuenhome 最近回覆 於 6 天前

Windows Firewall has blocked some features of this app

Hi, I'm a paranoid guy so i tend to investigate anything and everything weird that happens to me. Yesterday, i was browsing a movie directory looking for a movie to watch… (閱讀更多)

Hi,

I'm a paranoid guy so i tend to investigate anything and everything weird that happens to me.

Yesterday, i was browsing a movie directory looking for a movie to watch outside of major platforms (Netflix). The site was full of ads and other crap, my AV was ringing the bells, blocking lots of potentially malicious links.

Suddenly, i got prompted by Windows Defender to allow firefox.exe to communicate on public networks too. Private networks were allowed already, but somehow it wanted access over public networks too.

It looked exactly like this : https://content.invisioncic.com/Mmalware/monthly_2018_03/image.png.2897f90ed89aa34691c24143e249ab12.png

I am wondering if i could've been exploited by some sort of 0-day, as FireFox security is weaker now, we might see more broad attacks on people.

How could this happen and why would FireFox suddenly want to add new incoming rule?

I have the latest version of FireFox for many days, haven't installed anything new or updated anything. It happened just like that. Also, i was calling with a friend via Messenger which uses WebRTC, but we've been calling like that for past week or so, so don't have a clue why did it happen now...

Should i be concerned?

Let me know, please.

alohaboy15488 於 5 天前 詢問

Download files started failing on Linux

When I try to dowload a file, i fails and create a 0 byte file. I tried with repository firefox, and download the tar.gz from dev version. Both fail. I deleted ~/.mozilla… (閱讀更多)

When I try to dowload a file, i fails and create a 0 byte file. I tried with repository firefox, and download the tar.gz from dev version. Both fail. I deleted ~/.mozilla and ~/.cache/mozilla to start fresh and the error persist. I can browse, open a PDF in integrated viewer, but I am unable to save it. Other browsers can download files to ~/Downloads without problems.

Any hint of how to debug (and/or solve) the problem is welcome.

Thanks

enboig 於 6 天前 詢問

enboig 最近回覆 於 6 天前

sound when using firefox

Hi The other day i was watching a movie on Viaplay. I paused it, and when i started it again, there was no sound. Ive tried other websites, to see if there is any sound,… (閱讀更多)

Hi The other day i was watching a movie on Viaplay. I paused it, and when i started it again, there was no sound. Ive tried other websites, to see if there is any sound, but sadly no. Ive tried other browser, and there the sound works just fine.

ive tried reinstall mozilla, and seached for solutions, but cant get any answers.

Please is there som tec guru, that can help me

Best reggards

Michael

michael_sandberg87 於 1 週前 詢問

michael_sandberg87 最近回覆 於 6 天前