顯示問題標籤 顯示所有問題
  • 已解決
  • 封存

New CSS styles not picked in Firefox.

I am building a website and, for the last couple of days, when I make changes to the CSS file they are no longer being picked up by the browser by which I mean they aren'… (閱讀更多)

I am building a website and, for the last couple of days, when I make changes to the CSS file they are no longer being picked up by the browser by which I mean they aren't displayed in the web page nor in the developer tools inspector.

They are visible in Chromium browser and dev tools.

I have cleared the cache and refreshed the page to no avail. It is only when I restart the browser that the new style rules take effect in the browser and show up in the dev tools.

mt3ch 於 1 年前 詢問

cor-el 於 1 年前 解答

  • 已解決
  • 封存

Content-Security-Policy: frame-ancestors doesn't work

As mentioned here https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Content-Security-Policy/frame-ancestors, CSP: frame-ancestors is supported from Firefox 33. Ho… (閱讀更多)

As mentioned here https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Content-Security-Policy/frame-ancestors, CSP: frame-ancestors is supported from Firefox 33. However, it seems doesn't work.

I am trying to embed a 3-party site into our page using an iframe. The 3-party site did whitelist us using these headers - Content-Security-Policy: frame-ancestors 'self' https://*.ourdomain.com - X-Frame-Options: SAMEORIGIN

It works fine on Chrome, but not Firefox. I am using Firefox 79.

Is there anything wrong with our headers?

Thank you!

vinh.vu 於 1 年前 詢問

vinh.vu 於 1 年前 解答

  • 已解決
  • 封存

Notifications Not Working

Hello. I'm using a brand-new installation of Firefox 78.0.1 on a freshly installed copy of Windows 10 Pro. The only way I can get Firefox to display any notifications i… (閱讀更多)

Hello. I'm using a brand-new installation of Firefox 78.0.1 on a freshly installed copy of Windows 10 Pro. The only way I can get Firefox to display any notifications is by having alerts.useSystemBackend set to true. While this is set to false, notifications will not work. If I use this site to test them, it just says, 'queued for display', followed immediately by 'closed'. I've also tried creating a new profile and testing it again with no success. All sites were granted notification permissions in each case.

Thanks for any help.

dojima 於 1 年前 詢問

dojima 於 1 年前 解答