顯示問題標籤 顯示所有問題
  • 已解決
  • 封存

Font appears messed up only on Mozilla, only on one PC

Hello! So, I was working on a new blog on which I'm using the Rubik font from Google fonts. Everything was fine for several days, but today, after working for some time o… (閱讀更多)

Hello!

So, I was working on a new blog on which I'm using the Rubik font from Google fonts.

Everything was fine for several days, but today, after working for some time on it, the font just got messed up randomly (see attached image).

I added the font on a different, testing site and it shows messed up there as well, so it's not something website related.

Now, the shocking part is that it gets messed up only on Mozilla and only on the Mozilla browser that's on my Desktop PC.

I asked a friend to check it out and I also checked it out on my laptop, and the font is fine on other Mozilla browsers, as well as other browsers.

Other fonts from other websites are fine as well.

What troubleshooting I performed:

- Checked the font with Inspect Element, as it's shown here: https://developer.mozilla.org/en-US/docs/Tools/Page_Inspector/How_to/Edit_fonts and the font is set up correctly;

- Deleted the whole history since the beginning of time (cookies, cache, everything);

- Closed and opened Firefox again;

- Opened Mozilla in Safe Mode (hardware acceleration is disabled by default in safe mode);

- Restarted my PC;

- Uninstalled Mozilla as it shows here - https://support.mozilla.org/en-US/kb/uninstall-firefox-from-your-computer. Deleted the profile folder and everything.

- Installed a fresh copy again with no add-ons, no nothing.

Nothing worked. That font is still messed up on Mozilla, on this PC.

It doesn't make any sense, especially since it went nuts randomly without a particular reason.

Does anyone have an idea of what could be the problem and how to fix it?

Any help would be appreciated!

Thanks!

Asked by Radu_B 1 年前

Answered by jscher2000 1 年前

  • 封存

Pages display weird characters, misaligned elements, etc.

I've been using Firefox since it was released, but I'm sick of all the issues I have with it that DO NOT effect Chrome and other browsers. I frequently get garbage chara… (閱讀更多)

I've been using Firefox since it was released, but I'm sick of all the issues I have with it that DO NOT effect Chrome and other browsers. I frequently get garbage characters in place of things like apostrophes on various sites. I also get misaligned elements on some forms and so on (e.g. radio buttons above the line they should be on). But today I want an answer to a specific problem -- inline video players. Sometimes, but not all the time, the labels on the controls of inline players change to weird alphabetic characters so that I can't tell how to operate the player. See the example below (the red circles have been added to highlight the problem).

Asked by teppscan 1 年前

Last reply by cor-el 1 年前