X
點擊此處開啟此網站的行動版。

技術支援討論區

Windows 8.1 cannot connect to any website

已張貼

Firefox just updated to 28 on a Windows 8.1 now it wont connect to any website. The browser just says connecting in a loop.

Firefox just updated to 28 on a Windows 8.1 now it wont connect to any website. The browser just says connecting in a loop.

額外的系統細節

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.154 Safari/537.36

更多資訊

philipp
  • Top 25 Contributor
  • Moderator
5306 個解決方法 23424 個答案

hello, normally such issues are caused by a firewall/security software which doesn't recognize & therefore blocks new firefox versions: Fix problems connecting to websites after updating Firefox

hello, normally such issues are caused by a firewall/security software which doesn't recognize & therefore blocks new firefox versions: [[Fix problems connecting to websites after updating Firefox]]

提出問題者

Hi, I have added exceptions, turned the firewall off and also connected to an un-firewalled port and firefox still will not connect.

Is there anything else I can try?

Hi, I have added exceptions, turned the firewall off and also connected to an un-firewalled port and firefox still will not connect. Is there anything else I can try?
WilIP 13 個解決方法 64 個答案

If you can't connect to the Internet using other web browsers either, then try restarting your computer and your router (wait about 20 seconds before turning them back on again).

Otherwise, try using safe mode to check whether extensions are where the problem lies.

If you can't connect to the Internet using other web browsers either, then try restarting your computer and your router (wait about 20 seconds before turning them back on again). Otherwise, try [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode using safe mode] to check whether extensions are where the problem lies.

提出問題者

Hi,

I can connect to the internet via internet explorer desktop and metro, just not via firefox.

I have ran firefox in safe mode and disabled all ad-ons and it still does not work.

Is this is an issue with Windows 8.1 as it was working fine before this upgrade.

Anything else i can try?

Hi, I can connect to the internet via internet explorer desktop and metro, just not via firefox. I have ran firefox in safe mode and disabled all ad-ons and it still does not work. Is this is an issue with Windows 8.1 as it was working fine before this upgrade. Anything else i can try?
Moses
  • Moderator
459 個解決方法 3607 個答案

有幫助的回覆

Can you give me your troubleshooting information? The information found here is non-personal and non-identifiable information needed to see how Firefox is configured on your system with details on your extensions, plugins ,etc.

  • Go to "about:support" from the Address bar (without quotes)
  • Click "copy raw data to clipboard"
  • Copy back to your support thread and paste it into a new reply to me
Can you give me your troubleshooting information? The information found here is '''non-personal and non-identifiable information''' needed to see how Firefox is configured on your system with details on your extensions, plugins ,etc. *Go to "about:support" from the Address bar (without quotes) *Click "copy raw data to clipboard" *Copy back to your support thread and paste it into a new reply to me

由 Moses 於 修改

提出問題者

{

 "application": {
   "name": "Firefox",
   "version": "28.0",
   "userAgent": "Mozilla/5.0 (Windows NT 6.3; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0",
   "supportURL": "https://support.mozilla.org/1/firefox/28.0/WINNT/en-GB/"
 },
 "crashes": {
   "submitted": [],
   "pending": 0
 },
 "modifiedPreferences": {
   "browser.cache.disk.capacity": 358400,
   "browser.cache.disk.smart_size.first_run": false,
   "browser.cache.disk.smart_size.use_old_max": false,
   "browser.cache.disk.smart_size_cached_value": 358400,
   "browser.places.smartBookmarksVersion": 6,
   "browser.sessionstore.upgradeBackup.latestBuildID": "20140314220517",
   "browser.startup.homepage_override.mstone": "28.0",
   "browser.startup.homepage": "http://www.google.co.uk",
   "browser.startup.homepage_override.buildID": "20140314220517",
   "extensions.lastAppVersion": "28.0",
   "gfx.direct3d.last_used_feature_level_idx": 0,
   "network.cookie.prefsMigrated": true,
   "places.history.expiration.transient_current_max_pages": 103710,
   "plugin.state.npctrl": 0,
   "plugin.state.npican": 0,
   "plugin.importedState": true,
   "plugin.state.npitunes": 0,
   "plugin.disable_full_page_plugin_for_types": "application/pdf",
   "plugin.state.nppdf": 0,
   "plugin.state.npspwrap": 0,
   "plugin.state.npnul": 0,
   "plugin.state.npgoogleupdate": 0,
   "plugin.state.flash": 0,
   "privacy.sanitize.migrateFx3Prefs": true
 },
 "graphics": {
   "numTotalWindows": 1,
   "numAcceleratedWindows": 1,
   "windowLayerManagerType": "Direct3D 10",
   "windowLayerManagerRemote": false,
   "adapterDescription": "Intel(R) HD Graphics 4000",
   "adapterVendorID": "0x8086",
   "adapterDeviceID": "0x0166",
   "adapterRAM": "Unknown",
   "adapterDrivers": "igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32",
   "driverVersion": "10.18.10.3412",
   "driverDate": "1-22-2014",
   "adapterDescription2": "",
   "adapterVendorID2": "",
   "adapterDeviceID2": "",
   "adapterRAM2": "",
   "adapterDrivers2": "",
   "driverVersion2": "",
   "driverDate2": "",
   "isGPU2Active": false,
   "direct2DEnabled": true,
   "directWriteEnabled": true,
   "directWriteVersion": "6.3.9600.16384",
   "webglRenderer": "Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D9Ex vs_3_0 ps_3_0)",
   "info": {
     "AzureCanvasBackend": "direct2d",
     "AzureSkiaAccelerated": 0,
     "AzureFallbackCanvasBackend": "cairo",
     "AzureContentBackend": "direct2d"
   }
 },
 "javaScript": {
   "incrementalGCEnabled": true
 },
 "accessibility": {
   "isActive": false,
   "forceDisabled": 0
 },
 "libraryVersions": {
   "NSPR": {
     "minVersion": "4.10.3",
     "version": "4.10.3"
   },
   "NSS": {
     "minVersion": "3.15.5 Basic ECC",
     "version": "3.15.5 Basic ECC"
   },
   "NSSUTIL": {
     "minVersion": "3.15.5",
     "version": "3.15.5"
   },
   "NSSSSL": {
     "minVersion": "3.15.5 Basic ECC",
     "version": "3.15.5 Basic ECC"
   },
   "NSSSMIME": {
     "minVersion": "3.15.5 Basic ECC",
     "version": "3.15.5 Basic ECC"
   }
 },
 "userJS": {
   "exists": false
 },
 "extensions": []

}

{ "application": { "name": "Firefox", "version": "28.0", "userAgent": "Mozilla/5.0 (Windows NT 6.3; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0", "supportURL": "https://support.mozilla.org/1/firefox/28.0/WINNT/en-GB/" }, "crashes": { "submitted": [], "pending": 0 }, "modifiedPreferences": { "browser.cache.disk.capacity": 358400, "browser.cache.disk.smart_size.first_run": false, "browser.cache.disk.smart_size.use_old_max": false, "browser.cache.disk.smart_size_cached_value": 358400, "browser.places.smartBookmarksVersion": 6, "browser.sessionstore.upgradeBackup.latestBuildID": "20140314220517", "browser.startup.homepage_override.mstone": "28.0", "browser.startup.homepage": "http://www.google.co.uk", "browser.startup.homepage_override.buildID": "20140314220517", "extensions.lastAppVersion": "28.0", "gfx.direct3d.last_used_feature_level_idx": 0, "network.cookie.prefsMigrated": true, "places.history.expiration.transient_current_max_pages": 103710, "plugin.state.npctrl": 0, "plugin.state.npican": 0, "plugin.importedState": true, "plugin.state.npitunes": 0, "plugin.disable_full_page_plugin_for_types": "application/pdf", "plugin.state.nppdf": 0, "plugin.state.npspwrap": 0, "plugin.state.npnul": 0, "plugin.state.npgoogleupdate": 0, "plugin.state.flash": 0, "privacy.sanitize.migrateFx3Prefs": true }, "graphics": { "numTotalWindows": 1, "numAcceleratedWindows": 1, "windowLayerManagerType": "Direct3D 10", "windowLayerManagerRemote": false, "adapterDescription": "Intel(R) HD Graphics 4000", "adapterVendorID": "0x8086", "adapterDeviceID": "0x0166", "adapterRAM": "Unknown", "adapterDrivers": "igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32", "driverVersion": "10.18.10.3412", "driverDate": "1-22-2014", "adapterDescription2": "", "adapterVendorID2": "", "adapterDeviceID2": "", "adapterRAM2": "", "adapterDrivers2": "", "driverVersion2": "", "driverDate2": "", "isGPU2Active": false, "direct2DEnabled": true, "directWriteEnabled": true, "directWriteVersion": "6.3.9600.16384", "webglRenderer": "Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D9Ex vs_3_0 ps_3_0)", "info": { "AzureCanvasBackend": "direct2d", "AzureSkiaAccelerated": 0, "AzureFallbackCanvasBackend": "cairo", "AzureContentBackend": "direct2d" } }, "javaScript": { "incrementalGCEnabled": true }, "accessibility": { "isActive": false, "forceDisabled": 0 }, "libraryVersions": { "NSPR": { "minVersion": "4.10.3", "version": "4.10.3" }, "NSS": { "minVersion": "3.15.5 Basic ECC", "version": "3.15.5 Basic ECC" }, "NSSUTIL": { "minVersion": "3.15.5", "version": "3.15.5" }, "NSSSSL": { "minVersion": "3.15.5 Basic ECC", "version": "3.15.5 Basic ECC" }, "NSSSMIME": { "minVersion": "3.15.5 Basic ECC", "version": "3.15.5 Basic ECC" } }, "userJS": { "exists": false }, "extensions": [] }
Moses
  • Moderator
459 個解決方法 3607 個答案
Can you try to see if it'll connect after creating a new profile? *https://support.mozilla.org/en-US/kb/Recovering%20important%20data%20from%20an%20old%20profile#w_create-a-new-firefox-profile

提出問題者

[Removed loads of contact info]

Created a new profile, still no luck. Interestingly when I click to check add-ons I get them same message. It's almost like firefox thinks there is no internet connection what so ever. I have basted my troubleshoot info with the new profile.

{

 "application": {
   "name": "Firefox",
   "version": "28.0",
   "userAgent": "Mozilla/5.0 (Windows NT 6.3; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0",
   "supportURL": "https://support.mozilla.org/1/firefox/28.0/WINNT/en-GB/"
},
 "crashes": {
   "submitted": [],
   "pending": 0
 },
 "modifiedPreferences": {
   "browser.cache.disk.capacity": 358400,
   "browser.cache.disk.smart_size.first_run": false,
   "browser.cache.disk.smart_size.use_old_max": false,
   "browser.cache.disk.smart_size_cached_value": 358400,
   "browser.places.smartBookmarksVersion": 6,
   "browser.sessionstore.upgradeBackup.latestBuildID": "20140314220517",
   "browser.startup.homepage_override.mstone": "28.0",
   "browser.startup.homepage": "http://www.google.co.uk",
   "browser.startup.homepage_override.buildID": "20140314220517",
   "extensions.lastAppVersion": "28.0",
   "gfx.direct3d.last_used_feature_level_idx": 0,
   "network.cookie.prefsMigrated": true,
   "places.history.expiration.transient_current_max_pages": 103710,
   "plugin.importedState": true,
   "plugin.disable_full_page_plugin_for_types": "application/pdf",
   "privacy.sanitize.migrateFx3Prefs": true
 },
 "graphics": {
   "numTotalWindows": 1,
   "numAcceleratedWindows": 0,
   "windowLayerManagerType": "Basic",
   "windowLayerManagerRemote": false,
   "numAcceleratedWindowsMessage": [
     ""
   ],
   "adapterDescription": "Intel(R) HD Graphics 4000",
   "adapterVendorID": "0x8086",
   "adapterDeviceID": "0x0166",
   "adapterRAM": "Unknown",
   "adapterDrivers": "igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32",
   "driverVersion": "10.18.10.3412",
   "driverDate": "1-22-2014",
   "adapterDescription2": "",
   "adapterVendorID2": "",
   "adapterDeviceID2": "",
   "adapterRAM2": "",
   "adapterDrivers2": "",
   "driverVersion2": "",
   "driverDate2": "",
   "isGPU2Active": false,
   "direct2DEnabled": false,
   "directWriteEnabled": false,
   "directWriteVersion": "6.3.9600.16384",
   "direct2DEnabledMessage": [
     ""
   ],
   "webglRenderer": "Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D9Ex vs_3_0 ps_3_0)",
   "info": {
     "AzureCanvasBackend": "skia",
     "AzureSkiaAccelerated": 0,
     "AzureFallbackCanvasBackend": "cairo",
     "AzureContentBackend": "cairo"
   }
 },
 "javaScript": {
   "incrementalGCEnabled": true
 },
 "accessibility": {
   "isActive": false,
   "forceDisabled": 0
 },
 "libraryVersions": {
   "NSPR": {
     "minVersion": "4.10.3",
     "version": "4.10.3"
   },
   "NSS": {
     "minVersion": "3.15.5 Basic ECC",
     "version": "3.15.5 Basic ECC"
   },
   "NSSUTIL": {
     "minVersion": "3.15.5",
     "version": "3.15.5"
   },
   "NSSSSL": {
     "minVersion": "3.15.5 Basic ECC",
     "version": "3.15.5 Basic ECC"
   },
   "NSSSMIME": {
     "minVersion": "3.15.5 Basic ECC",
     "version": "3.15.5 Basic ECC"
   }
 },
 "userJS": {
   "exists": false
 },
 "extensions": []

}

''[Removed loads of contact info]'' Created a new profile, still no luck. Interestingly when I click to check add-ons I get them same message. It's almost like firefox thinks there is no internet connection what so ever. I have basted my troubleshoot info with the new profile. { "application": { "name": "Firefox", "version": "28.0", "userAgent": "Mozilla/5.0 (Windows NT 6.3; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0", "supportURL": "https://support.mozilla.org/1/firefox/28.0/WINNT/en-GB/" }, "crashes": { "submitted": [], "pending": 0 }, "modifiedPreferences": { "browser.cache.disk.capacity": 358400, "browser.cache.disk.smart_size.first_run": false, "browser.cache.disk.smart_size.use_old_max": false, "browser.cache.disk.smart_size_cached_value": 358400, "browser.places.smartBookmarksVersion": 6, "browser.sessionstore.upgradeBackup.latestBuildID": "20140314220517", "browser.startup.homepage_override.mstone": "28.0", "browser.startup.homepage": "http://www.google.co.uk", "browser.startup.homepage_override.buildID": "20140314220517", "extensions.lastAppVersion": "28.0", "gfx.direct3d.last_used_feature_level_idx": 0, "network.cookie.prefsMigrated": true, "places.history.expiration.transient_current_max_pages": 103710, "plugin.importedState": true, "plugin.disable_full_page_plugin_for_types": "application/pdf", "privacy.sanitize.migrateFx3Prefs": true }, "graphics": { "numTotalWindows": 1, "numAcceleratedWindows": 0, "windowLayerManagerType": "Basic", "windowLayerManagerRemote": false, "numAcceleratedWindowsMessage": [ "" ], "adapterDescription": "Intel(R) HD Graphics 4000", "adapterVendorID": "0x8086", "adapterDeviceID": "0x0166", "adapterRAM": "Unknown", "adapterDrivers": "igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32", "driverVersion": "10.18.10.3412", "driverDate": "1-22-2014", "adapterDescription2": "", "adapterVendorID2": "", "adapterDeviceID2": "", "adapterRAM2": "", "adapterDrivers2": "", "driverVersion2": "", "driverDate2": "", "isGPU2Active": false, "direct2DEnabled": false, "directWriteEnabled": false, "directWriteVersion": "6.3.9600.16384", "direct2DEnabledMessage": [ "" ], "webglRenderer": "Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D9Ex vs_3_0 ps_3_0)", "info": { "AzureCanvasBackend": "skia", "AzureSkiaAccelerated": 0, "AzureFallbackCanvasBackend": "cairo", "AzureContentBackend": "cairo" } }, "javaScript": { "incrementalGCEnabled": true }, "accessibility": { "isActive": false, "forceDisabled": 0 }, "libraryVersions": { "NSPR": { "minVersion": "4.10.3", "version": "4.10.3" }, "NSS": { "minVersion": "3.15.5 Basic ECC", "version": "3.15.5 Basic ECC" }, "NSSUTIL": { "minVersion": "3.15.5", "version": "3.15.5" }, "NSSSSL": { "minVersion": "3.15.5 Basic ECC", "version": "3.15.5 Basic ECC" }, "NSSSMIME": { "minVersion": "3.15.5 Basic ECC", "version": "3.15.5 Basic ECC" } }, "userJS": { "exists": false }, "extensions": [] }

由 Moses 於 修改

Moses
  • Moderator
459 個解決方法 3607 個答案

有幫助的回覆

Hi,

I removed your business contact info to protect your privacy.
I've also escalated this thread to the full-time dedicated SUMO HelpDesk to see if they have anything to add to get Firefox up and running. In my opinion, I think it's rather odd that Firefox is spitting out connection error. Usually a new profile fixes it.

You might have to do a clean reinstall of Firefox. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

More information about reinstalling Firefox can be found here.

WARNING: Do not run Firefox's uninstaller or use a third party remover as part of this process, because that could permanently delete your Firefox data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. These cannot be recovered unless they have been backed up to an external device!

Hi, I removed your business contact info to protect your privacy. <br> I've also escalated this thread to the full-time dedicated SUMO HelpDesk to see if they have anything to add to get Firefox up and running. In my opinion, I think it's rather odd that Firefox is spitting out connection error. Usually a new profile fixes it.<br> You might have to do a clean reinstall of Firefox. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps: '''Note:''' You might want to print these steps or view them in another browser. #Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer. #After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu). #Delete the Firefox installation folder, which is located in one of these locations, by default: #*'''Windows:''' #**C:\Program Files\Mozilla Firefox #**C:\Program Files (x86)\Mozilla Firefox #*'''Mac:''' Delete Firefox from the Applications folder. #*'''Linux:''' If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see [[Installing Firefox on Linux]]. If you downloaded and installed the binary package from the [http://www.mozilla.org/firefox#desktop Firefox download page], simply remove the folder ''firefox'' in your home directory. #Now, go ahead and reinstall Firefox: ##Double-click the downloaded installation file and go through the steps of the installation wizard. ##Once the wizard is finished, choose to directly open Firefox after clicking the Finish button. More information about reinstalling Firefox can be found [https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems?esab=a&s=troubleshooting&r=3&as=s#w_5-reinstall-firefox here]. <b>WARNING:</b> Do not run Firefox's uninstaller or use a third party remover as part of this process, because that could permanently delete your Firefox data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. <u>These cannot be recovered unless they have been backed up to an external device!</u>
guigs 1072 個解決方法 11697 個答案

Moses and spidex_eales, sorry for the delay.

*Firefox can't load websites but other browsers can 

Please let us know if you have tried troubleshooting dns prefetching, if you are using ipv6 on your network, or the connection settings is set to No Poxy. Is your Firewall updated?http://kb.mozillazine.org/Firewalls

Looking forward to your reply!!

Moses and spidex_eales, sorry for the delay. *[[Firefox can't load websites but other browsers can]] Please let us know if you have tried troubleshooting dns prefetching, if you are using ipv6 on your network, or the connection settings is set to No Poxy. Is your Firewall updated?[http://kb.mozillazine.org/Firewalls] Looking forward to your reply!!