X
點擊此處開啟此網站的行動版。

技術支援討論區

The imbedded media player is playing media in Browser again after update to firefox 28. Make it stop!!

已張貼

I want mp3s to play in my Windows Media Player, not in a browser window. Apparently the update to firefox 28 took me back to where mp3s play in a browser window. How do I turn this option off....again!

I want mp3s to play in my Windows Media Player, not in a browser window. Apparently the update to firefox 28 took me back to where mp3s play in a browser window. How do I turn this option off....again!

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 12.0 r0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.30214.0
  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • GEPlugin
  • DIRECTV Player Plugin
  • CANON iMAGE GATEWAY Mycamera Plugin
  • np-mswmp

應用程式

  • Firefox 28.0
  • 使用者代理:Mozilla/5.0 (Windows NT 6.3; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/28.0/WINNT/en-US/

擴充套件

  • Get Mail Plus 3.4.10 (getmail@webdesigns.ms11.net)
  • Lightbeam 1.0.9 (jid1-F9UJ2thwoAm5gQ@jetpack)
  • Norton Toolbar 2014.6.5.1 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62})
  • Norton Vulnerability Protection 12.1.0.10 - 1 ({BBDA0591-3099-440a-AA10-41764D9DB4DB})
  • ReminderFox 2.1.4.2 ({ada4b710-8346-4b82-8199-5de2b400a6ae})
  • RES Player Plugin 1.9.7.1 ({3112ca9c-de6d-4884-a869-9855de680400})
  • Theme Font & Size Changer 7.7 ({f69e22c7-bc50-414a-9269-0f5c344cd94c})
  • Toolbar Buttons 1.0 ({03B08592-E5B4-45ff-A0BE-C1D975458688})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Address Bar Search 1.2 ({badea1ae-72ed-4f6a-8c37-4db9a4ac7bc9}) (Inactive)
  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • Garmin Communicator 4.1.0 ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E}) (Inactive)
  • Logitech SetPoint 6.5 ({F003DA68-8256-4b37-A6C4-350FA04494DF}) (Inactive)
  • Social Fixer 7.801 (socialfixer@mattkruse.com) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: NVIDIA GeForce GT 640
  • adapterDescription2:
  • adapterDeviceID: 0x0fc0
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 300
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.3.9600.16384
  • driverDate: 3-4-2014
  • driverDate2:
  • driverVersion: 9.18.13.3523
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 640 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

修改過的偏好設定

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 6
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140314220517
  • browser.startup.homepage: http://www.centurylink.net/
  • browser.startup.homepage_override.buildID: 20140314220517
  • browser.startup.homepage_override.mstone: 28.0
  • browser.tabs.onTop: False
  • browser.tabs.warnOnClose: False
  • dom.max_script_run_time: 0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 28.0
  • font.internaluseonly.changed: True
  • gfx.direct2d.disabled: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • layers.acceleration.disabled: True
  • media.webm.enabled: False
  • media.windows-media-foundation.enabled: False
  • media.windows-media-foundation.play-stand-alone: False
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1395532588
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf,audio/mpeg,audio/x-mpeg
  • plugin.importedState: True
  • plugin.state.npadobeaamdetect: 0
  • plugin.state.npappdetector: 0
  • plugin.state.npauthz: 0
  • plugin.state.npctrl: 2
  • plugin.state.npgarmin: 0
  • plugin.state.npgoogleupdate: 0
  • plugin.state.npintelwebapiipt: 0
  • plugin.state.npintelwebapiupdater: 0
  • plugin.state.npitunes: 0
  • plugin.state.npmcffplg: 0
  • plugin.state.npmcsnffpl: 0
  • plugin.state.npmvtplugin: 0
  • plugin.state.npnv3dv: 0
  • plugin.state.npnv3dvstreaming: 0
  • plugin.state.nppdf: 0
  • plugin.state.npplayerplugin: 2
  • plugin.state.npqtplugin: 2
  • plugin.state.nprnowplugin: 0
  • plugin.state.npspwrap: 0
  • plugin.state.npwlpg: 0
  • plugins.load_appdir_plugins: True
  • privacy.popups.showBrowserMessage: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1393362542

其他

  • User JS: 否
  • 輔助功能: 否
Wesley Branton
  • Top 25 Contributor
725 個解決方法 5689 個答案

Do the following:

  • Open the Firefox Options
  • Select the Applications tab
  • Locate all MP3 file types
  • Change each MP3 action to Other...
  • Select Windows Media Player from the list
  • Click Ok
  • Restart Firefox

This should open all MP3 files in Windows Media Player.

Do the following: *Open the Firefox Options *Select the ''Applications'' tab *Locate all MP3 file types *Change each MP3 action to ''Other...'' *Select Windows Media Player from the list *Click ''Ok'' *Restart Firefox This should open all MP3 files in Windows Media Player.

有幫助的回覆

That's what was selected and I've even changed the option to download and the links still opens an in-browser player. The last time this happened it was because of the "windows-media-foundation player" being enabled which had to be disabled in "about-config". As far as I can tell that option is still disabled so it must be new code added in the last update.

That's what was selected and I've even changed the option to download and the links still opens an in-browser player. The last time this happened it was because of the "windows-media-foundation player" being enabled which had to be disabled in "about-config". As far as I can tell that option is still disabled so it must be new code added in the last update.

有幫助的回覆

I found, by accident, changing to "false": "media.directshow.enabled" in about:config resolved the problem. I'm not sure why, since I'm on a Windows 8.1 (64) PC running the latest version of WMP, and the article I found this on was related to Windows XP. I have to assume if I had disabled this before then the latest update turned it back on.

I found, by accident, changing to "false": "media.directshow.enabled" in about:config resolved the problem. I'm not sure why, since I'm on a Windows 8.1 (64) PC running the latest version of WMP, and the article I found this on was related to Windows XP. I have to assume if I had disabled this before then the latest update turned it back on.
cor-el
  • Top 10 Contributor
  • Moderator
17881 個解決方法 161785 個答案

For Windows Vista and later this would be the media.windows-media-foundation.enabled pref.

For Windows Vista and later this would be the media.windows-media-foundation.enabled pref.

提出問題者

That's how it worked before, but that option had already been changed before (on version 20 something or the other, whenever that got added) and was still disabled when I went to change it (again). As I mentioned above the thing that fixed it was changing "media.directshow.enabled" to false (which according to everything I read should only affect Windows XP PCs, my PC is running Windows 8.1 (64) )

That's how it worked before, but that option had already been changed before (on version 20 something or the other, whenever that got added) and was still disabled when I went to change it (again). As I mentioned above the thing that fixed it was changing "media.directshow.enabled" to false (which according to everything I read should only affect Windows XP PCs, my PC is running Windows 8.1 (64) )