X
點擊此處開啟此網站的行動版。

技術支援討論區

html5 audio

已張貼

How i can configure audio output in html5? Firefox html5 plays only on first ALSA sound card ignoring my ~/.asoundrc in home directory. But other sounds like plugins Flash and other according to ~/.asoundrc work fine for me in firefox. My system: Debian Jessie x86_64 Browser: firefox v28.0 x86_64 Audio: ALSA only (no pulseaudio, no OSS, no phonon ... etc)

Problem only with html5 audio

How i can configure audio output in html5? Firefox html5 plays only on first ALSA sound card ignoring my ~/.asoundrc in home directory. But other sounds like plugins Flash and other according to ~/.asoundrc work fine for me in firefox. My system: Debian Jessie x86_64 Browser: firefox v28.0 x86_64 Audio: ALSA only (no pulseaudio, no OSS, no phonon ... etc) Problem only with html5 audio

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 11.2 r202

應用程式

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:28.0) Gecko/20100101 Firefox/28.0

更多資訊

guigs 1072 個解決方法 11697 個答案

Try to update flash and Shockwave, I do not know if your drivers are up to date either, but it looks like ALSA looks for the graphics device? Upgrade your graphics drivers to use hardware acceleration and WebGL

Wait, wait, there was an old bug I found, it moved from alsa to oss

  • Bug 503691 - ALSA is required to build media backends on Linux

https://bugs.gentoo.org/show_bug.cgi?id=276354#c5

Work arounds that I found in other forums:

Have you tried these already? I hope this helps.

Try to update flash and Shockwave, I do not know if your drivers are up to date either, but it looks like ALSA looks for the graphics device? [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Wait, wait, there was an old bug I found, it moved from alsa to oss *Bug 503691 - ALSA is required to build media backends on Linux https://bugs.gentoo.org/show_bug.cgi?id=276354#c5 Work arounds that I found in other forums: *Gentoo [https://forums.gentoo.org/viewtopic-t-923736-start-0.html] *linux questions [http://www.linuxquestions.org/questions/linux-hardware-18/linux-and-alsa-default-sound-card-two-methods-fail-to-set-firefox-chrome-sound-4175479415/] Have you tried these already? I hope this helps.