X
點擊此處開啟此網站的行動版。

技術支援討論區

此討論串已經關閉並封存。 如果您有需要幫助,請新增一個新問題

Firefox says Java is out of date but it's not

已張貼

The Plugin checker says my Java is out of date but it's not

The Plugin checker says my Java is out of date but it's not

被選擇的解決方法

Your system details list of installed plugins shows, "Next Generation Java Plug-in 10.51.2 for Mozilla browsers". If you check the "Do I have Java?" link at http://www.java.com/en/download/ and run the Java Detection applet it should tell you that you have the recommended version of Java installed (Version 7 Update 51).

This is a PluginCheck bug so there is no need to do anything:

  • Bug 985968 - Mozilla Plugin check page displays Java plugin as vulnerable even if the latest version is installed.

(See Bugzilla Etiquette. Please don't comment in bug reports unless you have something constructive to add.)

從原來的回覆中察看解決方案 10

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 12.0 r0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.30214.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • iTunes Detector Plug-in
  • 1,2,1,2044
  • Yahoo Application State Plugin version 1.0.0.7
  • Office Live Update v1.5
  • NPWLPG
  • Virtual Earth 3D 4.00100226006 plugin for Mozilla
  • CANON iMAGE GATEWAY Mycamera Plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Yahoo! activeX Plug-in Bridge

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:27.0) Gecko/20100101 Firefox/27.0

更多資訊

Andrew
  • Moderator
321 個解決方法 4047 個答案

Hi!

I can seem to reproduce this issue.

Please also see /questions/991063

Hi! I can seem to reproduce this issue. Please also see [/questions/991063]
AliceWyman
  • Moderator
240 個解決方法 2597 個答案

選擇的解決方法

Your system details list of installed plugins shows, "Next Generation Java Plug-in 10.51.2 for Mozilla browsers". If you check the "Do I have Java?" link at http://www.java.com/en/download/ and run the Java Detection applet it should tell you that you have the recommended version of Java installed (Version 7 Update 51).

This is a PluginCheck bug so there is no need to do anything:

  • Bug 985968 - Mozilla Plugin check page displays Java plugin as vulnerable even if the latest version is installed.

(See Bugzilla Etiquette. Please don't comment in bug reports unless you have something constructive to add.)

Your system details list of installed plugins shows, "Next Generation Java Plug-in 10.51.2 for Mozilla browsers". If you check the "[http://www.java.com/en/download/installed.jsp?detect=jre Do I have Java?]" link at http://www.java.com/en/download/ and run the Java Detection applet it should tell you that you have the recommended version of Java installed (Version 7 Update 51). This is a PluginCheck bug so there is no need to do anything: *[https://bugzilla.mozilla.org/show_bug.cgi?id=985968 Bug 985968] - Mozilla Plugin check page displays Java plugin as vulnerable even if the latest version is installed. (See [https://bugzilla.mozilla.org/page.cgi?id=etiquette.html Bugzilla Etiquette]. Please don't comment in bug reports unless you have something constructive to add.)
miffed214 0 個解決方法 7 個答案

有幫助的回覆

There seems to be a SEVERE lack of information on this issue and evidently no one is doing anything about it.

The available info simply leads you in circles.

There seems to be a SEVERE lack of information on this issue and evidently no one is doing anything about it. The available info simply leads you in circles.
AliceWyman
  • Moderator
240 個解決方法 2597 個答案

有幫助的回覆

Here's the story:

Oracle released Java 8 and Mozilla updated the PluginCheck page, which seems to have caused Java 7 Update 51 to be detected as vulnerable. PluginCheck sends you to http://www.java.com/en/download/manual.jsp where it shows Java 7 Update 51 as the recommended version.

Java 8 isn't offered yet at java.com ..... Here's Java's article on that:

Long story short: there's no need to do anything.

Here's the story: Oracle released Java 8 and Mozilla updated the PluginCheck page, which seems to have caused Java 7 Update 51 to be detected as vulnerable. PluginCheck sends you to http://www.java.com/en/download/manual.jsp where it shows Java 7 Update 51 as the recommended version. Java 8 isn't offered yet at java.com ..... Here's Java's article on that: *http://www.java.com/en/download/faq/java8.xml ''Why is Java 8 not available on java.com? '' Long story short: there's no need to do anything.
soundwave 5 個解決方法 90 個答案

Unless you want the firefox plugin check to report things accurately to the user...

Unless you want the firefox plugin check to report things accurately to the user...
AliceWyman
  • Moderator
240 個解決方法 2597 個答案

soundwave, I meant that there's no need for you or other users to do anything. Of course, Mozilla developers should fix the plugincheck page! See the bug report I posted earlier.

'''soundwave''', I meant that there's no need for you or other users to do anything. Of course, Mozilla developers should fix the plugincheck page! See the bug report I posted earlier.
soundwave 5 個解決方法 90 個答案

I retract my statement and tip my hat to you

I retract my statement and tip my hat to you

提出問題者

So it's been over a month now, Java released version 10.55 and it was still broke. I updated Firefox to version 29 yesterday and hoped it would be fixed, but no joy. This must be a tough problem. Any idea when it will be fixed?

So it's been over a month now, Java released version 10.55 and it was still broke. I updated Firefox to version 29 yesterday and hoped it would be fixed, but no joy. This must be a tough problem. Any idea when it will be fixed?
AliceWyman
  • Moderator
240 個解決方法 2597 個答案

Mozilla is still working on the bug. At least they've added a note to the top of the Plugin Check page, explaining the detection problem. For details, see this article:

Mozilla PluginCheck webpage identifies the latest Java 7 plugin as vulnerable

Mozilla is still working on the bug. At least they've added a note to the top of the [http://www.mozilla.org/en-US/plugincheck/ Plugin Check page], explaining the detection problem. For details, see this article: [http://kb.mozillazine.org/Java#Mozilla_PluginCheck_webpage_identifies_the_latest_Java_7_plugin_as_vulnerable Mozilla PluginCheck webpage identifies the latest Java 7 plugin as vulnerable]

提出問題者

Thanks Alice, I saw the note several weeks ago. I was hoping for a fix in the new version. Oh well, Patience, Patience.

Thanks Alice, I saw the note several weeks ago. I was hoping for a fix in the new version. Oh well, Patience, Patience.
sununpa 0 個解決方法 3 個答案

OK, understood, however...

I get the same message with Flash and I'm new here so there's no telling what else might show up. For the record, I just happened to have updated pretty much everything on my machine (Java, Flash, Adobe, etc...) before installing FF.

Perhaps it has something to do with the fact I was running IE 8 when I did the updates? 8=\

Nevertheless, the plugin checker here does say they are all up to date. Except for the Presentation thingy, but that's another subject. 8=]

OK, understood, however... I get the same message with Flash and I'm new here so there's no telling what else might show up. For the record, I just happened to have updated pretty much everything on my machine (Java, Flash, Adobe, etc...) before installing FF. Perhaps it has something to do with the fact I was running IE 8 when I did the updates? 8=\ Nevertheless, the plugin checker here does say they are all up to date. Except for the Presentation thingy, but that's another subject. 8=]
AliceWyman
  • Moderator
240 個解決方法 2597 個答案

To sununpa, I couldn't tell if you were just making a comment or if you have a question about updating Flash or other plugins. You can test your Flash Player in Firefox by visiting this Adobe page:

The latest version of the Flash plugin for Firefox is currently 14.0.0.179. Internet Explorer uses a different Flash Player; the latest Flash for IE is currently 14.0.0.176. See this article if you need more help with the Flash plugin used in Firefox:

If you have other problems with plugins using Firefox please ask a new question. See Forum rules and guidelines: For support requests, do not re-use existing threads started by others, even if they are seemingly on the same subject. Ask a new question instead.

I'll close this thread.

'''To sununpa,''' I couldn't tell if you were just making a comment or if you have a question about updating Flash or other plugins. You can test your Flash Player in Firefox by visiting this Adobe page: * http://www.adobe.com/software/flash/about/ The latest version of the Flash plugin for Firefox is currently 14.0.0.179. Internet Explorer uses a different Flash Player; the latest Flash for IE is currently 14.0.0.176. See this article if you need more help with the Flash plugin used in Firefox: * [[Flash Plugin - Keep it up to date and troubleshoot problems]] If you have other problems with plugins using Firefox please [/questions/new ask a new question]. See [[Forum rules and guidelines]]: ''For support requests, do not re-use existing threads started by others, even if they are seemingly on the same subject. Ask a new question instead.'' I'll close this thread.
the-edmeister
  • Top 25 Contributor
  • Moderator
5406 個解決方法 40228 個答案

Perhaps it has something to do with the fact I was running IE 8 when I did the updates?

IE uses a different version of Flash (ActiveX) than what is needed for Firefox, the Plugin version.

'''''Perhaps it has something to do with the fact I was running IE 8 when I did the updates? ''''' IE uses a different version of Flash (ActiveX) than what is needed for Firefox, the Plugin version.