搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox crashes

  • 18 回覆
  • 5 有這個問題
  • 183 次檢視
  • 最近回覆由 pashadad

more options

I am using Windows vista in my dell studio xps 16 laptop when ever i load Facebook messages Firefox crashes or freezes sometimes opening other windows also cause it to crash but mostly its Facebook that causes this.

these are the crash reports bp-cac1af48-e509-48a3-b9f1-4e99a2140206 bp-42699329-c3d4-48d6-811b-d74a72140206

所有回覆 (18)

more options

pls update ur firefox browser

more options

Try to disable hardware acceleration in Firefox (you need to close and restart Firefox).

more options

Greetings cor-el i had disabled hardware acceleration months back when this problem initially started but that didn't not solve the issue.

As Gaurav pareek said i have updated Firefox if the problem persist i shall get back in a couple of hours

more options

Unfortunately Firefox has crashed again i had forgot to mention that Firefox is taking much memory nearly 1GB

this is the crash report bp-977e2208-4034-4423-8451-1bf3e2140207

more options

bp-7c9157f3-6350-4e26-b4f3-f3e602140213 Crashed again :(

more options

7b63791b-a23f-450f-b957-1b6c499817c7 2/20/2014 3:36 PM

bp-4d446ade-0bd1-4adb-9c25-44d3f2140220 2/20/2014 1:24 PM

bp-458dd0e1-6c02-4bf1-8bd4-3655f2140220 2/20/2014 12:25 PM

bp-aa77aead-3e5b-4f5e-83c2-dd6832140219 2/20/2014 12:05 AM

bp-321613c9-f58a-48d6-b933-67f722140219 2/19/2014 4:32 PM

4ada29b7-618b-43b0-a3b3-d800c28e0676 2/19/2014 3:07 PM

bp-b437bf72-f846-4039-8b77-01c392140218 2/18/2014 1:10 PM

ea135702-aae5-4c96-994a-ce2901e00861 2/17/2014 6:15 PM

bp-80fefdee-7a36-4288-943e-a91262140217 2/17/2014 4:32 PM

bp-ffbedea1-a8d3-46bb-a9fe-ff8702140216 2/16/2014 11:47 PM

bp-43dbe4f2-e220-45a7-977c-7b1cd2140216 2/16/2014 6:00 PM

bp-c16327b5-853c-43ec-8dff-0eb5b2140215 2/16/2014 2:22 AM

bp-7c9157f3-6350-4e26-b4f3-f3e602140213 2/14/2014 1:29 AM

more options
more options

i has tried that before but it does not solve the issue

more options

ambroochi,

I see you posted earlier this month and I'm sorry it's taken so long to resolve this issue

Looks from your crash reports it shows that xul.dll is the file that crashes Firefox (xul.dll is a file that is installed with Firefox).

I can suggest doing a clean re-install which is different from resetting Firefox as mentioned by Aman Routh before me.


Please read the WARNING at the bottom before proceeding with these steps

A clean re-install means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

More information about reinstalling Firefox can be found here.

WARNING: Do not run Firefox's uninstaller or use a third party remover as part of this process, because that could permanently delete your Firefox data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. These cannot be recovered unless they have been backed up to an external device!

Please report back to see if this helped you!

Thank you.

more options

If that doesn't work, you might want to try starting Firefox in Safe Mode as one of your extensions might be causing the problem. Here's how to start it ---

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that turns off some settings and disables most add-ons (extensions and themes).

(If you're using an added theme, switch to the Default theme.)

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu by clicking on the Restart with Add-ons Disabled... menu item:
FirefoxSafeMode

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Thank you.

more options

Thanks for the detailed reply Moses I shall execute it and revert if the problem persist ,if not i am thankful for your help

more options

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.

more options

Moses I tried ur methods and it still continues to crash :(

bp-a7660444-3c99-4729-be5f-d04c12140224 2/24/2014 12:37 PM
bp-5315f9be-887e-43a1-a1bc-7aa8b2140223 2/23/2014 5:14 PM
bp-00f5cc1f-3815-45fc-9348-7df1e2140223 2/23/2014 4:42 PM
081a9bb6-4afb-4b26-9c28-d26a2b7a8032 2/23/2014 12:32 AM
bp-511ec8f0-82dc-4da6-857a-aa9932140221 2/21/2014 11:51 PM
bp-4cac726e-e597-4f0d-af76-89fe12140221 2/21/2014 1:11 PM
bp-423e9643-e0ba-4de7-83ec-fc3312140220 2/21/2014 12:02 AM

由 cor-el 於 修改

more options

Try to disable hardware acceleration in Firefox (you need to close and restart Firefox).

Try to set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled. See also comment 414 in bug 812695:

That way you still have the benefit from hardware acceleration, but may not suffer from rendering issues.

You can also try to uninstall Windows update KB2670838 if you have this update.

more options

i have tried all ur suggestions cor-el but it does not seem to work  :(

bp-ecfaa8dc-712a-4b91-8344-08d6d2140305 3/5/2014 1:31 PM
bp-75dff512-4705-49ef-82ff-a40f22140304 3/5/2014 1:35 AM
bp-365d452a-3ec6-425b-ac1f-7e30a2140304 3/4/2014 6:41 PM
b43d013e-7df7-48ac-ab59-dfd39fd3b051 3/4/2014 4:06 PM
bp-e557997e-5d79-4465-983e-624262140303 3/3/2014 11:36 PM
bp-d73ed354-2c59-4750-a0c0-44fea2140303 3/3/2014 4:18 PM
bp-afb801d5-3b24-496a-b334-fde022140302 3/2/2014 8:27 PM
bp-33f45fa5-b47c-4746-99e6-231c72140302 3/2/2014 3:33 PM
bp-5327b072-d070-426a-ab14-556a42140301 3/1/2014 1:59 PM
bp-8c36dd64-1820-4f10-96c9-1bd382140228 2/28/2014 1:00 PM
bp-effe3ec0-5d5c-4c89-823d-330882140227 2/27/2014 4:27 PM
bp-9b99b2a1-6ce0-417b-938a-d459c2140226 2/26/2014 11:56 PM

由 cor-el 於 修改

more options

Those are out-of-memory crash reports, so those signature are different from the ones you posted above.

more options

i have been using RAMBack plugin and its helping in minimizing the crashes but still its crashes :(

bp-c409e19b-4da9-4357-9ff1-b1a712140319 3/19/2014 5:54 PM bp-b995481c-cec6-4ace-8480-d9c262140319 3/19/2014 4:39 PM a29d6386-c25d-4615-a999-44a5f0928ca4 3/19/2014 12:33 PM 22f27b94-cd10-4dbf-8a7f-d2076aeb2412 3/18/2014 11:36 AM bp-60fba482-1316-4863-a39d-26d412140317 3/17/2014 5:15 PM 1ece60bf-d61f-48d6-aa58-79f23fb47ea2 3/17/2014 12:44 PM bp-c69e2ad9-5ccc-442c-8b87-ede262140316 3/17/2014 1:32 AM bp-65844556-a1e5-4b19-a715-9c92a2140314 3/15/2014 2:33 AM bp-aa209e11-ce8d-4e93-9616-d243c2140312 3/12/2014 2:45 PM bp-526bce37-e8e2-4f6d-9d10-77d8c2140311 3/11/2014 10:47 PM bp-ed6aa0ea-2f0e-4fb7-90f9-d7fb02140311 3/11/2014 11:38 AM bp-121e482e-4ba1-43e1-9c9e-1bcd92140310 3/10/2014 6:08 PM bp-bb2e1526-2aea-46e5-9c2e-331a52140308 3/9/2014 1:47 AM bp-f454b0d4-734e-4748-b694-9444b2140308 3/8/2014 2:50 PM bp-efa56191-1428-4c06-bc4d-7aeca2140307 3/7/2014 4:00 PM bp-31301d00-ef6e-4e8b-b9f8-b61132140306 3/7/2014 12:21 AM

more options

I updated to FF 28. Then I could not even click a tab with the constant crashes.

I used Cor-els [TY Cor-el!] fix of:

disabling hardware acceleration = Options/general tab/ un-check "use hardware acceleration". - That fixed the FF 28 crash problem for me.

W 8 // Dell XPS AIO 27

FF I love your browser, but it keeps becoming more and more problematic :( You all need to REALLY test new releases to the general public prior to updates. You are starting to act like microsoft - uggggh!

由 pashadad 於 修改