X
點擊此處開啟此網站的行動版。

技術支援討論區

How do I get rid of 'sweet page' after having used malware softw., reestablishing firefox as hyperlink, rebooting ?

已張貼

It is not the described sweet pack' but 'sweet page' - presents itself as search engine - supposedly from the Netherlands. I have run malwarebytes anti-malware - no malware found - I reestablished mozilla as hyperlink - rebooted twice - didn't help, it keeps popping up whenever I try t open a new tab. must have happened when I updated Java from the Java homepage. How can I get rid of that? Thank you very much for your efforts, with kind regards Irene Fritz

It is not the described ''sweet pack' but 'sweet page' - presents itself as search engine - supposedly from the Netherlands. I have run malwarebytes anti-malware - no malware found - I reestablished mozilla as hyperlink - rebooted twice - didn't help, it keeps popping up whenever I try t open a new tab. must have happened when I updated Java from the Java homepage. How can I get rid of that? Thank you very much for your efforts, with kind regards Irene Fritz

額外的系統細節

已安裝的外掛程式

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • Shockwave Flash 11.9 r900
  • Google Update
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.4.144
  • Amazon MP3 Downloader Plugin 1.0.17
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Npdsplay dll

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:26.0) Gecko/20100101 Firefox/26.0

更多資訊

Diego Victor 658 個解決方法 4175 個答案

First try reset your home page:

To remove from search engine:

First try reset your home page: *[https://support.mozilla.org/en-US/kb/How%20to%20set%20the%20home%20page How to set the home page] To remove from search engine: *[https://support.mozilla.org/en-US/kb/search-bar-easily-choose-your-search-engine#w_removing-a-search-engine Removing a search engine]
jscher2000
  • Top 10 Contributor
8797 個解決方法 71955 個答案

有幫助的回覆

There's also a separate, hidden setting for new tabs:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

Two gotchas:

  • If Firefox ignores the setting, one of your extensions may be overriding it. You can review, disable, and/or remove extensions on the add-ons page:

    orange Firefox button (or Tools menu) > Add-ons > in the left column click Extensions
  • If the change works for the rest of your session but at the next startup is back to the unwanted page, you might have a user.js file in your personal Firefox settings folder (your Firefox profile folder). This article describes how to track down and remove the file: How to fix preferences that won't save.

Any luck?

There's also a separate, hidden setting for new tabs: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''newtab''' and pause while the list is filtered (3) Double-click the '''browser.newtab.url''' preference and enter your preferred page: * ''Page thumbnails (default)'' => about:newtab * ''Blank tab'' => about:blank * ''Built-in Firefox home page'' => about:home * ''Any other page'' => full URL to the page Press Ctrl+t to open a new tab and verify that it worked. Fixed? Two gotchas: * If Firefox ignores the setting, one of your extensions may be overriding it. You can review, disable, and/or remove extensions on the add-ons page:<br><br>orange Firefox button (or Tools menu) > Add-ons > ''in the left column click'' Extensions * If the change works for the rest of your session but at the next startup is back to the unwanted page, you might have a user.js file in your personal Firefox settings folder (your Firefox profile folder). This article describes how to track down and remove the file: [[How to fix preferences that won't save]]. Any luck?