搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox build 28 and 29 do not start when installed

  • 6 回覆
  • 9 有這個問題
  • 14 次檢視
  • 最近回覆由 Zakashi

more options

Ever since November any build past Firefox 27 has installed but immediately crashes after a few seconds without ever opening the firefox application. Every single nightly build I have attempted to try has the same problem, the 64 bit builds are no longer properly opening for me. They throw a windows crash report, not even the Mozilla one. I have tried resetting firefox, and uninstalling, i've tried portable builds and simply running the extracted updates.

被選擇的解決方法

Okay, after reading an article about signing of x64 builds from dec 2011, I attempted to run the x64 build from last night in compatibility mode, initially for windows vista because it was on top. It executed whilst my nightly 27 build was running and i promptly closed both to duplicate the result. When it worked a second time by itself, I replaced my install with the zip contents and it proceeded to launch normally with compatibility mode windows 7. It loaded 12/30 build and then updated to the 1/14 build successfully.

從原來的回覆中察看解決方案 👍 1

所有回覆 (6)

more options

Worksforme. I do not often use Windows but my Windows 7 64 bit is running the 32 bit Fx 28.0a2 (2014-01-10) and an up-to-date Nightly 32 bit.

  • My users agent strings
    Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0
    Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
  • Yours per info aside User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:27.0) Gecko/20100101 Firefox/27.0
    So you appear to be running and posting from an (old ?) 64 bit version of Firefox.

You are going to have to try to investigate the Windows crashes.

Why are you trying to run 64 bit versions. The supported versions for Windows are 32 bit versions.

Are you able to confirm you have a 32bit version of Firefox installed for day-to-day browsing that runs ok ?

more options

I am running the 64bit version for testing purposes, nightly build 27 from late october runs fine in 64. Meanwhile, 32bit nightly build from today starts and opens. However the 64 bit nightly build from today does not open. Those user agent strings I am not sure, the 27 build runs fine, but when it updates to current it installs fine and then crashes. It is not a major concern as I can manage with an outdated build, but I haven't been able to update the 64 bit build for 2 versions now and its kind of annoying.

more options

64 bit Firefox builds for Windows are merely generated for testing for compilation errors and make sure that the compilation finishes properly and are not subjected to tests like the 32 bit Firefox versions and thus can fail at any time. So using this 64 version is at your own risk.

more options

Win64 builds are Tier-3 compared to the officially supported Tier-1 builds which include the Win32 Nightly channel builds. The Tier-3 builds and servers are not a priority to get fixed should any problems arise. https://developer.mozilla.org/en-US/docs/Supported_build_configurations

You could also post in and follow the Builds threads in http://forums.mozillazine.org/viewforum.php?f=23

more options

Yeah, I realize that the x64 nightly builds of of minor concern and that they are naturally buggy. But I find it difficult to believe that this is some sort of widespread problem plaguing thousands of users. It is just a problem that has occurred for me for 2 complete builds and every single nightly release since november.

more options

選擇的解決方法

Okay, after reading an article about signing of x64 builds from dec 2011, I attempted to run the x64 build from last night in compatibility mode, initially for windows vista because it was on top. It executed whilst my nightly 27 build was running and i promptly closed both to duplicate the result. When it worked a second time by itself, I replaced my install with the zip contents and it proceeded to launch normally with compatibility mode windows 7. It loaded 12/30 build and then updated to the 1/14 build successfully.