X
點擊此處開啟此網站的行動版。

技術支援討論區

How to fix this problem? Secure Connection Failed, SSL received a record with an incorrect Message Authentication Code. (Error code: ssl_error_bad_mac_read)

已張貼

Secure Connection Failed SSL received a record with an incorrect Message Authentication Code. (Error code: ssl_error_bad_mac_read)

I have been receiving this error message recently when I tried to access school elearning websites and other school related websites, I have also tried on internet explorer and it shows page cannot be displayed. I have been trying the available solutions to solve it but none of them work. Is there alternative solutions available? Please advise. Thanks.

Secure Connection Failed SSL received a record with an incorrect Message Authentication Code. (Error code: ssl_error_bad_mac_read) I have been receiving this error message recently when I tried to access school elearning websites and other school related websites, I have also tried on internet explorer and it shows page cannot be displayed. I have been trying the available solutions to solve it but none of them work. Is there alternative solutions available? Please advise. Thanks.

被選擇的解決方法

That link works fine for me. I'm not seeing any error message.

What are the connection settings?

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":


從原來的回覆中察看解決方案 4

額外的系統細節

已安裝的外掛程式

  • Google Update
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.7.148
  • Shockwave Flash 11.9 r900
  • 5.1.20913.0
  • McAfee MSS+ NPAPI Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.8
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPWLPG
  • McGraw Hill Chemdraw Plugin 12.0.3.1267
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

應用程式

  • Firefox 26.0
  • 使用者代理:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/26.0/WINNT/en-US/

擴充套件

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • ooVoo toolbar, powered by Ask.com 3.15.2.23037 (toolbar@ask.com) (Inactive)
  • Skype Click to Call 6.13.0.13771 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2: NVIDIA GeForce 410M
  • adapterDeviceID: 0x0126
  • adapterDeviceID2: 0x1054
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 1023
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 1-20-2011
  • driverDate2: 10-2-2012
  • driverVersion: 8.15.10.2287
  • driverVersion2: 9.18.13.697
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

修改過的偏好設定

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131205075310
  • browser.startup.homepage: http://www.google.com.sg/
  • browser.startup.homepage_override.buildID: 20131205075310
  • browser.startup.homepage_override.mstone: 26.0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 26.0
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • keyword.URL: http://websearch.ask.com/redirect?client=ff&src=kw&tb=OVO2&o=2164&locale=en_US&apn_uid=fb1fb11e-2a8b-45a7-a561-1f5d1031aef3&apn_ptnrs=%5EA2N&apn_sauid=BDFF6FA9-5D16-47B9-B703-2C018EE39F9F&apn_dtid=%5EYYYYYY%5EYY%5ESG&&q=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1388825690
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.enable_md5_signatures: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1387108481

其他

  • User JS: 否
  • 輔助功能: 是
cor-el
  • Top 10 Contributor
  • Moderator
17690 個解決方法 160039 個答案

Can you post a link to a publicly accessible page that doesn't require authentication (signing on)?

Can you reach this page via a normal http connection in case the server isn't set up properly?

You may have to use "Forget About This Site" to make Firefox use a http connection.

You can try to test if there is a problem with TLS by temporarily disabling TLS.

You can set the security.tls.version.min and security.tls.version.max prefs to 0 to disable TLS (0 means SSL3).
You may need to close and restart Firefox after changing these prefs.

security.tls.version.min = 0
security.tls.version.max = 0

Note that this is only meant as a quick test and you should reset the two prefs afterward.

Can you post a link to a publicly accessible page that doesn't require authentication (signing on)? Can you reach this page via a normal http connection in case the server isn't set up properly? You may have to use "Forget About This Site" to make Firefox use a http connection. You can try to test if there is a problem with TLS by temporarily disabling TLS. You can set the security.tls.version.min and security.tls.version.max prefs to 0 to disable TLS (0 means SSL3).<br /> You may need to close and restart Firefox after changing these prefs. security.tls.version.min = 0 security.tls.version.max = 0 *http://kb.mozillazine.org/security.tls.version.*<br />0 means SSL 3.0, 1 means TLS 1.0, 2 means TLS 1.1, etc. *http://kb.mozillazine.org/about:config Note that this is only meant as a quick test and you should reset the two prefs afterward.

有幫助的回覆

Thank you for your advice, I've tried temporarily disabling TLS and restart Firefox but it didn't work.

Sorry, but may I ask you what do you mean by:

"Can you post a link to a publicly accessible page that doesn't require authentication (signing on)?

Can you reach this page via a normal http connection in case the server isn't set up properly?"

Thank you for your advice, I've tried temporarily disabling TLS and restart Firefox but it didn't work. Sorry, but may I ask you what do you mean by: "Can you post a link to a publicly accessible page that doesn't require authentication (signing on)? Can you reach this page via a normal http connection in case the server isn't set up properly?"
cor-el
  • Top 10 Contributor
  • Moderator
17690 個解決方法 160039 個答案

That is about the address (URL) of the website that you try to visit.

Then we can see if the problem occurs for us as well or only a problem on your side.

That is about the address (URL) of the website that you try to visit. Then we can see if the problem occurs for us as well or only a problem on your side.

提出問題者

This is the link: https://learn.nyp.edu.sg/webapps/portal/frameset.jsp

I have also tried using another computer at home to access the link with Firefox but the same error message appeared.

This is the link: https://learn.nyp.edu.sg/webapps/portal/frameset.jsp I have also tried using another computer at home to access the link with Firefox but the same error message appeared.
cor-el
  • Top 10 Contributor
  • Moderator
17690 個解決方法 160039 個答案

選擇的解決方法

That link works fine for me. I'm not seeing any error message.

What are the connection settings?

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":


That link works fine for me. I'm not seeing any error message. What are the connection settings? *Tools > Options > Advanced > Network : Connection > Settings *https://support.mozilla.org/kb/Options+window+-+Advanced+panel If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly. See "Firefox connection settings": *https://support.mozilla.org/kb/Firefox+cannot+load+websites+but+other+programs+can ---- *http://kb.mozillazine.org/Error_loading_websites

有幫助的回覆

It works after I disabled IPv6 in Firefox. Thank you for your help :)

It works after I disabled IPv6 in Firefox. Thank you for your help :)