X
點擊此處開啟此網站的行動版。

技術支援討論區

something unexpected went wrong with this url...class not registered

已張貼

Cannot open links in Outlook 2013 with default browser set to FireFox (26.0). If I set Internet Exploder as the default, I can open links in Outlook 2013. Windows 8 x64

Thanks

Stuart

Cannot open links in Outlook 2013 with default browser set to FireFox (26.0). If I set Internet Exploder as the default, I can open links in Outlook 2013. Windows 8 x64 Thanks Stuart

額外的系統細節

已安裝的外掛程式

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.9 r900
  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • The plugin allows you to have a better experience with Microsoft Lync
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • 5.1.20913.0
  • IBM 821 Conference Plugin for Mozilla version 8.2.10.911
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.1

應用程式

  • Firefox 26.0
  • 使用者代理:Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/26.0/WINNT/en-US/

擴充套件

  • DuckDuckGo Plus 0.3.8 (jid1-ZAdIEUB7XOzOJw@jetpack)
  • Ghostery 5.0.6 (firefox@ghostery.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Adobe Acrobat - Create PDF 1.1 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • FoxClocks 3.3.26 ({d37dc5d0-431d-44e5-8c91-49419370caa1}) (Inactive)
  • IE View 1.5.6 ({6e84150a-d526-41f1-a480-a67d3fed910d}) (Inactive)
  • Norton Toolbar 2014.6.2.3 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62}) (Inactive)
  • Norton Vulnerability Protection 12.0.4.5 - 1 ({BBDA0591-3099-440a-AA10-41764D9DB4DB}) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: NVIDIA GeForce GTX 760
  • adapterDescription2:
  • adapterDeviceID: 0x1187
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16581
  • driverDate: 10-23-2013
  • driverDate2:
  • driverVersion: 9.18.13.3165
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 760 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

修改過的偏好設定

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131205075310
  • browser.startup.homepage: http://www.foxnews.com/tech/index.html
  • browser.startup.homepage_override.buildID: 20131205075310
  • browser.startup.homepage_override.mstone: 26.0
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 26.0
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True

其他

  • User JS: 否
  • 輔助功能: 否
cor-el
  • Top 10 Contributor
  • Moderator
17567 個解決方法 158896 個答案

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

You can also check for issues with Java.

Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes You can also check for issues with Java. *http://kb.mozillazine.org/Java

提出問題者

Entered safe mode, default theme is enabled and no other themes are installed. Checked any extension and disabled them all. Jave SE 7 U45 10.45.2.18 installed and appears to function normally.

Problem remains.

Entered safe mode, default theme is enabled and no other themes are installed. Checked any extension and disabled them all. Jave SE 7 U45 10.45.2.18 installed and appears to function normally. Problem remains.

提出問題者

Also, disabled HW acceleration...problem remains.

Also, disabled HW acceleration...problem remains.
eosterberg 0 個解決方法 3 個答案

I have this problem as well with both versions of Firefox 26 and 27.

I have Windows 8.1 PRO 64 bit and Outlook 13. When Firefox is set as the default browser and I click on a URL in Outlook, I get an error message from Outlook: "Something unexpected went wrong with this url...class not registered" This does not happen when Internet Explorer is the default browser.

I have this problem as well with both versions of Firefox 26 and 27. I have Windows 8.1 PRO 64 bit and Outlook 13. When Firefox is set as the default browser and I click on a URL in Outlook, I get an error message from Outlook: "Something unexpected went wrong with this url...class not registered" This does not happen when Internet Explorer is the default browser.
John99 971 個解決方法 13138 個答案

There have been a few posts about this problem recently. So far, in recent posts, I have only noticed this reported as affecting Windows 8. I am sure it is not affecting every Windows 8 user.

Of the many possibilities a couple of others (In addition to interfering extensions ) are

  • A Windows or other software update.
  • Malware

If you have the problem please state

  • The exact message that you get (If possibe paste it into your reply or provide a screenshot)
  • Your Operating System and Version.
  • Does your device use a keyboard or touch screen. (I am not certain that is important)
  • Try the Run option and enter firefox.exe
    • Apparently on Windows 8 Run is available :
      (see)
      • In desktop mode from the extreme lower left corner, popup similar to the old style start menu
      • Shortcut keyboard key combination [Windows Key] +[R]
      • Charms bar, search for run

I will tag this thread as escalate because I do not think we have yet discovered the cause of this or the solution.

There have been a few posts about this problem recently. So far, in recent posts, I have only noticed this reported as affecting Windows 8. I am sure it is not affecting every Windows 8 user. Of the many possibilities a couple of others (In addition to interfering extensions ) are * A Windows or other software update. * Malware If you have the problem please state * The exact message that you get (If possibe paste it into your reply or provide a screenshot) ** [[How to make screenshots]] <br /> [[How do I create a screenshot of my problem?]] * Your Operating System and Version. * Does your device use a keyboard or touch screen. (I am not certain that is important) * '''Try the Run option and enter ''firefox.exe'' ''' **Apparently on Windows 8 Run is available :<br />([http://blogs.msdn.com/b/zxue/archive/2012/03/07/win8-howto-12-show-and-use-run-command.aspx see]) *** In desktop mode from the extreme lower left corner, popup similar to the old style start menu *** Shortcut keyboard key combination [Windows Key] +[R] *** Charms bar, search for ''run'' I will tag this thread as escalate because I do not think we have yet discovered the cause of this or the solution.
John99 971 個解決方法 13138 個答案

Further Questions

  • Is the only problem her with trying to open links or Files when Firefox is set as the default browser.
  • Confirm such links or Files open ok when IE is set as the default browser.
  • Do you only have a problem when trying to use Out look links ?
  • Have you tried some third alternative browser ?
    (Do other browsers also have problems when you try to set them as default browser)
Further Questions *Is the only problem her with trying to open links or Files when Firefox is set as the default browser. *Confirm such links or Files open ok when IE is set as the default browser. *Do you only have a problem when trying to use Out look links ? *Have you tried some third alternative browser ? <br /> (Do other browsers also have problems when you try to set them as default browser)
eosterberg 0 個解決方法 3 個答案

The open problem I have with Firefox is when I read Outlook email and try to open a link from Outlook when Firefox is the default browser.

When I set Internet Explorer or Safari as the default browser, I can open a link from Outlook.

The open problem I have with Firefox is when I read Outlook email and try to open a link from Outlook when Firefox is the default browser. When I set Internet Explorer or Safari as the default browser, I can open a link from Outlook.
cor-el
  • Top 10 Contributor
  • Moderator
17567 個解決方法 158896 個答案

Try to redo the default browser setting and temporarily set another browser as the default browser.

Try to redo the default browser setting and temporarily set another browser as the default browser. *https://support.mozilla.org/kb/How+to+make+Firefox+the+default+browser *https://support.mozilla.org/kb/Setting+Firefox+as+the+default+browser+does+not+work
guigs 1072 個解決方法 11697 個答案

Hi,

Does this also happen when you set the defaults for the program? https://support.mozilla.org/en-US/kb/how-make-web-links-open-firefox-defa...

Go to Control Panel Set program access and computer defaults Select Custom and choose the Mail Client and Browser defaults here. Please make sure to check the box "Enable access to this program"


Also in the Internet Properties go to the Programs tab and see that IE opens up links. You can reset these settings from IE http://support.microsoft.com/kb%5C310.../EN-US Then go back to default programs and set Firefox as your default browser instead.

You can also try this: Going to Firefox default programs and change the internet protocols: http://superuser.com/questions/490415/is-it-possible-to-use-the-ie10-app-w...

Ideally though you just need to change URL:HyperText Transfer Protocol to Firefox.

Hope this helps.

Rachel

Hi, Does this also happen when you set the defaults for the program? [https://support.mozilla.org/en-US/kb/how-make-web-links-open-firefox-default#firefox:win8:fx27] Go to Control Panel Set program access and computer defaults Select Custom and choose the Mail Client and Browser defaults here. Please make sure to check the box "Enable access to this program" Also in the Internet Properties go to the Programs tab and see that IE opens up links. You can reset these settings from IE [http://support.microsoft.com/kb%5C310049/EN-US] Then go back to default programs and set Firefox as your default browser instead. You can also try this: Going to Firefox default programs and change the internet protocols: [http://superuser.com/questions/490415/is-it-possible-to-use-the-ie10-app-without-making-internet-explorer-the-default] Ideally though you just need to change URL:HyperText Transfer Protocol to Firefox. Hope this helps. Rachel

由 guigs 於 修改

foxyshadis 2 個解決方法 15 個答案

I've had this problem ever since version 30 was uplifted into Aurora. I hope it gets fixed before the Beta period, or it'll probably start affecting more users. I have tried every fix in this thread before I came across it, not one works. Safe mode changes nothing, starting with a fresh profile does nothing, even updating with the fresh profile. I even dug into the registry and verified that the http and https associations were exactly as they should be.

The only difference is that I also get the "Class not registered" error when I try to open Aurora from the taskbar or start screen now, even if I unpin it and re-pin it. Same happens if I run any shortcut to it. The only way I can start it is directly from the actual firefox.exe, I don't know if there's some cruft in the registry messing with this.

Win 8.1 x64. No malware.

In the meantime I'm copy-pasting every single external link.

I've had this problem ever since version 30 was uplifted into Aurora. I hope it gets fixed before the Beta period, or it'll probably start affecting more users. I have tried every fix in this thread before I came across it, not one works. Safe mode changes nothing, starting with a fresh profile does nothing, even updating with the fresh profile. I even dug into the registry and verified that the http and https associations were exactly as they should be. The only difference is that I also get the "Class not registered" error when I try to open Aurora from the taskbar or start screen now, even if I unpin it and re-pin it. Same happens if I run any shortcut to it. The only way I can start it is directly from the actual firefox.exe, I don't know if there's some cruft in the registry messing with this. Win 8.1 x64. No malware. In the meantime I'm copy-pasting every single external link.
cor-el
  • Top 10 Contributor
  • Moderator
17567 個解決方法 158896 個答案

有幫助的回覆

Try to uninstall and reinstall the Aurora version to do a clean reinstall.

Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.

Try to uninstall and reinstall the Aurora version to do a clean reinstall. Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.
foxyshadis 2 個解決方法 15 個答案

Thanks, cor-el. I finally had time to do that, and it worked perfectly. Everything is back to normal.

Thanks, cor-el. I finally had time to do that, and it worked perfectly. Everything is back to normal.
John99 971 個解決方法 13138 個答案

有幫助的回覆

stuart-bailey & eosterberg

  • Do you still have problems, or did you find a solution ?
  • Have you tried the clean install ?
    Does that work for you ?
    • A clean install involves deleting the Firefox program files.
      Take Care do NOT delete the profile folder or take any options to remove personal information, because you will destroy passwords, bookmarks and settings.
    • See Troubleshoot and diagnose Firefox problems_5-reinstall-firefox
stuart-bailey & eosterberg *Do you still have problems, or did you find a solution ? *Have you tried the clean install ? <br />Does that work for you ? ** A clean install involves deleting the Firefox program files. <br /> Take '''Care''' do NOT delete the profile folder or take any options to remove personal information, because you will destroy passwords, bookmarks and settings. ** See [[Troubleshoot and diagnose Firefox problems#w_5-reinstall-firefox]]_5-reinstall-firefox