X
點擊此處開啟此網站的行動版。

技術支援討論區

After update to Firefox 26.0 I have problem withs utf8 encoding after refresh of page

已張貼

Hello, after update to Firefox 26.0 (CS version, but as I checked, e.g. SK or LV versions does that too, I did not try EN version), my pages (written in PHP, running on Apache) after sending form with method POST starts to ignore header content-type charset=utf8 and broke the encoding by reset to win1250. In older versions of Firefox and other browsers, no such problem appear. I did some search in older messages, but without result. Could you please suggest some solution? Thank you, Lida Chroma

Hello, after update to Firefox 26.0 (CS version, but as I checked, e.g. SK or LV versions does that too, I did not try EN version), my pages (written in PHP, running on Apache) after sending form with method POST starts to ignore header content-type charset=utf8 and broke the encoding by reset to win1250. In older versions of Firefox and other browsers, no such problem appear. I did some search in older messages, but without result. Could you please suggest some solution? Thank you, Lida Chroma

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 11.9 r900
  • Google Update
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

更多資訊

guigs 1072 個解決方法 11697 個答案

HI Lida,

Thank you for contacting support with your question. If this is happening on multiple places then please provide a few examples and we are happy to investigate why it stopped working.

If it is just happening on your computer:

"Tools > Options > Content: Languages->Choose"

If it happening on multiple computers and networks:

  • This web sniffer will give the http header that is being passed on the pages that have the meta char type or the header() callhttp://web-sniffer.net/
  • http://validator.w3.org/ may help narrow down why the page is ignoring the char type.

Please let us know how this goes, we are happy to help further investigate to find what changed, if it did.

HI Lida, Thank you for contacting support with your question. If this is happening on multiple places then please provide a few examples and we are happy to investigate why it stopped working. If it is just happening on your computer: *please check for malware or view the page is safe mode. *Past question[https://support.mozilla.org/en-US/questions/945841 ] "Tools > Options > Content: Languages->Choose" If it happening on multiple computers and networks: * This web sniffer will give the http header that is being passed on the pages that have the meta char type or the header() call[http://web-sniffer.net/] *[http://validator.w3.org/] may help narrow down why the page is ignoring the char type. Please let us know how this goes, we are happy to help further investigate to find what changed, if it did.