X
點擊此處開啟此網站的行動版。

技術支援討論區

Firefox is eating up between 90% CPU usage to %230 CPU usage, while on a text-only page. I've tried many of the fixits. They didn't work. What can I do?

已張貼

I've cleared cookies multiple times

I've emptied the cache

I cleared my download history, and a majority of my browsing history

I've tried having hardware acceleration for both flash and firefox on and off

I turned off all my apps and plugins and when that did nothing I turned back on the ones I need. I never had a lot of apps to begin with. only a max of 5. I had quite a few plugins, but i disabled all but quicktime, flash, and silverlight. I have those three set on "ask to activate" so none are "always active" anymore.

I also tried a couple things from the FAQ and forums here about changing a few settings in the "about:config" setup.

A few of the above things initially worked, but after a day or two it'd be back to sucking up my CPU and memory. I would then try the same thing again, and this second time there would be no improvement. The real memory will fluctuate between 200 MB and 1.7 GB, and has done so for quite a while.

Even after I've left streaming sites, and sites with lots of images, and I'm not downloading anything, the memory and the CPU will still do that. I only have a handful of tabs open at a timeusually, and all of them are mostly text. I'll quit and reopen firefox, which will initially bring the memory and CPU usage down, but it inevitably climbs up quite quickly, regardless of my tab usage. It'll be the same if I'm playing a flash game or scrolling through blogs.

I never had any of these problems with Firefox 23, and my internet usage habits haven't changed at all. I had some of this slowness a few times with version 24, but nowhere near as bad as this, or as constant. Almost everyday I end up googling for other ways to speed things up. Everything I do never slowed down Firefox on earlier versions.

I've tried all my usual tasks on Safari which will never climb above 30-40 MB of memory, even on netflix streaming, or flash games, and the CPU will average around 8 and 11%.

I've cleared cookies multiple times I've emptied the cache I cleared my download history, and a majority of my browsing history I've tried having hardware acceleration for both flash and firefox on and off I turned off all my apps and plugins and when that did nothing I turned back on the ones I need. I never had a lot of apps to begin with. only a max of 5. I had quite a few plugins, but i disabled all but quicktime, flash, and silverlight. I have those three set on "ask to activate" so none are "always active" anymore. I also tried a couple things from the FAQ and forums here about changing a few settings in the "about:config" setup. A few of the above things initially worked, but after a day or two it'd be back to sucking up my CPU and memory. I would then try the same thing again, and this second time there would be no improvement. The real memory will fluctuate between 200 MB and 1.7 GB, and has done so for quite a while. Even after I've left streaming sites, and sites with lots of images, and I'm not downloading anything, the memory and the CPU will still do that. I only have a handful of tabs open at a timeusually, and all of them are mostly text. I'll quit and reopen firefox, which will initially bring the memory and CPU usage down, but it inevitably climbs up quite quickly, regardless of my tab usage. It'll be the same if I'm playing a flash game or scrolling through blogs. I never had any of these problems with Firefox 23, and my internet usage habits haven't changed at all. I had some of this slowness a few times with version 24, but nowhere near as bad as this, or as constant. Almost everyday I end up googling for other ways to speed things up. Everything I do never slowed down Firefox on earlier versions. I've tried all my usual tasks on Safari which will never climb above 30-40 MB of memory, even on netflix streaming, or flash games, and the CPU will average around 8 and 11%.

由 tjak1 於 修改

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 11.9 r900
  • 5.1.20913.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

應用程式

  • Firefox 25.0.1
  • 使用者代理:Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:25.0) Gecko/20100101 Firefox/25.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/25.0.1/Darwin/en-US/

擴充套件

  • Adblock Plus 2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • AddonFox 1.2.1 ({ad48108d-92a6-4eb9-87e4-978aca1dbae4})
  • Stylish 1.4.0 ({46551EC9-40F0-4e47-8E18-8E5CF550CFB8})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Tumblr Savior 0.4.9 (jid1-W5guVoyeUR0uBg@jetpack)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription:
  • adapterDeviceID: 0x 407
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x10de
  • driverDate:
  • driverVersion:
  • info: {u'AzureContentBackend': u'quartz', u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRendererMessage: [u'']
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

修改過的偏好設定

  • accessibility.blockautorefresh: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.enabled: False
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.history_expire_days.mirror: 180
  • browser.history_expire_days_min: 20
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131112160018
  • browser.startup.homepage: about:home
  • browser.startup.homepage_override.buildID: 20131112160018
  • browser.startup.homepage_override.mstone: 25.0.1
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 25.0.1
  • font.internaluseonly.changed: True
  • gfx.blacklist.webgl.msaa: 4
  • keyword.URL: http://websearch.shopathome.com?user_id={e680c6af-7f7a-e241-9705-be106715aba3}&q=
  • layers.acceleration.disabled: True
  • network.cookie.prefsMigrated: True
  • network.http.pipelining: True
  • network.http.pipelining.maxrequests: 30
  • network.http.proxy.pipelining: True
  • places.database.lastMaintenance: 1386216629
  • places.history.expiration.transient_current_max_pages: 53688
  • places.last_vacuum: 1362268151
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.amazonmp3downloaderplugin: 0
  • plugin.state.divxbrowserplugin: 0
  • plugin.state.f5 ssl vpn plugin: 0
  • plugin.state.fbplugin: 0
  • plugin.state.flash: 1
  • plugin.state.flip4mac wmv plugin: 0
  • plugin.state.iphotophotocast: 0
  • plugin.state.java: 0
  • plugin.state.move-media-player: 0
  • plugin.state.quicktime plugin: 2
  • plugin.state.silverlight: 1
  • plugin.state.unity web player: 0
  • plugin.state.veoh plugin: 0
  • plugin.state.veohtv2version: 0
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.downloads: False
  • privacy.clearOnShutdown.formdata: False
  • privacy.clearOnShutdown.history: False
  • privacy.clearOnShutdown.sessions: False
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1386106245
  • webgl.disabled: True

其他

  • User JS: 否
  • 輔助功能: 否
iamjayakumars 492 個解決方法 5972 個答案
Try these *http://kb.mozillazine.org/Firefox_CPU_usage *https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix

提出問題者

Thanks for the suggestions. I've just installed noscript as per the first link. I can't tell yet if it's helping or not, I'll have to see in a few hours.

I can't try any of the suggestions under the "all the time" section in the first link because it's only for Windows and I have a Mac. Do you know of a resource that instructs how to do those things on a mac?

and the second link I've done everything on that list already.

At the moment the CPU usage is minimal and the real memory is still fluctuating above 300 MB, but I haven't been using firefox very long today so that might change in a while. If I get more huge spikes I'll be sure to report back.

Thanks for the suggestions. I've just installed noscript as per the first link. I can't tell yet if it's helping or not, I'll have to see in a few hours. I can't try any of the suggestions under the "all the time" section in the first link because it's only for Windows and I have a Mac. Do you know of a resource that instructs how to do those things on a mac? and the second link I've done everything on that list already. At the moment the CPU usage is minimal and the real memory is still fluctuating above 300 MB, but I haven't been using firefox very long today so that might change in a while. If I get more huge spikes I'll be sure to report back.

提出問題者

alright, i had multiple tabs with lots of large picture files open for at least a couple hours, maybe more, and everything was fine, staying around a 30% usage, and 400 MB memory. I'd still prefer it to be lower in both areas, like Safari, but at these numbers at least nothing hiccups or slows down.

all of sudden, with far fewer tabs open than before, and only 2 tabs with pictures, the the CPU spikes over 100%. the CPU is down now but it's still using 900 MB of memory and hasn't gone down since the spike. What else can I do to keep the memory usage from being this high?

I didn't do anything and the CPU just all of a sudden went back down while I was typing this.

Can I prevent it from spiking at all like that? especially when it never happens when I'm actually doing things that take more memory and CPU like videos, scrolling through lots of large picture files, and downloads and such?

One more note (about my attached picture)

the line graph of my disk activity has repetitive spikes right now. I only have one tab open with pictures, and it's been doing that for several minutes. Firefox being the only application I have open, other than my activity monitor, I assume that firefox is causing this.

alright, i had multiple tabs with lots of large picture files open for at least a couple hours, maybe more, and everything was fine, staying around a 30% usage, and 400 MB memory. I'd still prefer it to be lower in both areas, like Safari, but at these numbers at least nothing hiccups or slows down. all of sudden, with far fewer tabs open than before, and only 2 tabs with pictures, the the CPU spikes over 100%. the CPU is down now but it's still using 900 MB of memory and hasn't gone down since the spike. What else can I do to keep the memory usage from being this high? I didn't do anything and the CPU just all of a sudden went back down while I was typing this. Can I prevent it from spiking at all like that? especially when it never happens when I'm actually doing things that take more memory and CPU like videos, scrolling through lots of large picture files, and downloads and such? One more note (about my attached picture) the line graph of my disk activity has repetitive spikes right now. I only have one tab open with pictures, and it's been doing that for several minutes. Firefox being the only application I have open, other than my activity monitor, I assume that firefox is causing this.

由 tjak1 於 修改

提出問題者

is there really nothing i can do?

i just updated to firefox 26 and all the problems are still there.

if i don't get any more suggestions soon then i might just have to do the switch to chrome. i hate having to get familiar with new interfaces, but this immense amount of lagging is so much worse.

is there really nothing i can do? i just updated to firefox 26 and all the problems are still there. if i don't get any more suggestions soon then i might just have to do the switch to chrome. i hate having to get familiar with new interfaces, but this immense amount of lagging is so much worse.
kobe 441 個解決方法 5048 個答案

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * On Windows you can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac you can open Firefox 4.0+ in Safe Mode by holding the '''option''' key while starting Firefox. * On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox) * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. [[Image:FirefoxSafeMode|width=520]] ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Thank you.

提出問題者

even in safe mode, all it took was a couple tabs open with pictures in them, and in a mere 5 minutes the memory was already at 500 MB. and the firefox shockwave plugin at an additional 300MB. it will increase and memory steadily and never go back down unless i quit and restart firefox, only to increase in memory usage over time again. Scrolling and typing lag, and it'll freeze often. Sometimes I can keep from force quitting or crashing firefox if i force quit the shockwave plugin. Sometimes that doesn't work or it crashes before i have a chance to try that.

you said what to do if the problems weren't present in safe mode, but what do I do since they are still there when i'm in safe mode?

even in safe mode, all it took was a couple tabs open with pictures in them, and in a mere 5 minutes the memory was already at 500 MB. and the firefox shockwave plugin at an additional 300MB. it will increase and memory steadily and never go back down unless i quit and restart firefox, only to increase in memory usage over time again. Scrolling and typing lag, and it'll freeze often. Sometimes I can keep from force quitting or crashing firefox if i force quit the shockwave plugin. Sometimes that doesn't work or it crashes before i have a chance to try that. you said what to do if the problems weren't present in safe mode, but what do I do since they are still there when i'm in safe mode?
kobe 441 個解決方法 5048 個答案

Can you try out a new profile as a test.

SEE the Profile Manager - Create, remove, or switch Firefox profiles article for the how to on creating a profile

Can you try out a new profile as a test. SEE the [[Use the Profile Manager to create and remove Firefox profiles]] article for the how to on creating a profile
klappa 1 個解決方法 53 個答案

I have the same problem as the threadstarter. I get regularly video hickups every other five seconds. I tried to start a fresh user but i still get hickups. I've uninstalled flash and ran adobes flash uninstaller. My computer has the newest quadcore high end processor from Intel. It has been this for a year or two now.

The same video and everything else is as buttery smooth in Internet Explorer. So i have reached my conclusion that flash for Firefox is a disgrace and it's utterly SHIT!!!

I have the same problem as the threadstarter. I get regularly video hickups every other five seconds. I tried to start a fresh user but i still get hickups. I've uninstalled flash and ran adobes flash uninstaller. My computer has the newest quadcore high end processor from Intel. It has been this for a year or two now. The same video and everything else is as buttery smooth in Internet Explorer. So i have reached my conclusion that flash for Firefox is a disgrace and it's utterly SHIT!!!
shape5 1 個解決方法 28 個答案

有幫助的回覆

i'm also having major CPU problems w/ FF 29.0.1. when i restart the app it calms down again but after loading tabs it steadily climbs up to 100% after not too long. i have checked out the 2 CPU links/articles above and do all the basic troubleshooting and tips, but with all the FF tools & add-ons isn't there some sort of CPU monitor that has the ability to display which extensions/scripts are hogging the CPU? Activity Monitor on Mac just shows the total used by the app. it's impossible in my case to efficiently disable dozens of add-ons & scripts, restart, and test each one by one b/c it can take several hrs before the CPU starts to spike high again. i have no time for this.

thanks

i'm also having major CPU problems w/ FF 29.0.1. when i restart the app it calms down again but after loading tabs it steadily climbs up to 100% after not too long. i have checked out the 2 CPU links/articles above and do all the basic troubleshooting and tips, but with all the FF tools & add-ons isn't there some sort of CPU monitor that has the ability to display which extensions/scripts are hogging the CPU? Activity Monitor on Mac just shows the total used by the app. it's impossible in my case to efficiently disable dozens of add-ons & scripts, restart, and test each one by one b/c it can take several hrs before the CPU starts to spike high again. i have no time for this. thanks
shape5 1 個解決方法 28 個答案

i can't be sure this is it or not, but after running the NoScript add-on for a while FF seems to be running better, at a lower CPU %. i actually went to disable it b/c of all the manual work i had to do in approving/allowing scripts for each and every site, and then it said i could leave only the base security features / harmful script blocking & click-jacking (or something to that effect) without having to manage anything manually, and this has been working fine since, with no additional work required. so i'd recommend using it. i've also been using Flashblock.

i can't be sure this is it or not, but after running the NoScript add-on for a while FF seems to be running better, at a lower CPU %. i actually went to disable it b/c of all the manual work i had to do in approving/allowing scripts for each and every site, and then it said i could leave only the base security features / harmful script blocking & click-jacking (or something to that effect) without having to manage anything manually, and this has been working fine since, with no additional work required. so i'd recommend using it. i've also been using Flashblock.