搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Firefox will no longer permit me to stay signed in to Comcast.

more options

I use Firefox 25.0.1 on a new MacBook Pro laptop running OS X 10.9. Up until a few days ago I could click on firefox and my home page would open immediately and then mail, also. Now I have to sign in EVERY time. Clicking on "remember me" does no good. Comcast repairman checked everything re internet, and there is no problem.

I use Firefox 25.0.1 on a new MacBook Pro laptop running OS X 10.9. Up until a few days ago I could click on firefox and my home page would open immediately and then mail, also. Now I have to sign in EVERY time. Clicking on "remember me" does no good. Comcast repairman checked everything re internet, and there is no problem.

被選擇的解決方法

Hi stljan, most third party cookies are just for tracking, but some are needed to serve content correctly. You can experiment with the settings and see whether any sites break with the "visited" option.

從原來的回覆中察看解決方案 👍 1

所有回覆 (5)

more options

It sounds as though the cookie that keeps you logged in to Comcast is either getting cleared or has become corrupted.

First, make sure that you allow Comcast to store persistent cookies. You can check this in the Page Info dialog while you're on a page on comcast.net (or whatever domain shows for the login form). Either:

  • right-click the page > Page Info > Permissions
  • Tools menu > Page Info > Permissions
  • click the padlock in the address bar > More Information > Permissions

Under "Set cookies" the effective permission should be "Allow". If it isn't go ahead and adjust it to Allow.

On the adjacent Security tab, you can remove the existing cookies for comcast.net in the "View Cookies" dialog. Make sure to save any drafts before doing this, since it most likely will log you out in the process.

Second, make sure you aren't clearing cookies at shutdown. (Your "More system details" do not show this as an issue, but please double-check.) This is set in the Preferences dialog, Privacy tab, under "Clear history when Firefox closes." This article describes how to configure the feature: Delete browsing, search and download history on Firefox -- "How do I make Firefox clear my history automatically."

Note that in private browsing windows, the cookie dialog will appear blank and Firefox will automatically clear the cookies between sessions, regardless of your preferences.

It appears that you have disabled third party cookies. You might also try allowing those to see whether that solves it. You can do that in the Preferences dialog as described in this article: Websites say cookies are blocked - Unblock them.

more options

jscher2000,

Your solution worked!!! Thank you so much!!

By clearing ALL cookies related to comcast (including infinity.comcast.net and login.comcast.net) the problem was solved. I did check, and I did not have "clear history when Firefox closes" selected. I went to the section related to 3rd party cookies and accepted 3rd party cookies "always."

How safe is accepting 3rd party cookies? Would accepting 3rd party cookies from "visited sites" be a better option? Why would I want cookies from a site I've have never visited? (Maybe there is a good reason why.)

Thanks again, Stljan

more options

In case you are using "Clear history when Firefox closes":

  • do not clear the Cookies
  • do not clear the Site Preferences

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.

Clearing cookies will remove all specified (selected) cookies including cookies with an allow exception that you would like to keep.


If clearing cookies doesn't work then it is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookies files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.

more options

Cor-el,

Since I did not have "clear history when Firefox closes" selected, I avoided the problems you showed me how to fix. However, I have saved your answer for future reference if I have the login problem again.

Thank you for suggesting a further solution.

Stljan

more options

選擇的解決方法

Hi stljan, most third party cookies are just for tracking, but some are needed to serve content correctly. You can experiment with the settings and see whether any sites break with the "visited" option.