X
點擊此處開啟此網站的行動版。

技術支援討論區

Adobe Flash Player 11.9 r900 constantly crashes with a data execution prevention error.

已張貼

This happens with almost every website I go to.

This happens with almost every website I go to.

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 11.9 r900
  • Google Update
  • GEPlugin
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.20513.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • Nitro PDF plugin for Firefox and Chrome
  • VLC media player Web Plugin 2.0.2
  • A component of your photo software powered by RocketLife
  • DivX VOD Helper Plug-in
  • DivX Web Player version 2.1.1.94
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.732
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

應用程式

  • Firefox 25.0.1
  • 使用者代理:Mozilla/5.0 (Windows NT 6.0; rv:25.0) Gecko/20100101 Firefox/25.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/25.0.1/WINNT/en-US/

擴充套件

  • Session Manager 0.8.0.8 ({1280606b-2510-4fe0-97ef-9b5a22eafe30})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • DivX HiQ 2.1.1.94 ({6904342A-8307-11DF-A508-4AE2DFD72085}) (Inactive)
  • DivX Plus Web Player HTML5 <video> 2.1.1.94 ({23fcfd51-4958-4f00-80a3-ae97e717ed8b}) (Inactive)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: Intel(R) G33/G31 Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x29c2
  • adapterDeviceID2:
  • adapterDrivers: igdumdx32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 7.0.6002.18409
  • driverDate: 2-26-2009
  • driverDate2:
  • driverVersion: 7.15.10.1666
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 3
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) G33/G31 Express Chipset Family Direct3D9Ex vs_0_0 ps_2_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

修改過的偏好設定

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131112160018
  • browser.startup.homepage_override.buildID: 20131112160018
  • browser.startup.homepage_override.mstone: 25.0.1
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 25.0.1
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1385796410
  • places.history.expiration.transient_current_max_pages: 80258
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.extensions-sessionmanager: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1384575866

其他

  • User JS: 否
  • 輔助功能: 否
iamjayakumars 492 個解決方法 5972 個答案

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

________________________________________________________________________________

We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash IDs to help us learn more about your crash.

  1. Enter about:crashes in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below.
  2. Copy the 5 most recent Report IDs that start with bp- and paste them into your response here.

SubmittedCrashReports-Win7

Thank you for your help!

More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * On Windows you can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac you can open Firefox 4.0+ in Safe Mode by holding the '''option''' key while starting Firefox. * On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox) * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. [[Image:FirefoxSafeMode|width=520]] ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' ________________________________________________________________________________ We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash IDs to help us learn more about your crash. #Enter ''about:crashes'' in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below. #Copy the '''5''' most recent Report IDs that start with '''bp-''' and paste them into your response here. [[Image:SubmittedCrashReports-Win7|width=520]] <br><br> Thank you for your help! More information and further troubleshooting steps can be found in the [[Firefox crashes - Troubleshoot, prevent and get help fixing crashes]] article.

提出問題者

As requested:

Submitted Crash Reports

bp-4e5e5f95-ce4c-4ecd-a628-0ef6f2131130 11/30/2013 12:54 PM
4fdabb8e-b46a-48a1-9c01-b6a7c0ce6d4c 11/30/2013 12:54 PM
07f227d2-fdf9-470f-8118-b674c3eb6779 11/30/2013 12:54 PM
cfa7db17-5b17-4a59-a0d6-d0153fc2db69 11/30/2013 11:10 AM
1efac985-a328-465b-a32c-c35925d174c1
As requested: Submitted Crash Reports <pre><nowiki> bp-4e5e5f95-ce4c-4ecd-a628-0ef6f2131130 11/30/2013 12:54 PM 4fdabb8e-b46a-48a1-9c01-b6a7c0ce6d4c 11/30/2013 12:54 PM 07f227d2-fdf9-470f-8118-b674c3eb6779 11/30/2013 12:54 PM cfa7db17-5b17-4a59-a0d6-d0153fc2db69 11/30/2013 11:10 AM 1efac985-a328-465b-a32c-c35925d174c1</nowiki></pre>

由 cor-el 於 修改

AliceWyman
  • Moderator
240 個解決方法 2597 個答案

See Adobe Flash plugin has crashed - Prevent it from happening again. The crash report for ID bp-4e5e5f95-ce4c-4ecd-a628-0ef6f2131130 shows plugin Shockwave Flash Version:11.9.900.152 which is the latest version so you should start by disabling hardware acceleration in Flash:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.

See [[Adobe Flash plugin has crashed - Prevent it from happening again]]. The crash report for ID bp-4e5e5f95-ce4c-4ecd-a628-0ef6f2131130 shows plugin Shockwave Flash Version:11.9.900.152 which is the latest version so you should start by disabling hardware acceleration in Flash: #Go to this [http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues Adobe Flash Player Help page]. #Right-click on the Flash Player logo on that page. #Click on '''Settings''' in the context menu. The Adobe Flash Player Settings screen will open. # Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel. <br/> <br/>[[Image:fpSettings1.PNG]] <br/> # Remove the check mark from '''Enable hardware acceleration'''. # Click '''Close''' to close the Adobe Flash Player Settings Window. # Restart Firefox. This [http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html Flash Player Help - Display Settings page] has more information on Flash Player hardware acceleration, if you're interested. Does this solve the problem? Let us know.

提出問題者

I am not getting the error in safe mode and I did turn off hardware acceleration. I'll try troubleshooting extensions at a later time.

Thank you!

I '''am not''' getting the error in safe mode and I did turn off hardware acceleration. I'll try troubleshooting extensions at a later time. Thank you!

提出問題者

It looks like the Session Manager 0.8.0.8 add-on is the problem.

It looks like the Session Manager 0.8.0.8 add-on is the problem.
AliceWyman
  • Moderator
240 個解決方法 2597 個答案

Thanks for letting us know that it looks like the Session Manager 0.8.0.8 add-on was causing the problem. I marked your reply as the solution.

If the problem returns, please let us know.

Thanks for letting us know that it looks like the Session Manager 0.8.0.8 add-on was causing the problem. I marked your reply as the solution. If the problem returns, please let us know.

提出問題者

As it turns out, that was not the solution but it might have been part of it. This morning the problem returned. The only thing I was doing differently was downloading a file. I still had Session Manager disabled.

I have very few add-ons. I can disable more of them (one by one) tonight and see waht happens.

As it turns out, that was not the solution but it might have been part of it. This morning the problem returned. The only thing I was doing differently was downloading a file. I still had Session Manager disabled. I have very few add-ons. I can disable more of them (one by one) tonight and see waht happens.
AliceWyman
  • Moderator
240 個解決方法 2597 個答案

有幫助的回覆

So, this question is not solved. Too bad.

You said before that the problem does NOT happen when you restart Firefox in Firefox Safe Mode ... is that true? If so, then the problem could either be hardware acceleration in Firefox OR an extension. You said you turned off hardware acceleration ... did you do that in Firefox like this?

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

If the problem comes back even with hardware acceleration in Firefox turned off, troubleshoot all your extensions. See the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for details.

If the problem still happens with ALL extensions disabled and hardware acceleration in Firefox turned off, try disabling HW acceleration in Flash settings, if you haven't tried that already. Let us know.

So, this question is not solved. Too bad. You said before that the problem does NOT happen when you restart Firefox in [[Safe Mode|Firefox Safe Mode]] ... is that true? If so, then the problem could either be hardware acceleration '''in Firefox''' OR an extension. You said you turned off hardware acceleration ... did you do that in Firefox like this? *Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options. *In the Firefox options window click the ''Advanced'' tab, then select "General". *In the settings list, you should find the ''Use hardware acceleration when available'' checkbox. Uncheck this checkbox. *Now, restart Firefox and see if the problems persist. If the problem comes back even with hardware acceleration in Firefox turned off, troubleshoot all your extensions. See the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article for details. If the problem still happens with ALL extensions disabled and hardware acceleration in Firefox turned off, try disabling HW acceleration in Flash settings, if you haven't tried that already. Let us know.

提出問題者

I am not at my computer right now but here is the status of what I have done: Run Firefox in safe mode ===> problem goes away Turned hardware acceleration off in Flash ===> problem remains Disable Session Manager ===> problem remains but seems to happen less often (happened when downloading a file)

I will turn off hardware acceleration in Firefox when I return to my computer.

I am not at my computer right now but here is the status of what I have done: Run Firefox in safe mode ===> problem goes away Turned hardware acceleration off in Flash ===> problem remains Disable Session Manager ===> problem remains but seems to happen less often (happened when downloading a file) I will turn off hardware acceleration in Firefox when I return to my computer.
ASUService 0 個解決方法 2 個答案

I've had this issue for quite a while.

I have followed every step ...

Kill hardware accel. Safe Mode Disabled all add-ons.

I got better but still crashes ... just not as often.

Here's the crash report entry: bp-3261afbb-8d8e-4afa-a913-6d6fe2131204 12/4/2013 10:05 AM

I've had this issue for quite a while. I have followed every step ... Kill hardware accel. Safe Mode Disabled all add-ons. I got better but still crashes ... just not as often. Here's the crash report entry: bp-3261afbb-8d8e-4afa-a913-6d6fe2131204 12/4/2013 10:05 AM
AliceWyman
  • Moderator
240 個解決方法 2597 個答案

ASUService, (and anyone else needing help with Flash Player crashes):

See Forum rules and guidelines: ... For support requests, do not re-use existing threads started by others, even if they are seemingly on the same subject.

This thread is for helping moreofless. If you read the articles and suggestions posted above and you need more help, please ask a new question and include troubleshooting information with your crash Report IDs. You can use this link as a starting point: https://support.mozilla.org/questions/new

'''ASUService''', (and anyone else needing help with Flash Player crashes): See [[Forum rules and guidelines]]: ... ''For support requests, do not re-use existing threads started by others, even if they are seemingly on the same subject.'' This thread is for helping '''moreofless'''. If you read the articles and suggestions posted above and you need more help, please ask a new question and include troubleshooting information with your crash Report IDs. You can use this link as a starting point: https://support.mozilla.org/questions/new
ASUService 0 個解決方法 2 個答案

SERIOUSLY .... that's dumb as hell. Guess it's time to dump Firefox :(

SERIOUSLY .... that's dumb as hell. Guess it's time to dump Firefox :(
AliceWyman
  • Moderator
240 個解決方法 2597 個答案

ASUService, those are the forum rules.

'''ASUService,''' those are the forum rules.
KPJPGJ 0 個解決方法 2 個答案

I am getting this problem since I have downloaded 25.0.1 on Windows 7. Disable Use Hardware Acceleration and started in a safe mode. In safe mode adobe crash.

If I go to Adobe site, I cannot see the flash logo. On top window just before back button (Lego Sign ) it display message as "Adobe Flash" is enabled on helpx.adobe.com [Continue Allowing] after clicking on [Continue Allowing] still get black box at the Flash Logo place.


Crash report starts with bp.

bp-1d72376a-e687-4707-9539-2e3b12131205
bp-83199e27-ef43-48b8-9dec-910e52131205
bp-55458977-55ee-4916-b9e0-fb6c32131205
bp-a9520f3d-beb9-44ca-855a-eb9272131205
bp-569af281-8b9d-4d62-bc40-cac1a2131205
I am getting this problem since I have downloaded 25.0.1 on Windows 7. Disable Use Hardware Acceleration and started in a safe mode. In safe mode adobe crash. If I go to Adobe site, I cannot see the flash logo. On top window just before back button (Lego Sign ) it display message as "Adobe Flash" is enabled on helpx.adobe.com [Continue Allowing] after clicking on [Continue Allowing] still get black box at the Flash Logo place. Crash report starts with bp. <pre><nowiki> bp-1d72376a-e687-4707-9539-2e3b12131205 bp-83199e27-ef43-48b8-9dec-910e52131205 bp-55458977-55ee-4916-b9e0-fb6c32131205 bp-a9520f3d-beb9-44ca-855a-eb9272131205 bp-569af281-8b9d-4d62-bc40-cac1a2131205 </nowiki></pre>

由 cor-el 於 修改

jscher2000
  • Top 10 Contributor
8775 個解決方法 71736 個答案

有幫助的回覆

Hi moreofless, did a separate crash dialog indicate that it was a DEP error (sometimes the Windows crash dialog will indicate this)?

In some cases a DEP error can indicate that malware is attempting to interact with Flash, or that the Flash media you were using was malicious. It may be worth running a few supplemental scans just in case. The support article has suggestions on free tools that have proven reliable for Firefox users: Troubleshoot Firefox issues caused by malware.

A common problem on Windows Vista and higher is incompatibility with the protected mode feature of the Flash Player plugin. Usually this leads to frequent, unsubtle problems, so you might not have this problem, but just in case, you could disable it.

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

Or if there are problems with permission, try this way:

(1) In a My Computer or Windows Explorer window, open this folder:

C:\Windows\SysWOW64\Macromed\Flash

If that folder does not exist, then you are using 32-bit Windows, and you can open the following folder instead:

C:\Windows\System32\Macromed\Flash

(Note: This folder exists on both 32-bit and 64-bit Windows, but on 64-bit Windows Firefox uses the Flash player in the SysWOW64 folder instead.)

(2) Check for a file named mms.cfg:

Note: If you do not see file extensions such as .ocx, .dll, .exe, and .cfg on the files in this folder, then Windows may be hiding these from you. In order to work with file names accurately, it is best to unhide the extensions. This Microsoft support article has the steps: http://support.microsoft.com/kb/865219.

(A) If mms.cfg exists, drag it to your Documents folder where you can edit it without being bothered about administrator privileges

(B) If mms.cfg does not exist, open your Documents folder, right-click > New > Text File and name the new file mms.cfg

(3) Open mms.cfg from Documents into a text editor such as Notepad.

Add this on its own line (I put it last):

ProtectedMode=0

Save the file and close Notepad.

(4) Hold down the Ctrl key and drag the mms.cfg file back to the Flash folder to make a copy there, keeping the original in Documents

This change will take effect once the Flash plugin is completely unloaded, which may require exiting and restarting Firefox (allow a few minutes for all the Flash processes in memory to terminate after exiting Firefox).

Hi moreofless, did a separate crash dialog indicate that it was a DEP error (sometimes the Windows crash dialog will indicate this)? In some cases a DEP error can indicate that malware is attempting to interact with Flash, or that the Flash media you were using was malicious. It may be worth running a few supplemental scans just in case. The support article has suggestions on free tools that have proven reliable for Firefox users: [[Troubleshoot Firefox issues caused by malware]]. A common problem on Windows Vista and higher is incompatibility with the protected mode feature of the Flash Player plugin. Usually this leads to frequent, unsubtle problems, so you might not have this problem, but just in case, you could disable it. See this support article from Adobe under the heading "Last Resort": [http://forums.adobe.com/message/4468493#TemporaryWorkaround Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?] Or if there are problems with permission, try this way: (1) In a My Computer or Windows Explorer window, open this folder: C:\Windows\SysWOW64\Macromed\Flash If that folder does not exist, then you are using 32-bit Windows, and you can open the following folder instead: C:\Windows\System32\Macromed\Flash ''(Note: This folder exists on both 32-bit and 64-bit Windows, but on 64-bit Windows Firefox uses the Flash player in the SysWOW64 folder instead.)'' (2) Check for a file named mms.cfg: '''''Note:''' If you do not see file extensions such as .ocx, .dll, .exe, and .cfg on the files in this folder, then Windows may be hiding these from you. In order to work with file names accurately, it is best to unhide the extensions. This Microsoft support article has the steps: [http://support.microsoft.com/kb/865219].'' (A) ''If mms.cfg exists,'' drag it to your '''Documents folder''' where you can edit it without being bothered about administrator privileges (B) ''If mms.cfg does not exist,'' open your '''Documents folder''', right-click > New > Text File and name the new file mms.cfg (3) Open mms.cfg from Documents into a text editor such as Notepad. Add this on its own line (I put it last): ProtectedMode=0 Save the file and close Notepad. (4) Hold down the Ctrl key and drag the mms.cfg file back to the Flash folder to make a copy there, keeping the original in Documents This change will take effect once the Flash plugin is completely unloaded, which may require exiting and restarting Firefox (allow a few minutes for all the Flash processes in memory to terminate after exiting Firefox).
KPJPGJ 0 個解決方法 2 個答案

Thank You, jscher2000. My problem has been solved. As of now I do not have any addon and still flash was crashing. After making changes to mms.cfg this problem has been solved. I will try to install each add-on and now I will check if any add-on causing any issues.

Thank You, jscher2000. My problem has been solved. As of now I do not have any addon and still flash was crashing. After making changes to mms.cfg this problem has been solved. I will try to install each add-on and now I will check if any add-on causing any issues.
lisaluv777 0 個解決方法 1 個答案

jscher2000....This is the solution that worked for me. Thank you very much.

jscher2000....This is the solution that worked for me. Thank you very much.

由 lisaluv777 於 修改