X
點擊此處開啟此網站的行動版。

技術支援討論區

PDF files don't open I have tried EVERYTHING to no avail please help

已張貼

In the last couple of weeks I cannot open PDF files in Firefox. They open fine in Internet Explorer. I have been on the support forum now for over 2 hours and tried EVERYTHING suggested to no avail. It appears this is a common problem. Please help.

In the last couple of weeks I cannot open PDF files in Firefox. They open fine in Internet Explorer. I have been on the support forum now for over 2 hours and tried EVERYTHING suggested to no avail. It appears this is a common problem. Please help.

被選擇的解決方法

I think I have solved it :)

In the address bar there is a padlock icon (but not always) I clicked on that then 'more information' then 'permissions' then changed adobe reader to 'allow' So now all attachments open. I then checked 'do this automatically from now on when the file opening dialog box came up. Thanks to everyone who contributed. Ray

從原來的回覆中察看解決方案 0

額外的系統細節

已安裝的外掛程式

  • npsitesafety
  • Google Update
  • Shockwave Flash 11.9 r900
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • 5.1.20913.0
  • GEPlugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.2.122

應用程式

  • Firefox 25.0.1
  • 使用者代理:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/25.0.1/WINNT/en-US/

擴充套件

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • AVG Security Toolbar 17.1.2.1 (avg@toolbar) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: ATI Radeon 3000 Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x9616
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 4-19-2011
  • driverDate2:
  • driverVersion: 8.850.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon 3000 Graphics Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

修改過的偏好設定

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.autostart: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131112160018
  • browser.startup.homepage: www.google.co.uk
  • browser.startup.homepage_override.buildID: 20131112160018
  • browser.startup.homepage_override.mstone: 25.0.1
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 25.0.1
  • gfx.direct3d.last_used_feature_level_idx: 1
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 93889
  • plugin.disable_full_page_plugin_for_types: application/pdf,application/vnd.adobe.xfdf,application/vnd.fdf,application/vnd.adobe.xdp+xml
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True

其他

  • User JS: 否
  • 輔助功能: 否
iamjayakumars 489 個解決方法 5951 個答案

Check your PDF Plugins are updated!

Goto > Mozilla Menu > Tools > Options

  • Application > Search for "PDF" and change the action to "VIew in built-in PDF" or choose adobe reader.

For more

Check your PDF Plugins are updated! *http://www.mozilla.org/en-US/plugincheck/ Goto > Mozilla Menu > Tools > Options *Application > Search for "PDF" and change the action to "VIew in built-in PDF" or choose adobe reader. For more *https://support.mozilla.org/en-US/kb/view-pdf-files-firefox-without-downloading-them

提出問題者

No sorry it didn't help. All plug-ins are up to date but it still doesn't work

No sorry it didn't help. All plug-ins are up to date but it still doesn't work
iamjayakumars 489 個解決方法 5951 個答案

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information.
Note: This will cause you to lose any Extensions and some Preferences.

  • Open websites will not be saved in Firefox versions lower than 25.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

Thank you.

Hello, The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. <br> '''Note''': ''This will cause you to lose any Extensions and some Preferences.'' *Open websites will not be saved in Firefox versions lower than 25. To Reset Firefox do the following: #Go to Firefox > Help > Troubleshooting Information. #Click the "Reset Firefox" button. #Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish. #Firefox will open with all factory defaults applied. Further information can be found in the [[Reset Firefox – easily fix most problems]] article. Did this fix your problems? Please report back to us! Thank you.
FredMcD
  • Top 10 Contributor
4246 個解決方法 59401 個答案

有幫助的回覆

Check your settings under Firefox Options > Applications. Make sure the PDF settings.

Check your settings under '''''Firefox Options > Applications'''''. Make sure the PDF settings.

有幫助的回覆

Hi guys thanks for trying to help but absolutely nothing works. I simply don't know what else to try except giving up and using IE instead but I love using Firefox. Are there others out there in the same boat as me?

Hi guys thanks for trying to help but absolutely nothing works. I simply don't know what else to try except giving up and using IE instead but I love using Firefox. Are there others out there in the same boat as me?
cor-el
  • Top 10 Contributor
  • Moderator
17473 個解決方法 157940 個答案

Current Firefox versions have enabled a built-in PDF Viewer that doesn't have all features that other PDF readers like the Adobe Reader have or may not function properly otherwise.

You can change the action for Portable Document Format (PDF) from Preview in Firefox to use another application like the Adobe Reader or set to Always Ask in "Firefox > Options/Preferences > Applications".

You can set the pdfjs.disabled pref to true on the about:config page to disable the build-in PDF viewer.

You can check the value of the plugin.disable_full_page_plugin_for_types pref on the about:config page and remove the application/pdf part if present or reset the pref to the default via the right-click context menu if you want to display PDF documents in Firefox with another application (i.e. not the built-in PDF Viewer).

See also:

Current Firefox versions have enabled a built-in PDF Viewer that doesn't have all features that other PDF readers like the Adobe Reader have or may not function properly otherwise. You can change the action for Portable Document Format (PDF) from Preview in Firefox to use another application like the Adobe Reader or set to Always Ask in "Firefox > Options/Preferences > Applications". You can set the pdfjs.disabled pref to true on the <b>about:config</b> page to disable the build-in PDF viewer. You can check the value of the plugin.disable_full_page_plugin_for_types pref on the about:config page and remove the application/pdf part if present or reset the pref to the default via the right-click context menu if you want to display PDF documents in Firefox with another application (i.e. not the built-in PDF Viewer). *http://kb.mozillazine.org/about:config See also: *https://support.mozilla.org/kb/view-pdf-files-firefox-without-downloading-them

提出問題者

Ok tried that again but still no joy. Hours on this today and I have to give up tonight. I think Firefox just doesn't display PDF any more. I hope you will come up with a solution. Thank you

Ok tried that again but still no joy. Hours on this today and I have to give up tonight. I think Firefox just doesn't display PDF any more. I hope you will come up with a solution. Thank you
cor-el
  • Top 10 Contributor
  • Moderator
17473 個解決方法 157940 個答案

Did you check the location bar to see if there is a shield icon or a Lego icon that would indicate that content is blocked?


Did you check the location bar to see if there is a shield icon or a Lego icon that would indicate that content is blocked? ---- *https://support.mozilla.org/kb/why-do-i-have-click-activate-plugins *http://kb.mozillazine.org/Issues_related_to_plugins#Click_to_Play
iamjayakumars 489 個解決方法 5951 個答案

Hello,

Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

Please report back to see if this helped you!

Thank you.

Hello, Certain Firefox problems can be solved by performing a ''Clean reinstall''. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps: '''Note:''' You might want to print these steps or view them in another browser. #Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer. #After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu). #Delete the Firefox installation folder, which is located in one of these locations, by default: #*'''Windows:''' #**C:\Program Files\Mozilla Firefox #**C:\Program Files (x86)\Mozilla Firefox #*'''Mac:''' Delete Firefox from the Applications folder. #*'''Linux:''' If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see [[Installing Firefox on Linux]]. If you downloaded and installed the binary package from the [http://www.mozilla.org/firefox#desktop Firefox download page], simply remove the folder ''firefox'' in your home directory. #Now, go ahead and reinstall Firefox: ##Double-click the downloaded installation file and go through the steps of the installation wizard. ##Once the wizard is finished, choose to directly open Firefox after clicking the Finish button. Please report back to see if this helped you! Thank you.

提出問題者

I have already tried re-installing Firefox but that didn't work. However I have found this morning that its not just PDF files that won't open, its Word documents and Excel spreadsheets too. I am not in front of my PC now as I am at work so can't check the shield icon. However when I open files in IE a box comes up at the bottom of the screen asking to show content. Then I can open the file. I'll get back on the case later when I get home. Thanks Ray Walker

I have already tried re-installing Firefox but that didn't work. However I have found this morning that its not just PDF files that won't open, its Word documents and Excel spreadsheets too. I am not in front of my PC now as I am at work so can't check the shield icon. However when I open files in IE a box comes up at the bottom of the screen asking to show content. Then I can open the file. I'll get back on the case later when I get home. Thanks Ray Walker
FredMcD
  • Top 10 Contributor
4246 個解決方法 59401 個答案

Have you tried to re-install your viewer? BTW, what viewer are you using?

Have you tried to re-install your viewer? BTW, what viewer are you using?

提出問題者

using adobe reader and I have already re-installed it

using adobe reader and I have already re-installed it

提出問題者

no I don't see a sheild anywhere

no I don't see a sheild anywhere
jscher2000
  • Top 10 Contributor
8695 個解決方法 71066 個答案

Is this problem specific to a particular site? For example, email attachments don't open, but if you find a PDF or DOC file in a Google search, that one will open?

Example of PDF documents on Microsoft site related to security: https://www.google.com/search?q=site%3Amicrosoft.com+security+filetype%3Apdf

Is this problem specific to a particular site? For example, email attachments don't open, but if you find a PDF or DOC file in a Google search, that one will open? Example of PDF documents on Microsoft site related to security: https://www.google.com/search?q=site%3Amicrosoft.com+security+filetype%3Apdf

提出問題者

yes you are right its only in e-mail attachments where I have the problem

yes you are right its only in e-mail attachments where I have the problem
jscher2000
  • Top 10 Contributor
8695 個解決方法 71066 個答案

Something in this thread about Yahoo attachments might be relevant: Firefox suddently stopped downloading email attachments. Does anything there help?

Something in this thread about Yahoo attachments might be relevant: [https://support.mozilla.org/en-US/questions/971042 Firefox suddently stopped downloading email attachments.] Does anything there help?

提出問題者

Well, I klick the attachment, then for a moment it says "Scanning attachment" in the mail preview pane and after that, when the download should normally start, nothing happens.

This was from someone with the same problem

Well, I klick the attachment, then for a moment it says "Scanning attachment" in the mail preview pane and after that, when the download should normally start, nothing happens. This was from someone with the same problem
jscher2000
  • Top 10 Contributor
8695 個解決方法 71066 個答案

Hi lizipilot, two other things from that thread.

(1) Did you test whether you have the same issue in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

(2) Did you want to try temporarily disabling Firefox's integration with Windows' own attachment security feature? This thread has the steps for changing that setting: Downloaded files instantly disappear on completion.

Hi lizipilot, two other things from that thread. (1) Did you test whether you have the same issue in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled In the dialog, click "Start in Safe Mode" (''not'' Reset) Any difference? (2) Did you want to try temporarily disabling Firefox's integration with Windows' own attachment security feature? This thread has the steps for changing that setting: [https://support.mozilla.org/en-US/questions/978144 Downloaded files instantly disappear on completion].

提出問題者

tried safe mode no different unfortunately

tried safe mode no different unfortunately
cdkao 0 個解決方法 1 個答案

I have the same problem too. Somehow the latest Firefox update messed up the ability to preview Adobe file within it's browser.

I tried everything above as well. No luck.

I do have a solution now. That is to uninstall Firefox and use IE or Chrome.

Farewell Firefox!

I have the same problem too. Somehow the latest Firefox update messed up the ability to preview Adobe file within it's browser. I tried everything above as well. No luck. I do have a solution now. That is to uninstall Firefox and use IE or Chrome. Farewell Firefox!