搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Youtube is completly broken under firefox.(chrome/IE works normally)

  • 17 回覆
  • 24 有這個問題
  • 1598 次檢視
  • 最近回覆由 jscher2000

more options

Hello, since a day or two (22/nov/2013) youtube is not displayed proprely, in fact the whole page is a real mess and its unusable under firefox. I had to use chrome to watch videos today because of that.

I have the latest flash updates, same goes for firefox.

I made a screenshot of the whole things, but it doesnt seem like I can include it to this post.

所有回覆 (17)

more options

pic to further narrow the problem.

more options

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us.

more options

It fixed it, thanks.

more options

Nope, nevermind, after logging in my account youtube went in the same broken state.

more options

Bump for help! :'(

more options

Could you test in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled (Flash will still work)

In the dialog, click "Start in Safe Mode" (not Reset)

Any improvement?

more options

Nope, doesnt change a thing.

I want to precise that the display bug spawn as I am logged in youtube.

more options

The randomness of the page is confusing. Could you check the web console?

On a Youtube page, press Ctrl+Shift+k to open the console. If you used the player controls, you might need to click a blank area of the page first before this works.

Reload the page bypassing the cache using Ctrl+Shift+r

Click the CSS button in the console to temporarily hide CSS warnings.

Type css in the search box on the right side to view the load status of the style sheets. Do you get the two I get, both with 200 status?

more options

You bet its confusing as hell!

Anyway I get: [21:17:48,729] GET http://s.ytimg.com/yts/cssbin/www-core-2x-vflDTULqG.css [HTTP/1.1 200 OK 180ms] [21:17:48,730] GET http://s.ytimg.com/yts/cssbin/www-home-c4-2x-vflawSPr-.css [HTTP/1.1 200 OK 230ms]

Reloading the page while bypassing the cache make the page work... but for how long?

Also, I have to take back that it only happen as I am logged in youtube because the glitch also happen when I am not after further testing.

more options

Help?

Also, I have to reload pages quite often because they are all messed up(lines of codes and formatting all over the place)... dont know if its related.

Also dont be shy to ask for more information, I just dont know what to provide really.

more options

Which security software (firewall, anti-virus) do you have?

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that has any effect.

more options

A short time ago, Youtube changed its page navigation model from loading the entire page when you click a link to modifying the contents of the current page (similar to how instant prediction results work in Google search). Since the page will lay out correctly for you on reload, it suggests that something is interfering with the normal operation of the scripts that modify the pages when you navigate between videos.

Note: If you notice this problem primarily when going "back" you could work around a problem with the in-memory cache by making a setting change. This forces Firefox to re-parse the page and may slow down "Back" on all sites by some milliseconds. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste sess and pause while the list is filtered

(3) Double-click the browser.sessionhistory.max_total_viewers preference and change it to 0 (that's a zero).

Background on that: When I go back to Google search results page, it takes me to a blank Google screen

more options

Avast internet security... I will try that jscher2000.

more options

Thats what Ive got this morning while clicing on the youtube icon. Nothing to do with going back with the back button.

Also, it happen now with other website, such as mechwarrior forums or this page: http://mwo.smurfy-net.de/

more options

Clear the cache and cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

more options

In case something is corrupted in your current Firefox profile (currently active settings folder), could you do a two-minute experiment?

Create a new Firefox profile

It will have your system-installed plugins and extensions (e.g., Flash and security suite toolbars), but no themes, other extensions, or other customizations. It also should have completely fresh settings databases and a fresh cache folder.

Exit Firefox and start up in the Profile Manager using Start > search box (or Run):

firefox.exe -P

Any time you want to switch profiles, exit Firefox and return to this dialog.

When creating a new profile, I recommend using the default location suggested, and to avoid data loss, not re-using any existing folder. Before deleting unneeded profiles, I suggest making a backup first in case something were to go wrong.

Do pages lay out normally in the new profile? If so, if you exit and restart Firefox (still in the new profile), do they break on second viewing or reload?

more options

I just read in another thread that some avast users may be having issues with Youtube. This search shows recent threads on the avast forum (I didn't study them): https://www.google.com/search?q=youtube+site%3Aforum.avast.com#q=youtube+site:forum.avast.com&tbs=qdr:m