搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

此討論串已經關閉並封存。 如果您有需要幫助,請新增一個新問題

ssl_error_rx_record_too_long message on google.com and facebook.com

  • 2 回覆
  • 3 有這個問題
  • 7618 次檢視
  • 最近回覆由 NoahSUMO

more options

I recently was unable to access both facebook.com and google.com on firefox 25 for mac. I received the "SSL received a record that exceeded the maximum permissible length" message on both sites. I've reset firefox including removing all cookies and clearing the cache. (it should be noted however, that even when I do this, when I start typing something into the address bar older searches/pages will show up. Am I doing something wrong?). I've also tried running firefox in safe mode with the same results. Both websites do work on Safari.

The only solution I've come across is changing the security.tls.version.min and max to '0' in the about:config page. Is this the only solution? Should I be concerned that I'm forcing SSL 3.0 over TLS 1.0? Any help would be appreciated.

被選擇的解決方法

To answer the rest of your question, this problem isn't being caused by any cookies or cache in Firefox. It's a complicated problem on the network end that even I can't clearly describe. It seems to be either Shaw's or Google's fault and Firefox seems to be a unintended victim of the ssl error.

Changing the security.tls.version.max pref seems to be the only immediate solution for now. I don't know how much security you lose by doing this or if you'll cause other problems as result of making that change. I've asked the Firefox devs for a straight answer about that and I'll let you know what they say.

About your older searches/pages showing up in the address bar, those are your visited pages aka browser history and bookmarks. Don't worry about those, they don't harm anything and you can keep them. They help you autocomplete sites you want to visit so you don't have to type them out fully everytime.

從原來的回覆中察看解決方案 👍 0

所有回覆 (2)

more options

Hi, my guess is you live in the B.C. area and use Shaw for your internet.

There's a massive problem in your local area with Shaw not allowing Firefox users to visit Google related sites and Facebook. Both sides (Firefox & Shaw) are looking into the issue and hopefully the problem will be resolved by Shaw first, since the problem looks ISP/network related.

See this thread for more reports on the issue and any breaking news:
https://support.mozilla.org/en-US/questions/976504

由 NoahSUMO 於 修改

more options

選擇的解決方法

To answer the rest of your question, this problem isn't being caused by any cookies or cache in Firefox. It's a complicated problem on the network end that even I can't clearly describe. It seems to be either Shaw's or Google's fault and Firefox seems to be a unintended victim of the ssl error.

Changing the security.tls.version.max pref seems to be the only immediate solution for now. I don't know how much security you lose by doing this or if you'll cause other problems as result of making that change. I've asked the Firefox devs for a straight answer about that and I'll let you know what they say.

About your older searches/pages showing up in the address bar, those are your visited pages aka browser history and bookmarks. Don't worry about those, they don't harm anything and you can keep them. They help you autocomplete sites you want to visit so you don't have to type them out fully everytime.