X
點擊此處開啟此網站的行動版。

技術支援討論區

autoplay and play button do not work for videos

已張貼

I am trying to play a video (the website supports .webm, .ogv, mp4) but neither autoplay nor the start button seem to work. However, if I slide the control button to the right (+/- 40 sec) the video does play.

I have tried many of the solutions suggested in other threads (deactivating potential conflicting plugins, resetting Firefox, etc.) but none of them work.

What am I missing?

I am trying to play a video (the website supports .webm, .ogv, mp4) but neither autoplay nor the start button seem to work. However, if I slide the control button to the right (+/- 40 sec) the video does play. I have tried many of the solutions suggested in other threads (deactivating potential conflicting plugins, resetting Firefox, etc.) but none of them work. What am I missing?

被選擇的解決方法

The problem had an easy solution: changing the order of the videos, listing first the .mp4 source and next the .webm source made the videos run on Firefox, Explorer and Chrome.

Does anybody know why?

從原來的回覆中察看解決方案 0

額外的系統細節

已安裝的外掛程式

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • Shockwave Flash 11.9 r900
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • SiteAdvisor
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • McAfee MSC FF plugin DLL
  • Shockwave Flash 11.8 r800
  • 5.1.20913.0
  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • A plugin to detect whether the Adobe Creative Cloud is installed on this machine.v_2_0_0_0
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Amazon MP3 Downloader Plugin 1.0.18
  • Intel web components updater - Installs and updates the Intel web components
  • Nitro PDF Plug-in for Firefox and Chrome

應用程式

  • Firefox 25.0
  • 使用者代理:Mozilla/5.0 (Windows NT 6.3; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0
  • 技術支援網址:https://support.mozilla.org/1/firefox/25.0/WINNT/en-GB/

擴充套件

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Adobe Acrobat - Create PDF 2.0 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • McAfee SiteAdvisor 3.6.3 ({4ED1F68A-5463-4931-9384-8FFF5ED91D92}) (Inactive)
  • Wondershare Video Converter Ultimate 6.0.0 ({8D150B8F-EFE8-45a3-A4A3-053020F48FAC}) (Inactive)

JavaScript

  • incrementalGCEnabled: True

圖形

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0166
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.16384
  • driverDate: 10-1-2013
  • driverDate2:
  • driverVersion: 10.18.10.3316
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

修改過的偏好設定

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131025151332
  • browser.startup.homepage_override.buildID: 20131025151332
  • browser.startup.homepage_override.mstone: 25.0
  • extensions.lastAppVersion: 25.0
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True

其他

  • User JS: 否
  • 輔助功能: 是
Curtis Parfitt-Ford 33 個解決方法 363 個答案

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

Curtis

Hello, In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see [[How do I create a screenshot of my problem?]] Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. This will help us to visualize the problem. Thank you! Curtis

有幫助的回覆

Thanks.

You will find the screenshot attached.

Thanks. You will find the screenshot attached.

提出問題者

additional information: IE, Chrome and Safari work without problems - with Safari using Quick-Time. However on my Android phone I have problems as well. There it seems the video is continuously restarting. The website has the following code:

omitting the brackets:

video width="320" height="240" controls loop autoplay

   source src="http://www.website.com/videos/videoX.webmsd.webm" type="video/webm"
  /source
  source src="http://www.website.com/videos/videoX.ipad3.mp4" type="video/mp4"
  /source
  source src="http://www.website.com/videos/videoX.oggtheora.ogv" type="video/ogv"
  /source
 /video"
additional information: IE, Chrome and Safari work without problems - with Safari using Quick-Time. However on my Android phone I have problems as well. There it seems the video is continuously restarting. The website has the following code: omitting the brackets: video width="320" height="240" controls loop autoplay source src="http://www.website.com/videos/videoX.webmsd.webm" type="video/webm" /source source src="http://www.website.com/videos/videoX.ipad3.mp4" type="video/mp4" /source source src="http://www.website.com/videos/videoX.oggtheora.ogv" type="video/ogv" /source /video"

由 dutch78 於 修改

提出問題者

Looking forward to support ..

Looking forward to support ..

由 dutch78 於 修改

選擇的解決方法

The problem had an easy solution: changing the order of the videos, listing first the .mp4 source and next the .webm source made the videos run on Firefox, Explorer and Chrome.

Does anybody know why?

The problem had an easy solution: changing the order of the videos, listing first the .mp4 source and next the .webm source made the videos run on Firefox, Explorer and Chrome. Does anybody know why?