搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

old tabs

  • 16 回覆
  • 1 有這個問題
  • 155 次檢視
  • 最近回覆由 cor-el

more options

every time i open Firefox it starts with my previous tab that i was using. i have it set to go to my homepage, but it never does. i thought maybe this was a problem with firefox 24 and waited until 25 was released. but the problem still remains.

所有回覆 (16)

more options

Try to delete the file "sessionstore.bak". This file is stored in your Profiles - Where Firefox stores your bookmarks, passwords and other user data

more options

thanks, I just tried that based on your suggestion but that didnt seem to fix the problem

more options

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

more options

thank you for the advice, i tried removing my theme and starting in safe mode but that still didn't fix the problem

more options

Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from http://www.mozilla.org and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

Please report back to see if this helped you!

Thank you.

more options

i would prefer to not have to do that if possible. are there any other solutions without having to do a clean install? thank you

more options

Just the one tab, not all the tabs from your last session?

How do you shut down Firefox: using Exit from the menu, or the red X button(s), or the Close All Windows command from the Windows Task Bar?


Could you check two things?

browser.startup.page

Just in case this setting does not correspond to your choice in the Options dialog:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste start and pause while the list is filtered

(3) Check the browser.startup.page preference and see whether it matches what you want:

  • 0 => open a blank page
  • 1 => open your home page
  • 3 => restore your windows and tabs from last time
  • other => undefined?

Anything unusual here?

user.js File

Your "More System Details" shows you have a user.js file in your personal Firefox settings folder (your Firefox profile folder). Firefox will read the settings specified in this file at startup, and use them to override your settings. This article describes how to track down and remove the file: How to fix preferences that won't save.

Any luck?

more options

You can check if you have an user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.


Note that your System Details List shows that you have a user.js file in the profile folder to initialize some prefs on each start of Firefox.

The user.js file is only present if you or other software has created it, so normally it wouldn't be there. you can check its content with a plain text editor if you didn't create this file yourself.

The user.js file is read each time you start Firefox and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

more options

hello sorry that was not clear, it will re-open whatever i had previously open. so if i had 5 tabs it will re-open those same 5 tabs. i close out of firefox by clicking the x on the top right. i went into the about:config like your recommended but it was set properly. I also dont see a user.js file in my folder? anything else? thank you all for your efforts

more options

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)

Note that Windows hides some file extensions by default.
Among them are .html and .ini and .js and .txt, so you may only see a name without file extension.
You can see the real file extension (type) if you open the Properties of the file via the right-click context menu.

more options

i deleted the user.js and it is still happening

more options

i figured out something interesting that might help solve this problem. i was running the program CCleaner and when i highlight clear session for firefox, it will open my homepage normally. there is something wrong with the session settings i guess. does this help at all?

more options

I'm not sure exactly what CCleaner is removing, but if it is removing sessionstore.js, the file that stores your windows and tabs from your previous session, then that would make it impossible for Firefox to restore your session and instead you would only be able to start up to the home page.

In re-reading posts, I just noticed you are closing Firefox using the "red X" button. Could you try using Exit from the menu, either

  • orange Firefox button > Exit
  • File menu > Exit

While closing the last window should cause Firefox to exit properly, perhaps that is not working correctly and Firefox is crashing during shutdown.

more options

Did you check in the Firefox profile folder if there is a file user.js?

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)

Note that Windows hides some file extensions by default.
Among them are .html and .ini and .js and .txt, so you may only see a user name without file extension (type JSCRIPT).
You can see the real file extension (type) if you open the Properties of the file via the right-click context menu.

more options

deleting the user.js fixed it!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


Thank you all sooooooo much

more options

You're welcome.