搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Disqus and other comment boxes no longer appear.

  • 21 回覆
  • 74 有這個問題
  • 15299 次檢視
  • 最近回覆由 Tricia_TD

more options

I upgraded to Firefox 24.0 a few days ago. (At the same time, I also upgraded to the latest java.) I have a Dell laptop running Windows XP.

After I upgraded, Disqus comment boxes (and some others) no longer appear in my browser. And I don't mean fail to load, that's an old Disqus problem (occasionally). They flat out do not appear.

As a result, I've gone back to using Chrome, which shows them just fine. I like Firefox better than Chrome, but if I can't see comments on my usual sites, it's dead to me.

被選擇的解決方法

Yes, that is what I have done.

Everything is working fine now. ~

從原來的回覆中察看解決方案 👍 2

所有回覆 (20)

more options

P.S. Here is an example of a website that uses Disqus.

http://www.eschatonblog.com/2013/10/the-conservatism-of-obamacare.html

The comment box doesn't even appear. But it does in Chrome. ~

more options

So...some people at Eschaton have the new firefox, and they can use Disqus.

As far as I know, all of those people use Windows 7.

Is anyone out there able to use disqus sites with Windows XP? ~

more options

I don't have XP handy (I can find an old laptop at some point, but not immediately).

To see whether the upgrade might conflict with one of your add-ons, could you try the site Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

more options

You can try these steps in case of issues with web pages:

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

more options

How much of the header/form area is missing? Do you have the avatar, or is that entire area missing? Is more than the form missing?

The attached screen shot shows the result of right-click > Inspect Element (Q), although I clicked between the avatar and textbox and then clicked into the postbox in the HTML pane to avoid expanding the postbox by right-clicking on it directly.

由 jscher2000 於 修改

more options

None of it shows, here'sa screencap.

I tried a screengrab with inspect element, but it's not displaying the element information. ~

more options

Is there any reason that JavaScript might be disabled on that site? Firefox's internal JavaScript on/off switch is global, so if you have scripts disabled, you will be told that by many sites.

There may be some selective filtering/blocking by extensions -- if you never tried this site in Firefox's Safe Mode, please do that test -- or by external security/privacy software.

more options

Thanks, people. I don't yet have an answer...but I do have a culprit.

My dad's computer here is also running Windows XP. So I updated it to Firefox 25, and disqus worked fine.

What's different? I have updated java on my laptop, updated to the newest Avast antivirus program, I have Adblock Edge (that was my original suspicion, but messing around with it improved nothing), and I have a screengrab add-on I use a lot.

So the next thing I did on my dad's pc is update Avast. Bang, disqus is gone...just like on my laptop. ~

more options

I should clarify: The latest Avast seems to be blocking Disqus in Firefox. Disqus comments still work in Chrome on my dad's pc, as they do on my laptop.

~

more options

Great sleuthing. On the Avast forums, this has been attributed to the Online Security extension.

Does that extension let you approve/trust/exclude certain domains? If so, try approving both:

more options

Not sure whether this is correct, but according to one thread out on the web, you can turn off avast's blocking of a site in Firefox by adding the site to the Trusted Sites list in Internet Explorer (same as the Internet Options dialog available in the Windows Control Panel). See: avast! Online Security 9.0.2006.53 Add-on for Firefox Blocks All Video Streams.

由 jscher2000 於 修改

more options

jscher, I tried adding disqus.com, disquscdn.com, and eschaton.com to Settings, Antivirus, Exclusions in avast!, but to no avail.

I also looked at the avast! add-on (avast! Online Security 9.0.2006.53) in Firefox, and tried to disable it. (Firefox - Tools, Add-ons, Extensions.) In spite of the message "avast! Online Security will be disabled after you restart Firefox", it was not disabled. Even after I rebooted the laptop twice.

A new avast! program: 2014.9.0.2008 was released this morning at 5:16 A.M. It still blocks disqus, but I could finally disable that plug-in...and for the first time in weeks, disqus now works in Firefox.

I'd mark this problem as solved (and it is a avast! problem, not a Firefox problem), but I want to try contacting the avast! people first (for instance, I want to know if disabling the plug-in means there is no anti-virus protection when I use Firefox, or is it just some extra layer that they added on top).

Be back when I have an answer, or even if I don't get one...

~

more options

yes...they all opened  !! how do i open them w/o disabling add-ons ?

more options

Hi robert5711, since this forum is not threaded, I'm not sure what you tried. Did you restart in Firefox's Safe Mode? I think you only need to disable the avast! Online Security extension. You can do that on the Add-ons page. Either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Extensions.

more options

It works fine now!!! Do I leave the avast extention disabled??

more options

選擇的解決方法

Yes, that is what I have done.

Everything is working fine now. ~

more options

THKS IF!

more options

If, thank you very much for sharing how to fix this, it was driving me crazy!

Disabling firefox's add for avast will fix disqus issues.

Thanks again, E.

more options

Have you heard back from Avast about this?

more options

This happens on XP, Windows 7 and Windows 8.1. Avast is the common factor. And if the choice is keeping Firefox and losing comments or reducing security in this malware laden age? Sorry, Firefox, you lose.

I can't imagine that there isn't a technical solution since other browsers work.

  1. 1
  2. 2