搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Youtube Problem

  • 9 回覆
  • 74 有這個問題
  • 7817 次檢視
  • 最近回覆由 Will Lanni

more options

Hello.. I have spent for almost 6hours solving this problem :(
Can anyone here help me why my Youtube displayed suddenly like this

I already cleared all the cache and history.. I even reset the firefox settings and disabled the extensions and plugins.. :(
and also i tried to uninstall and reinstall firefox but doesnt seem to help my problem.. Safe mode is not working also.. :(

PLEASe HELP!

由 cor-el 於 修改

所有回覆 (9)

more options

Hello chelotcute,

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

more options

You can try basic steps like these in case of issues with web pages:

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
more options

I did all the of ur possible solution unfortunately none of it solved my problem.. :(

I already upgraded the graphic acceleration drivers or and disabled the WebGL still doesnt work :(

more options

I've had the same problem yesterday, in my computer (xp) and the laptop (w7) (different systems and different software...). I was not able to display properly youtube. I tried all the cache solutions without solving the problem.

I've solved installing the addon https everywhere and forcing the site to htpps.

由 skeeper1 於 修改

more options

I found that this issue was caused by the following CSS on a parent container:

transform: translate3d(0,0,0);

Once I removed this style from the parent container, the embedded youtube video began working again.

FireFox 25 and 26, both Windows and Mac.

more options

Hi wlanni, is that a solution for people embedding Youtube into other sites, or a hack for end-users on youtube.com?

more options

Hello,

Starting in Firefox 23, if a secure page includes certain types of insecure content, Firefox blocks the insecure content and a shield icon will appear in the address bar. See this article for more information about the new mixed content blocker: Mixed content blocking in Firefox

To temporarily allow the mixed content to be displayed:

  • Click the shield icon Mixed Content Shield in the address bar and choose Disable Protection on This Page from the dropdown menu.

Fx23MixedContentBlocker

To allow insecure content to be displayed in all secure pages, enter about:config in the address bar and double-click on this preference, to toggle it from true to false:

security.mixed_content.block_active_content

You can also use this add-on instead, to toggle the preference:

You may want to do this only for the current session, then reset the preference back to "true" and check back with the site to see whether it's been fixed, since this is a global setting that exposes you on all sites, not just the one you care about.

Let us know if this helps!

more options

Quote:

I found that this issue was caused by the following CSS on a parent container: transform: translate3d(0,0,0);

That sounds like an issue similar to reported in another thread where transform: translateX(-250px); is used for the containing DIV and an iframe with a YouTube video didn't work.

more options

@jscher2000 -- this was a solution for embedding a video on our site using the newer embed code off of YouTube in the iframe (as opposed to the old flash code).

We had either a black box with no poster frame and a red play button that did nothing, or the poster frame would appear but clicking wouldn't work, or it might play but none of the YouTube interface controls would work. I rebuilt the page line by line, and the video worked fine in FF (v25, then v26 this morning) until it was wrapped in a div with that transform code. As soon as I pulled that one line of CSS off everything worked fine. If you want to test to see if it works for you (or not), look here:

http://www.getty.edu/research/exhibitions_events/exhibitions/connecting_seas

Hope this helps!!