搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

All my Yahoo Mail icons disappeared after I installed Firefox 24.0.

  • 51 回覆
  • 69 有這個問題
  • 13660 次檢視
  • 最近回覆由 bobchapman

more options

Immediately after installing Firefox 24.0, the entire look of my Yahoo Mail page changed, and all the usual icons for reply, attach, forward etc. disappeared and were replaced by small boxes with letters in them. I don't have this problem in Safari.

被選擇的解決方法

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.


Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl+0 (zero); Command+0 on Mac)

Try to disable hardware acceleration in Firefox.

從原來的回覆中察看解決方案 👍 2

所有回覆 (20)

more options

Hello,

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

more options

Thanks for responding. I had previously tried this. No luck. I also tried disabling extensions and that didn't work either. I am confident it is a Firefox issue related to the installation of version 24.0 because I didn't have this issue before the installation and Yahoo Mail works fine on Safari.

more options

Hi dansolin, Yahoo! uses a custom font for buttons like reply and forward, and if the font is blocked or if you do not let sites choose their own fonts, these may be replaced by "character not found" symbols (a box with 2 rows of 2 characters).

If what you see is similar to the screen shot in the following post, please check out the rest of that thread and see whether it helps: https://support.mozilla.org/en-US/que.../972964#answer-487473.

more options

Thanks so much. That solved the problem of the missing icons. Much appreciated. The page still looks very different than it did before. The margins between the columns are much narrower and the font is very different, but I think I can deal with those issues.

Dan

more options

選擇的解決方法

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.


Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl+0 (zero); Command+0 on Mac)

Try to disable hardware acceleration in Firefox.

more options

Changing the font options to permit web sites to choose their own fonts solved the missing font issue. Changing the Yahoo Mail setting to view in basic fixed the other presentation issues. My sincere thanks to those who helped. Much appreciated.

more options

none of this really fixes it though it isn;t a virus the full featured ymail should work it does not fonts are missing why?

the 'enable web sites to load their own fonts' does not work

it;s just broken it is very easy to see the problem in the new yahoo mail IF anyone would try it instead of just saying download 99 virus and bot checkers, maybe that is it it isn;t that


wle

more options

Hi wlexxx, could you describe the problem you're seeing in more detail?

There are two aspects to fixing the custom font problem (the one that shows rectangles with two rows of two digits):

  1. Let the site choose its own fonts (see attached screen shot); and
  2. Since it's a custom font Firefox needs to download from the site, make sure that isn't blocked.

On the latter point, do you want to check the about:config preferences editor here:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste gfx and pause while the list is filtered

(3) If the gfx.downloadable_fonts.enabled preference is bold and user set to false, double-click it to restore the default value of true.

Any luck?

more options

no that didn;t do anything different i even restarted firefox wle

more options

surely other people are having this problem wle

more options

disable hardware acceleration didn;t do anything gfx download enable true didnt; do anything let sites choose their own fonts didn;t do anything

can someone just open a yahoo account and see for themselves? i see hundreds of complaints on twitter, FB, etc over this it;s virtually unusable

wle

more options

screen shot

more options

Hi wlexxx, your Yahoo layout is different than mine, I'm not sure why. (See attached screen shot.) Maybe Yahoo is experimenting?

If you haven't already, when you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. This can resolve issues caused by mixing up older and newer cached files or sending the site obsolete parameters.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

more options

Does such a font with icons work on this page that uses octicon (scroll down to the lower section)?

more options

yes i can see those can;t see yahoo page fonts wle

more options

no, as i said, clearing history, offsite content, cookies, cache doesn;t fix it wle

more options

anyone? bueller? bueller?

more options

Hi wlexxx, your case seems to be more intractable than other Yahoo users. To test how Firefox runs "uncustomized" on your system, could you do a two-minute experiment?

Create a new Firefox profile

It will have your system-installed plugins (e.g., Flash), but no themes, extensions, or other customizations. It also should have completely fresh settings databases and a fresh cache folder.

Exit Firefox and start up in the Profile Manager using Start > search box (or Run):

firefox.exe -P

Any time you want to switch profiles, exit Firefox and return to this dialog.

When creating a new profile, I recommend using the default location suggested, and to avoid data loss, not re-using any existing folder. Before deleting unneeded profiles, I suggest making a backup first in case something were to go wrong.

How does Yahoo mail look in the new profile?

more options

ok i have no add ons enable sites to use own fonts is true still no icons in yahoo email ctl shift r again and again

nothing

" It also should have completely fresh settings databases and a fresh cache folder." not sure how to verify that


wle

more options

Does such a font work here on GitHub (scroll down to see the octicons)?

  1. 1
  2. 2
  3. 3