搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

I can no longer log in to my enewspaper (vancouversun.com) using Firefox 24 - works with IE9. What's changed and how can I correct it?

  • 17 回覆
  • 2 有這個問題
  • 445 次檢視
  • 最近回覆由 PatL

more options

For years I've been able to log in to my epaper at www.vancouversun .com, but just lately that's changed. I enter my name and password, hit the sign in button and everything just hangs. It's possible that the problem started after the latest update to Firefox 24, but I'm not positive. I can log in OK using IE9 - I tried it as a test. I suspect it's some kind of security feature, but is there a way I can override it for this site?

被選擇的解決方法

That is possible.

Did you try Firefox Safe Mode?

You can look at some prefs to prevent websites from disabling or removing toolbars and user interface elements.

Any luck with a Private Browsing mode window?


You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

從原來的回覆中察看解決方案 👍 1

所有回覆 (17)

more options

Hello,

Starting in Firefox 23, if a secure page includes certain types of insecure content, Firefox blocks the insecure content and a shield icon will appear in the address bar. See this article for more information about the new mixed content blocker: Mixed content blocking in Firefox

To temporarily allow the mixed content to be displayed:

  • Click the shield icon Mixed Content Shield in the address bar and choose Disable Protection on This Page from the dropdown menu.

Fx23MixedContentBlocker

To allow insecure content to be displayed in all secure pages, enter about:config in the address bar and double-click on this preference, to toggle it from true to false:

security.mixed_content.block_active_content

You can also use this add-on instead, to toggle the preference:

You may want to do this only for the current session, then reset the preference back to "true" and check back with the site to see whether it's been fixed, since this is a global setting that exposes you on all sites, not just the one you care about.

Let us know if this helps!

more options

Hello, Many thanks for your prompt response. The epaper page doesn't have a shield icon. The sign in box appears to be separate, but it doesn't have any address bar. I've downloaded the add-on you suggested and clicked the A icon to turn it red. I also deleted all related cookies. Unfortunately, I still have the same problem. I reset the A icon to green.

more options

Can you reproduce in safe mode????

more options

I just tried safe mode and got the same result.

I can actually read the front page of the newspaper - it's the sign in that seems to hang.

As I mentioned - I can sign in using IE9.

Thanks again.

more options

Clear the cache and only cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

If clearing cookies doesn't work then it is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.

more options

Thanks cor-el.

I have tried all your suggestions, but still have the same problem.

I checked more into the newspaper support page and found their fix for IE is:-

  - ........ check "display mixed content"
  - This will stop the login pop-up window appearing repeatedly and/or login from being cut-off.

This implies that the problem is with the mixed content, so the "Toggle Mixed active content" add-on should have fixed it - but it didn't.

more options

Do you see a shield icon on the location bar indicating that Firefox is blocking mixed content?

If content is missing or otherwise not working when a secure https connection is used then check if there is a shield icon to the left of the "Site Identity Button" (globe/padlock) on the location bar indicating that content is blocked.

You can also check the Net log in the Web Console (Firefox/Tools > Web Developer;Ctrl+Shift+K).

more options

The epaper page doesn't have a shield icon. The sign in box (where the problem is) appears to be separate, but it doesn't have any address bar.

I'm afraid the developer site was a little over my head and I didn't get much from it.

more options

The log in pop-up connects to a secure connection

  • https://login.canada.com/openid/embed

You can try to clear the cache and only cookies from this web page (click the "Site Identity Button" (globe/padlock) on the location bar and click More Information > View Cookies).

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"
more options

cor-el,

Thanks for your continued support. I waited a couple of days because my epaper was having server problems and I thought that might be the source of my problem. It wasn't.

I followed your instructions: cleared the cache and deleted all related cookies. I still have a problem.

I went direct to the canada.com login site and logged in from there. It hung on the following:- https://sso.canada.com/capture/redirect?code=jkhb8hnhy2d2da

When I went directly to the sso site, I got the message:- An error occurred while trying to sign you in. Please try again later.

I can still log in from IE9.

Thanks for your help with this.

more options

Did you check for cookies from the sso.canada.com site?

You can inspect and manage the permissions for all domains on the about:permissions page or for the domain in the currently selected tab by clicking the "Site Identity Button" (globe/padlock) on the location bar and "More Information" to open "Page Info" and go to the Permissions tab.

You can try to enable third-party cookies as a test if they currently are disabled.

  • Firefox/Tools > Options > Privacy > Firefox will: "Use custom settings for history"
more options

There were no cookies from the sso.canada.com site.

The "permissions" information was very interesting. I tried allowing more for the relevant sites, but still no solution.

I've also tried enabling third-party cookies - again with no solution.

Finally, I: - cleared the cache; - deleted all relevant cookies; - enabled third-party cookies; - toggled the Add-on to allow mixed content; - disabled Adblock Plus; - even disabled Norton's firewall.

Still can't log-in.

One thing I did notice - the page and frame info showed quite a lot of Java script. Could some of this be causing a problem?

Thanks again.

more options

選擇的解決方法

That is possible.

Did you try Firefox Safe Mode?

You can look at some prefs to prevent websites from disabling or removing toolbars and user interface elements.

Any luck with a Private Browsing mode window?


You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

more options

Thanks once again for your continued support.

I'd tried Firefox Safe Mode already, but hadn't even considered the Private Browsing mode. However, when I tried it - guess what - I got signed in!!!

Now I can sign in without going to a Private Mode window. I even have everything set back as it was before:- the mixed content Add-on disabled; -Adblock Plus enabled; -Third Party Cookies not accepted.......

I'm not sure quite what changed. Are you able to explain this?

Thanks again.

more options

A Private Browsing mode window doesn't use the cookies from the normal mode and also the disk cache is disabled. It is possible that the serv4erstill had stored some data that is stored in a cookie or that there were still problems with the previously stored cookies.

You did previously delete the cookies.sqlite file like I suggested above to remove all cookies?
Did you close all open tabs before doing that because otherwise the cookies will get stored as part of the session data?

more options

Yes, - I did previously delete the cookies.sqlite file like you suggested. Actually, I closed Firefox and renamed the cookies.sqlite file. I also tried using an old cookies.sqlite file from August when everything was working OK.

How is the disk cache cleared? Does Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" clear the disk cache? Is this related to the off-line website data?

Thanks once again.

more options

Unfortunately, the Private Browsing mode didn't actually fix the problem. I guess it was just a coincidence. I could log in for a few days and then the problem reoccurred - and Private Browsing mode didn't fix it this time.

So - knowing that it sometimes worked, I went logically through every combination of settings that I could find and I now have the solution. I don't need to:- use Private Browsing mode; allow "mixed content"; allow third party cookies; disable AdBlock Plus; disable virus protection; .....

I just need to keep cookies until "they expire".

I used to set my option to "ask me every time". This doesn't work! It doesn't really make sense to me, but so far the solution has worked 100% of the time. Can any one explain why? Thanks.

由 PatL 於 修改