搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

No spellcheck in Firefox 24

  • 24 回覆
  • 49 有這個問題
  • 2987 次檢視
  • 最近回覆由 peterac

more options

After FF24 update some input fields just don't want to check me spelling. I have all dictionaries installed, but on some text arias i just don't have a spellcheck option. Only thing i have is "install dictionaries...". In some other *more simple* text fields everything works just fine. Most problematic are all kinds of visual html editors. In the most cases i have problem as i mentioned above, but if i open raw html window for exmple, the splellcheck function of FF24 works as it should. That what i mean by "more simple text fields" i.e. less visual formatting.

Any suggestions, please?

P.S. Tried on different PCs, with different browsers including Nightly. The result is the same on anything above 23.

所有回覆 (20)

more options

Certain websites can disable the spellcheck feature in certain textareas on their webpage.

Have you ever been able to use spellcheck on the page your are having issues with?

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
more options

Yes, the spellcheck was present until v24 update.

more options

Safe mode doesn't help too. As i said i've tried this on different PC's, so its firefox problem.

more options

Does it have effect if you copy the two dictionary files (xx-XX.dic and xx-XX.aff) of each dictionary to the dictionaries folder in the Firefox program folder?

This dictionaries folder may not exist if you have a Firefox locale that doesn't come with a dictionary.

You can use this button to go to the Firefox profile folder:

more options

Yeah. Now my language options in the spellcheck menu are doubled. But they are still not where i want them to be i.e. problem is still present.

more options

Little Update. I Found a fine example of my problem: http://www.tinymce.com/tryit/3_x/url_conversion.php It's the same type of visual editor i usually use. And the spellcheck was working there before v24. Try to type and check spelling within any of these fields on the page i mentioned above.

more options

Please try the following:

  1. Go to about:config
  2. Locate the layout.spellcheckDefault string
  3. If not already, change the value of this string to 1

Please report back soon.

more options

That is a contenteditable text area with spellcheck disabled.

contenteditable="true" onload="window.parent.tinyMCE.get('absurls').onLoad.dispatch();" spellcheck="false"
  • Bug 905176 - For input/textarea/contenteditable with spellcheck="false", "Check Spelling" context menu should be disabled/hidden
  • Bug 908570 - no longer able to check spelling on etherpad - only "add dictionary" is present

Please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

more options

Cor-el, so bugs are going to be fixed?

ComputerWhiz, the string is already = "1"

more options

If the string is already set to "1", then try setting the string to "2".

Please report back soon.

more options

The editor on the tinymce web page disables the spell checker, so you can't use the built-in Firefox spell checker.

The change is that they have removed the check box to enable the spell check that was present in previous Firefox versions, but the bug is that you still have a (worthless) Add dictionary entry visible.

You would have to use the built-in Inspector to remove the spellcheck="false" attribute or remove this attribute otherwise (probably not possible with a bookmarklet because this is an iframe).

由 cor-el 於 修改

more options

After upgrade to FF24 no spell check option for posts in Lithium powered boards.

more options

You can right-click in the text editor area and use "Inspect Element" to see if this text area has a spellcheck="false" attribute.
Removing this spellcheck="false" attribute by selecting it via a double-click and using the Delete or Backspace key should make the Check Spelling item in the right-click context menu reappear.

由 cor-el 於 修改

more options

cor=el, yes that makes it reappear, but it is only temporary then is reverts back for the next post or reply. This was not the case until the FF24 upgrade.

more options

You would need a Scriptish or GreaseMonkey script to remove this attribute automatically on page load.

Maybe this one works:

more options

cor-el, thanks, but this was not an issue until FF24. What has changed in FF24 to now make this a problem?

more options

In Firefox 24 and later the Check Spelling item is removed from the right-click context menu when there is a spellcheck=false attibute present.

  • bug 905176 - For input/textarea/contenteditable with spellcheck="false", "Check Spelling" context menu should be disabled/hidden

Please do not comment in bug reports: https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

more options

So you are saying this is the way FF24 and later will continue to work with no easy override?

more options

Thx cor-el for the greasemonkey script, but its not working on tiny mce. I figuted out adding "gecko_spellcheck: true," into the tinyMCE.init code in HTML source is helping (i was edititng locally saved html document). But how to add a line into the HTML source of a web page? Tried to google some greasemonkey tutorial, but didn't find anything understandable. Maybe somebody can give a tip on how to add a single line on exact place in HTML source?

  1. 1
  2. 2