搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

searching in the address bar takes me to a polish site

  • 6 回覆
  • 4 有這個問題
  • 2 次檢視
  • 最近回覆由 cor-el

more options

Until just about a week or two ago, if I typed in a word or phrase into the address bar (NOT the search engine bar!), I would get either google results or it would take me to the page. Now, if I type in just a word to search in the address bar, it takes me to some polish site (2be.pl is the address of the site - what?). I have searched for viruses, malware, unwanted add-ons, etc., and there is nothing. If I type in a phrase instead of just one word, though, it takes me to google results. I've never visited that Polish site and I also mainly use this computer for work, so I have not been on any sketchy sites. Any ideas to fix this?

所有回覆 (6)

more options

hello, is it happening with other browsers on the same system as well?

more options

No - if I use Google Chrome, the searching in the address bar takes me directly to Google results.

more options

Location Bar (address bar) searches were changed in Firefox 23. Now it's the same search engine as in the Search Bar, and uses the same search engine which is selected in the Search Bar.

You can use this add-on to restore that feature, as it was in Firefox 22 and earlier versions.
https://addons.mozilla.org/en-US/firefox/addon/keywordurl-hack/
Since Firefox 23 the keyword.URL preference lost its purpose. However with it an interesting feature of the awesomebar got lost as well, because it is now impossible to use a different search engine for it and the search box.

more options

you might want to try installing the search reset addon or to select a different search provider in the address bar and see if this is making a difference.

my other thought was that something has overwritten the default dns configuration on your system (it might have no effect in google, since it might always divert input into the location bar directly to google.com whereas firefox will treat a single word as a web address and sends it to the dns server to resolve it) - you might want to try to flush the dns cache and to use google's public dns service: https://developers.google.com/speed/public-dns/

由 philipp 於 修改

more options

Thank you so much for your responses! The add-ons did not work. On my lunch break, I will try the DNS configuration - it looks a little bit complicated, at least for me, so it will take me awhile.

more options

Also check the connection settings.

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":