搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

How do I stop AVG Secure Search from opening itself when I open a new tab?

  • 6 回覆
  • 48 有這個問題
  • 2 次檢視
  • 最近回覆由 cor-el

more options

The AVG add-on really likes to make itself known to you. So every time you open a new tab, it loads a page like this:

http://isearch.avg.com

with a bunch of weird parameters after it.

However, you can fix this.

in about:config

search for

avg.userPreferences.newtabDisabledByUser

and change it to

true

We also changed

avg.install.newtab

to

false

Namaste!

The AVG add-on really likes to make itself known to you. So every time you open a new tab, it loads a page like this: http://isearch.avg.com with a bunch of weird parameters after it. However, you can fix this. in about:config search for avg.userPreferences.newtabDisabledByUser and change it to true We also changed avg.install.newtab to false Namaste!

所有回覆 (6)

more options
more options

Lol, resetting looks like it would indeed work, and I didn't actually know about this feature, so thanks.

It looks like it will also nuke all customizations, though, even the ones you would still want.

The above changes to about:config variables will stop AVG from opening itself every time a new tab is opened, so I'm considering the issue closed, but I just wanted to share this information with other people, so I posted it in the support forum.

more options

What is "about:config"? Where do I find it to do a search. I put it into the Start search, clicked on it in the list and it opened IE saying "Navigation to the webpage was canceled".

more options

You can open about: pages like about:config via the location bar (about: is a protocol used to access special built-in pages).
You can accept the warning and click "I'll be careful" to continue.

more options

Thank you for explaining that. However, I tried the reset Firefox, and that didn't work but destroyed a lot of useful stull. So I downloaded a new version of Firefox from the website, uninstalled Firefox, rebooted and then reinstalled loading bookmarks from a backup. That got rid of it, but it might be back, so the information is useful for that if nothing else.

more options

There is usually no need to reset Firefox for issues like this.
Resetting all prefs (i.e. deleting prefs.js and possibly user.js) and checking for extensions should be sufficient to fix this.
It this doesn't help then you may have software that protects files in the Firefox profile folder or runs Firefox in a sandbox environment.