搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

When I scroll down in facebook my screen turns black.

  • 4 回覆
  • 70 有這個問題
  • 1 次檢視
  • 最近回覆由 cor-el

more options

When I scroll down on facebook my screen turns black for a few seconds. In the past, it used to do it only on tumblr, but it hasn't happened there in quite a while.

At that time, I actually thought it was do to my computers memory (I tend to leave my computer on a lot and I also tend to have many active windows and tabs) but now, it sometimes does it within only a few minutes of restarting my computer, when I haven't done a whole lot, so I don't think it's memory.

It has only happened on those sites and on both, there's infinite scrolling and constant loading of information, so perhaps it's to do with that.

It always comes back after a couple seconds if I continue to scroll, but if I stop scrolling, it stays black indefinitely.

I do have a screenshot showing exactly what it does, but I wasn't sure how to submit it, but I'd be happy to do so, if needed, if I can get some instructions on how to do it.

At this time, it's more annoying than anything else, but if it's a sign of a bigger issue with my computer, I need to figure it out.

Any help would be appreciated. Thanks

所有回覆 (4)

more options

Aha! Here's a screenshot of what it does .... As you can see, it's not the whole screen that is black. Just the part I want to read ...

more options

Some inexplicable display glitches can be caused by Firefox being incompatible in some way with your graphics card drivers. The standard workaround for that is to disable Firefox from using hardware acceleration of graphics.

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, is the issue resolved (or at least improved)?

more options

Occasionally Firefox will get a little mixed up with cached files and cookies. This can be a problem on dynamic sites that use a lot of elements. According, when you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.