搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

I can't play YouTube videos on Firefox.

  • 26 回覆
  • 103 有這個問題
  • 19648 次檢視
  • 最近回覆由 baachitraka

more options

When I try to play a YouTube video, It says an error has occured. I did look at help articles for help on this, but it required downloading something, and I don't have enough disk space. Is there something else I can do?

所有回覆 (20)

more options

Doesnt seem like you have the Adobe Flash plugin, needed for youtube videos, you would have to download flash, see the article below.

more options

I already have Flash Player Waka_Floca_Flame. I don't think I will be able to install it, there is very low space on this computer.

more options

Have you deleted the pluginreg.dat file? And or install the non ActiveX version, see below.

more options

This does not help.

more options

Is it reproducible in safe mode?

Or after clearing the cache and cookies?

more options

That makes no sense. That would not even apply, but I will try something else.

more options

Oh yeah it applies, belive me. I read again and the plugin listed you do have Flash so Im not sure whats going on.

more options

Neither do I.

more options

Can you then post troubleshooting info?

  • Click the Firefox button at the top left, then click the Help menu and select Troubleshooting Information from the submenu. If you don't have a Firefox button, click the Help menu at the top and select Troubleshooting Information from the menu.

Now, a new tab containing your troubleshooting information should open.

  • At the top of the page, you should see a button that says "Copy text to clipboard". Click it.
  • Now, go back to your forum post and click inside the reply box. Press Ctrl+V to paste all the information you copied into the forum post.

If you need further information about the Troubleshooting information page, please read the article Use the Troubleshooting Information page to help fix Firefox issues.

more options

Sure thing.


 Application Basics
       Name
       Firefox
       Version
       23.0.1
       User Agent
       Mozilla/5.0 (Windows NT 5.1; rv:23.0) Gecko/20100101 Firefox/23.0
       Build Configuration
         about:buildconfig
 Extensions
       Name
       Version
       Enabled
       ID
       DoNotTrackMe
       2.2.9.618
       true
       donottrackplus@abine.com
       MaskMe
       1.25.303
       true
       idme@abine.com
 Important Modified Preferences
     Name
     Value
       browser.cache.disk.capacity
       358400
       browser.cache.disk.smart_size.first_run
       false
       browser.cache.disk.smart_size.use_old_max
       false
       browser.cache.disk.smart_size_cached_value
       215040
       browser.newtab.url
       about:home
       browser.places.smartBookmarksVersion
       4
       browser.startup.homepage_override.buildID
       20130814063812
       browser.startup.homepage_override.mstone
       23.0.1
       browser.tabs.warnOnClose
       false
       dom.mozApps.used
       true
       extensions.lastAppVersion
       23.0.1
       network.cookie.prefsMigrated
       true
       places.database.lastMaintenance
       1377302418
       places.history.expiration.transient_current_max_pages
       11017
       plugin.disable_full_page_plugin_for_types
       application/pdf
       plugin.importedState
       true
       privacy.donottrackheader.enabled
       true
       privacy.sanitize.migrateFx3Prefs
       true
       privacy.sanitize.timeSpan
       0
       storage.vacuum.last.index
       1
       storage.vacuum.last.places.sqlite
       1376259967
 Graphics
       Adapter Description
       MOBILITY RADEON 9200
       Adapter Drivers
       ati2dvag
       Adapter RAM
       Unknown
       Device ID
       0x5c61
       Direct2D Enabled
       Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer.
       DirectWrite Enabled
       false (0.0.0.0)
       Driver Date
       7-30-2003
       Driver Version
       6.14.10.6382
       GPU #2 Active
       false
       GPU Accelerated Windows
       0/1 Basic Blocked for your graphics driver version. Try updating your graphics driver to version 9.6 or newer.
       Vendor ID
       0x1002
       WebGL Renderer
       Blocked for your graphics driver version. Try updating your graphics driver to version 9.6 or newer.
       AzureCanvasBackend
       skia
       AzureContentBackend
       none
       AzureFallbackCanvasBackend
       cairo
 JavaScript
       Incremental GC
       true
 Accessibility
       Activated
       false
       Prevent Accessibility
       0
 Library Versions
       Expected minimum version
       Version in use
       NSPR
       4.10
       4.10
       NSS
       3.15 Basic ECC
       3.15 Basic ECC
       NSSSMIME
       3.15 Basic ECC
       3.15 Basic ECC
       NSSSSL
       3.15 Basic ECC
       3.15 Basic ECC
       NSSUTIL
       3.15
       3.15
more options

And i dont see anything wrong? can you reinstall the plugin if you havent already.

more options

Just to be clear on this, do I uninstall my version, and then type it in and install it? And please tell me which one I need to install.

more options

Uninstall from the XP control panel, then download the latest one from

more options

Clear the cache and the cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Make sure that you aren't blocking cookies (some of your extensions may be sending special opt-out cookies).

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

If clearing cookies doesn't work then it is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.

more options

I was able to clear the cache, but not the cookies. There was nothing about cookies in the privacy tab.

more options

As a test, can you reproduce in a new profile?

more options

I'm not sure what you mean by "Reproducing files." I went to the link, but I don't know where to go in profile manager.

more options

See

Firefox must be closed before using the profile manager, for now view that article in another browser such as Internet Explorer.

more options

Sadly, this did not help either. I'm also downloading a Flash Player for Internet Explorer as well.

more options

It is not working in internet explorer either. I know of another broweser that I've used called Safari, and it didn't work as well. The only one that worked was Chrome, which I don't have right now.

  1. 1
  2. 2