X
點擊此處開啟此網站的行動版。
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

技術支援討論區

此討論串已經關閉並封存。 如果您有需要幫助,請新增一個新問題

Copy/Paste not working in Firefox v23 & v24 without ZoneAlarm installed

已張貼

Recently I updated my Firefox from version 22 to 23 and I noticed copy and paste text from web pages in Firefox to other applications like notepad and even Firefox not working in my windows 8 x86. Copying text from other apps like notepad and pasting to Firefox works fine! I also updated it to beta v24 and same problem is still there. I don't have any issue with IE. BTW I don't have ZoneAlarm Installed.

Recently I updated my Firefox from version 22 to 23 and I noticed copy and paste text from web pages in Firefox to other applications like notepad and even Firefox not working in my windows 8 x86. Copying text from other apps like notepad and pasting to Firefox works fine! I also updated it to beta v24 and same problem is still there. I don't have any issue with IE. BTW I don't have ZoneAlarm Installed.

由 Ehsan 於 修改

被選擇的解決方法

I tried to disable startup programs one by one from task manager. I noticed a program named QTranslate which translates text from webpages to other languages causes my problem. After I upgraded QTranlate to final version, my problem was gone and Now, copy/paste functions works perfect as well as before! :)

I think new versions of Firefox (v23&24) is not adaptive with previous version of QTranslate. Therefore, after upgrading my Firefox from v22 to v23, my problem occurred and upgrading QTranslate fixed my problem!

從原來的回覆中察看解決方案 1

額外的系統細節

已安裝的外掛程式

  • Shockwave Flash 11.8 r800
  • Google Update
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.20513.0
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.2.122
  • Raidcall plugin
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • The plugin allows you to have a better experience with Microsoft Lync
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Facebook Video Calling Plugin
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NPWLPG
  • Yahoo Application State Plugin version 1.0.0.7
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/

應用程式

  • User Agent: Mozilla/5.0 (Windows NT 6.2; rv:24.0) Gecko/20100101 Firefox/24.0

更多資訊

kobe 441 個解決方法 5048 個答案

有幫助的回覆

can you try in windows safe mode. * http://windows.microsoft.com/en-us/windows7/start-your-computer-in-safe-mode
HarryStottle 0 個解決方法 9 個答案

有幫助的回覆

I've been having this problem since v22 and all I've so far seen are nonsense suggestions about a connection with Zonealarm. I use copy and paste so much that I'm forced to revert to v21 or use alternative browsers.

I've been having this problem since v22 and all I've so far seen are nonsense suggestions about a connection with Zonealarm. I use copy and paste so much that I'm forced to revert to v21 or use alternative browsers.
cor-el
  • Top 10 Contributor
  • Moderator
17851 個解決方法 161559 個答案

Try to set the Boolean pref dom.event.clipboardevents.enabled to false on the about:config page.

Try to set the Boolean pref dom.event.clipboardevents.enabled to false on the about:config page.

提出問題者

Dear @cor-el, I did this and the problem is still there.

Dear @cor-el, I did this and the problem is still there.

由 Ehsan 於 修改

cor-el
  • Top 10 Contributor
  • Moderator
17851 個解決方法 161559 個答案

Aren't the keyboard shortcuts not working as well?

  • Copy: Ctrl+C or Ctrl+Insert (Mac: Command + C)
  • Paste: Ctrl+V or Shift+Insert (Mac: Command + V)
  • Cut: Ctrl+X or Shift+Delete (Mac: Command + X)
Aren't the keyboard shortcuts not working as well? *Copy: Ctrl+C or Ctrl+Insert (Mac: Command + C) *Paste: Ctrl+V or Shift+Insert (Mac: Command + V) *Cut: Ctrl+X or Shift+Delete (Mac: Command + X)

提出問題者

Dear @cor-el, copy/paste functions works well for me in other apps except Firefox. I tried to boot in safe mode with networking as @Waka_Flocka_Flame told, and the problem is gone just in safe mode!

Dear @cor-el, copy/paste functions works well for me in other apps except Firefox. I tried to boot in safe mode with networking as @Waka_Flocka_Flame told, and the problem is gone just in safe mode!

由 Ehsan 於 修改

pctech799 0 個解決方法 2 個答案

I have same that , I did this and the problem is still there.Help me ! Thanks ! sua may tinh tai nha Sua may tinh tai nha

I have same that , I did this and the problem is still there.Help me ! Thanks ! [http://www.pctech.com.vn/dich-vu/5/sua-may-tinh-tai-nha sua may tinh tai nha] Sua may tinh tai nha

由 pctech799 於 修改

cor-el
  • Top 10 Contributor
  • Moderator
17851 個解決方法 161559 個答案

Hi ehsan453,

If it works when you boot Windows in Safe Mode then it is likely that your security software is causing this problem.

Other programs apart form ZoneAlarm can cause such issues as well.

Which security software (firewall, anti-virus) do you have?

Hi ehsan453, If it works when you boot Windows in Safe Mode then it is likely that your security software is causing this problem. Other programs apart form ZoneAlarm can cause such issues as well. Which security software (firewall, anti-virus) do you have?

提出問題者

Dear @cor-el, I just have built-in Windows 8 security software (Windows Defender and Windows Firewall).

Dear @cor-el, I just have built-in Windows 8 security software (Windows Defender and Windows Firewall).
cor-el
  • Top 10 Contributor
  • Moderator
17851 個解決方法 161559 個答案

You can use the MSConfig program or the Autoruns utility to see which software and services are getting started, but be careful with disabling services.


Do a malware check with some malware scanning programs on the Windows computer.
Please scan with all programs because each program detects different malware.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

You can use the MSConfig program or the Autoruns utility to see which software and services are getting started, but be careful with disabling services. *http://technet.microsoft.com/en-us/sysinternals/bb963902.aspx ---- Do a malware check with some malware scanning programs on the Windows computer.<br> Please scan with all programs because each program detects different malware. Make sure that you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender: Home Page:<br>http://www.microsoft.com/windows/products/winfamily/defender/default.mspx *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked

提出問題者

Dear cor-el,

Tnx for your reply. But how can i diagnose which software or services that are getting started, causes this problem?

Dear cor-el, Tnx for your reply. But how can i diagnose which software or services that are getting started, causes this problem?

選擇的解決方法

I tried to disable startup programs one by one from task manager. I noticed a program named QTranslate which translates text from webpages to other languages causes my problem. After I upgraded QTranlate to final version, my problem was gone and Now, copy/paste functions works perfect as well as before! :)

I think new versions of Firefox (v23&24) is not adaptive with previous version of QTranslate. Therefore, after upgrading my Firefox from v22 to v23, my problem occurred and upgrading QTranslate fixed my problem!

I tried to disable startup programs one by one from task manager. I noticed a program named [http://quest-app.appspot.com QTranslate] which translates text from webpages to other languages causes my problem. After I upgraded QTranlate to final version, my problem was gone and Now, copy/paste functions works perfect as well as before! :) I think new versions of Firefox (v23&24) is not adaptive with previous version of QTranslate. Therefore, after upgrading my Firefox from v22 to v23, my problem occurred and upgrading QTranslate fixed my problem!

由 Ehsan 於 修改

HarryStottle 0 個解決方法 9 個答案

hmmm... Just updated to V23 and found - in the about:config - the value noscript.allowClipboard set to false. Toggled it to true and, as of right now, copy and paste seems to be working again...

hmmm... Just updated to V23 and found - in the about:config - the value noscript.allowClipboard set to false. Toggled it to true and, as of right now, copy and paste seems to be working again...

提出問題者

Dear HarryStottle,

There isn't any preference named "noscript.allowClipboard" in the about:config list!

Dear HarryStottle, There isn't any preference named "noscript.allowClipboard" in the about:config list!

由 Ehsan 於 修改

cor-el
  • Top 10 Contributor
  • Moderator
17851 個解決方法 161559 個答案

That is a pref that is added by the NoScript extension. So you won't have it when this extension isn't installed.

That is a pref that is added by the NoScript extension. So you won't have it when this extension isn't installed.
rvalens2 0 個解決方法 1 個答案

cor-el's fix worked for me. I am running Firefox Beta 24.0.

"Set the Boolean pref (true/false) dom.event.clipboardevents.enabled to false on the about:config page."

I would just add these step-by-step instructions.

  1. Type about:config in the address bar and press enter. You'll see a long page of configuration settings come up.
  2. Search for the line that says dom.event.clipboardevents.enabled
  3. Right click on the line and click toggle from the menu to switch the selection from true to false.
  4. Close the window X

And you are done. You should now be able to copy and paste text once again. Thanks cor-el for helping me fix this problem. It was driving me crazy.

'''cor-el's''' fix worked for me. I am running Firefox Beta 24.0. "Set the Boolean pref (true/false) '''dom.event.clipboardevents.enabled''' to false on the '''about:config''' page." I would just add these step-by-step instructions. # Type '''about:config''' in the address bar and press '''enter'''. You'll see a long page of configuration settings come up. # Search for the line that says '''dom.event.clipboardevents.enabled''' # Right click on the line and click '''toggle''' from the menu to switch the selection from true to false. # Close the window '''X''' And you are done. You should now be able to copy and paste text once again. Thanks '''cor-el''' for helping me fix this problem. It was driving me crazy.

由 rvalens2 於 修改

the-edmeister
  • Top 25 Contributor
  • Moderator
5433 個解決方法 40562 個答案

The thread Owner's problem has been solved. Moderator is locking this thread - off-topic (Firefox Beta posting).

The thread Owner's problem has been solved. Moderator is locking this thread - off-topic (Firefox Beta posting).