搜尋 Mozilla 技術支援網站

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Flash Player stopped working. I have the current Firefox and Flash player. Unloaded and reinstalled, Same thing. I spent hours and hours trying to repair

  • 12 回覆
  • 74 有這個問題
  • 32516 次檢視
  • 最近回覆由 frudtr8d

more options

was watching a video on youtube and went to do a daily on Forge of Empires. I could not log into Forge of Empires but the video stopped and I could not log in. Flash player stopped 3 days ago and not worked since. Everything is up to date. I have uninstalled everything, and reinstalled, I even uniinstalled and downgraded, still will not work. Never had any problems with it before

被選擇的解決方法

I posted reply on another thread - basically I am having same problem and I have done everything everyone has suggested and it still is not working - but I also am finding that my clipper for Polyvore is also no longer working on Firefox - actually, it begins to work and then just stops - every time, time after time. I have downloaded a new clipper and still the same problem - both problems (Flash and polyvore) started at same time - both worked fine previously and both work fine on IE - which I hate to say I may just have to switch to - if anyone has this problem and has managed to fix it, please tell me how - I want to stay with Mozilla.

從原來的回覆中察看解決方案 👍 2

所有回覆 (12)

more options

Hello,

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

more options
more options

Note that you currently are on the Beta update channel and run the Firefox 24 beta release and not the current Firefox 23 release.

You can find the full version of the latest Firefox 23.0 release in all languages and for all Operating Systems here:


Your System Details List doesn't show the Flash plugin.

Do you still have installed the Flash plugin and is this plugin enabled?

You can find the latest Flash player versions for Firefox on this page.

由 cor-el 於 修改

more options

I guess you dont understand.

I have uninstalled EVERYTHING!! Then Reinstalled them. Tried Downgrading BOTH Firefox AND Flash Player. I also disabled EVERYTHING EXCEPT Shockwave (Flashplayer)

It shows up in my add-ons. Forge of Empires is a Flash MMO game and will prompt you to install the 11.7 Flash or later if it is not installed. I log in and go to initialize my play and it STOPS. Nothing happens. I go to watch a youtobe video and I get a black window and nothing happens.

I have also tried to reset Firefoxin the troubleshooting information.

Application Basics


Name: Firefox
Version: 24.0
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

Extensions


Name: avast! Online Security
Version: 8.0.1489
Enabled: false
ID: wrc@avast.com

Important Modified Preferences


browser.cache.disk.capacity: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.disk.smart_size_cached_value: 358400
browser.places.smartBookmarksVersion: 4
browser.startup.homepage_override.buildID: 20130806170643
browser.startup.homepage_override.mstone: 24.0
dom.mozApps.used: true
extensions.lastAppVersion: 24.0
gfx.direct3d.last_used_feature_level_idx: 0
network.cookie.prefsMigrated: true
places.database.lastMaintenance: 1376322669
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.flash: 0
privacy.sanitize.migrateFx3Prefs: true
storage.vacuum.last.index: 0
storage.vacuum.last.places.sqlite: 1376322668

Graphics


Adapter Description: NVIDIA GeForce GTX 680M
Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM: 2048
Device ID: 0x11a0
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.16492)
Driver Date: 10-12-2012
Driver Version: 9.18.13.717
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 10
Vendor ID: 0x10de
WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 680M Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: false
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo

JavaScript


Incremental GC: true

Accessibility


Activated: false
Prevent Accessibility: 0

Library Versions


NSPR
Expected minimum version: 4.10
Version in use: 4.10

NSS
Expected minimum version: 3.15.1 Basic ECC
Version in use: 3.15.1 Basic ECC

NSSSMIME
Expected minimum version: 3.15.1 Basic ECC
Version in use: 3.15.1 Basic ECC

NSSSSL
Expected minimum version: 3.15.1 Basic ECC
Version in use: 3.15.1 Basic ECC

NSSUTIL
Expected minimum version: 3.15.1
Version in use: 3.15.1

由 cor-el 於 修改

more options

Hi Garry, does Flash work on Adobe's test page?

http://www.adobe.com/software/flash/about/


If you check the following folder, do you have any duplicate players?

C:\Windows\SysWOW64\Macromed\Flash

Please remove all the older ones. The current player plugin file is NPSWF32_11_8_800_94.dll and you should remove any earlier NPSWF32_*.dll files.

more options

Hi Garry, two other things you might need to check next.

If the file is physically present but Firefox is not detecting it:

In other words, it is in the correct folder noted above, but does not appear on this tab:

orange Firefox button (or Tools menu) > Add-ons > Plugins category

The Firefox setting to scan the Windows registry for new plugins might have been disabled. You could check here:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste scan and pause while the list is filtered

(3) If plugin.scan.plid.all is not set to its default value of true, double-click it to toggle it back to the default. You might need to exit and restart Firefox to trigger another scan.

If that change doesn't stick, check for a user.js file as described in this article: How to fix preferences that won't save.

If the scan is set to run but the scan does not pick up the Shockwave Flash plugin:

There may be problem with the relevant key in the Windows registry. Assuming you are familiar with regedit.exe, that key is here:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\MozillaPlugins\@adobe.com/FlashPlayer => Path = C:\Windows\SysWOW64\Macromed\Flash\NPSWF32_11_8_800_94.dll
more options

Finally, this is some standard guidance that addresses the most common issues with the Flash player. I'm sure you've seen some of it before, but just in case:

(1) Make sure all recorders/downloaders that interact with Flash media are as up-to-date as possible, or disable them.

(2) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(3) Disable protected mode (Windows Vista/7/8)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

more options

I have the very same problem. Ever since upgrading to 24.0 I can no longer view YouTube videos on Firefox. I have no trouble with other browsers (IE and Chrome) and I can view the Flash home page. I've tried the suggestions and they do not work. Please fix!!

more options

Hi Essive, are the videos blank, do they start/stop, does Firefox say you need the Flash plugin, or does the video area show a crash? What exactly is happening now?

Could you also try Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

more options

選擇的解決方法

I posted reply on another thread - basically I am having same problem and I have done everything everyone has suggested and it still is not working - but I also am finding that my clipper for Polyvore is also no longer working on Firefox - actually, it begins to work and then just stops - every time, time after time. I have downloaded a new clipper and still the same problem - both problems (Flash and polyvore) started at same time - both worked fine previously and both work fine on IE - which I hate to say I may just have to switch to - if anyone has this problem and has managed to fix it, please tell me how - I want to stay with Mozilla.

more options

Hi frudtr8d:

(1) Polyvore Clipper

Do you notice this problem on secure (HTTPS) sites? Firefox 23 and higher block "mixed" content. When you click the "Clip to Polyvore" button/bookmark, it injects a Polyvore script into the page but because the script address does not use a secure address, Firefox blocks it and displays a "shield" icon on the address bar requiring your approval to run it.

That sounds like a workaround, but unfortunately, at least as of Firefox 24, there's no way to get Firefox to run this kind of mixed content that is injected after the page loads. If this feature is critical to you, you could turn off mixed blocking protection completely. If it's not that critical, you could try changing the URL of the site you want to clip from to HTTP instead of HTTPS. Either way, you should complain to Polyvore so they provide a higher security version of their button.

If you have problems with the Clipper on HTTP sites, too, I don't have any insight on that. Without a Polyvore account, I don't get very far in testing it.

(2) Flash

It is normal for the plugin to be named Shockwave Flash, which was the original branding. Could you cycle the setting on the Add-ons page: first set it to "Never Activate" and then set it to "Always Activate" to make sure it isn't stuck in click-to-play mode.

I understand from your other post that Flash does work on Adobe's site, but not on CBC, BBC, and some other sites where the player stays black. One possible reason for this is an ad blocker or other extension that modifies how pages work.

To sniff that out, could you try Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled (does not disable Flash)

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

more options

Thank you Jscher2000. Turning off the addons did the trick with the Flash- which sort of surprised me since I had already turned off the ones I thought most likely to cause problems. At any rate, it works - so thank you.

As for Polyvore -I do not have the experience you refer to - no shield comes up for me. Now I am really confused. I have the same problem on http sites. It always starts to work as usual and then after it clips a few it stops - whereas it used to zip through the list in seconds. I will contact Polyvore though - thank you for the suggestion.

Thanks again for the help!