搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

change search engine on about:home page to startpage or ixquick

more options

Change the default search engine in about:home to duckduckgo works perfect for me. I changed in the about:config settings the value browser.search.defaultenginename from "Google" to "DuckDuckGo". But when I change the value to "Startpage HTTPS - Deutsch" or "Ixquick HTTPS - Deutsch" it didn't work. Can somebody help me?

Thanks lemon_grass

Change the default search engine in about:home to duckduckgo works perfect for me. I changed in the about:config settings the value browser.search.defaultenginename from "Google" to "DuckDuckGo". But when I change the value to "Startpage HTTPS - Deutsch" or "Ixquick HTTPS - Deutsch" it didn't work. Can somebody help me? Thanks lemon_grass

由 lemon_grass 於 修改

所有回覆 (7)

more options

Can you reproduce this in firefox aurora? I think this is fixed in v24.

由 kobe 於 修改

more options

If you select the default search engine for the search bar to this (installed) search engine then you should be able to see how Firefox identifies a specific search engine.

more options

This is exactly what I did to identify the firefox name for the search engines.

more options

I tried v25 and there it works perfect!

@Waka_... But it took me almost over two hours till I got aurora worked on any of my OS's. For me, somebody who never had something to do with firefox aurora, this is much more difficult than change a search engine.

First I didn't found the x86_64 Version of Aurora for Linux, then I tried it on Win7 32bit. There the installation file asked me for an user "administrator" with password. But I have no user called "administrator". I have my user "XXX" with admin rights but it didn't worked. I don't know why. After while I tried it again on Mint and so on, and so on ...

What I want to say, next time please post a link to a tutorial, when you say to somebody "try it with aurora"

I really appreciate your help! This is only my answer because I don't want that this happens to somebody else.

thanks lemon_grass

由 lemon_grass 於 修改

more options

Hi lemon_grass, sorry to hear about your troubles. I think it's a case of bad timing. Firefox 23 released today, so Beta bumped up to 24 and Aurora bumped up to 25.

If I understand correctly, I think this change is actually in Firefox 23: about home uses the search engine selected in the search bar.

more options

its working in ff23!

more options

Here is what I did and worked for me: Firefox help Troubleshooting Information Click Reset Firefox

Now my search engine is Google..... As far as I know reseting did not affect any of my settings All my bookmarks are there. Try it