搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

Enter Private Browsing - Windows 7 Taskbar Pin - Not Working Anymore

  • 4 回覆
  • 17 有這個問題
  • 7 次檢視
  • 最近回覆由 daveys93

more options

I am not sure what version this stopped working correctly for me at but I am currently running version 22.0. I have Firefox pinned to my taskbar in Windows 7. When I used to right click on the pinned icon I would get a menu that popped up with some options listed under "tasks". One of the tasks is "Enter Private Browsing", which when clicked would open Firefox in private mode.

Now when I right click on the icon I still have the "Enter Private Browsing" task listed, but when I click it, it just opens Firefox in normal mode. So now I have to click on the Firefox menu, click "New Private Window", this opens another window (this one is private) and then I have to switch back to the normal window and close it.

It used to be so convenient to just do the right click on the pinned icon and have the browser open in private mode. I think it is weird that the option is still there but just appears to do nothing.

Anyone know how to fix this?

I am not sure what version this stopped working correctly for me at but I am currently running version 22.0. I have Firefox pinned to my taskbar in Windows 7. When I used to right click on the pinned icon I would get a menu that popped up with some options listed under "tasks". One of the tasks is "Enter Private Browsing", which when clicked would open Firefox in private mode. Now when I right click on the icon I still have the "Enter Private Browsing" task listed, but when I click it, it just opens Firefox in normal mode. So now I have to click on the Firefox menu, click "New Private Window", this opens another window (this one is private) and then I have to switch back to the normal window and close it. It used to be so convenient to just do the right click on the pinned icon and have the browser open in private mode. I think it is weird that the option is still there but just appears to do nothing. Anyone know how to fix this?

所有回覆 (4)

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.

You can use one of these to start Firefox in Safe Mode:

  • On Windows, hold down the Shift key while starting Firefox with a double-click on the Firefox desktop shortcut
  • On Mac, hold down the Options key while starting Firefox
  • Help > Restart with Add-ons Disabled
more options

Thanks for the suggestion.

I checked my theme and it is set to default.

I tried starting Firefox in safe mode, but i am not sure this really tells me anything since I am having problems getting firefox to open in private mode from the taskbar pin menu.

In any case, I opened Firefox in safe mode and then right clicked on the taskbar pin and then clicked on the "Enter Private Browsing" option. This opened another Firefox window, but it just opened in normal mode and not private.

more options

Does it work if you hold down the Shift key when you click the Private Browsing mode entry or doesn't anything happen in that case?

Does opening Firefox via modified desktop shortcut that has the -private command line switch work?

more options

Shift+Click on the pinned tasks menu just opens a normal window.

I created a desktop shortcut with the " -private" switch and that opened in private mode, as it should. A good test but still does not solve the problem for me unfortunately :/

Just do not understand why the pinned item task does not work anymore.

Thanks for the attempt though. Any other suggestions?