搜尋 Mozilla 技術支援網站

防止技術支援詐騙。我們絕對不會要求您撥打電話或發送簡訊,或是提供個人資訊。請用「回報濫用」功能回報可疑的行為。

Learn More

disable plugin check

  • 8 回覆
  • 48 有這個問題
  • 34461 次檢視
  • 最近回覆由 ivo.kisselov

more options

Dont laugh, but yes I have firefox 3.6.28 with windows xp and sp 2. and just recently this stupid plugin check keeps popping up every time i open my firefox. My version 3.6 was fine until today. and nothing on my end has changed with my knowledge.

Yes i know most would tell me to update my firefox to correct it, BUT I DO NOT WANT TO UPDATE. if i wanted a newer version i would download it.

Personally I hate the new versions of firefox, and have no use for them. and do not want to update to something I DON'T WANT. I choose to keep my old firefox, I do not want to update it every time mozilla feels like changing or adding some stupid feature i do not use, need or want. leave versions alone for petes sake mozilla

With that said how can i permanently stop that stupid checker ?

由 defuz2013 於 修改

被選擇的解決方法

thanks again for reply, that did not work, but i did try downgrading from 3.6.28 to 3.6.22 and added the same plugins i used in 3.6.28, and all is fine again. no problems now.

so looks like it was a problem with version 3.6.28.

thanks for help anyway.

從原來的回覆中察看解決方案 👍 3

所有回覆 (8)

more options
more options

hi, thanks for reply, that answer only 1/2 works. changing the about:config settings as mentioned in that post does stop the plugin update part. but does NOT stop the new tab/window.

Now it opens a new blank tab instead of the plugin update page. any idea how to stop it ?

id like to keep the normal "open in new tab" so do not want to disable that. just the one that opens for the plugin update.

more options

Hello, try to change (in about:config) the plugin.scan.plid.all to False (double-click on it), with that the plugins in Windows registry will not be detected any more.

any luck ?

thank you

more options

選擇的解決方法

thanks again for reply, that did not work, but i did try downgrading from 3.6.28 to 3.6.22 and added the same plugins i used in 3.6.28, and all is fine again. no problems now.

so looks like it was a problem with version 3.6.28.

thanks for help anyway.

more options

Stop Nagging Me! If you go to about:config, you can disable the plugincheck. However, if you do (at least on MY system) it blows out your Flashplayer, and you have to reinstall everything including firefox. So....you can't win.

Here's my fix. Go to plugincheck URL, and type in ANY URL. For example, your home page, or if you want, a second home page. Instead of hounding you, it will open a page of your choice!

Why am I against upgrading? Because I am using an old computer that can only, due to hardware limitations, run Windows 2000. Every plug-in, and everything else is maxed out and running the highest version allowed by win2000, including Firefox12, adobe reader9, Java se6U26, and Flash player 11. I tried to download the newest updates, but they would not run. To do what you ask, I basically have to buy a new computer.

I cannot afford a new computer right now, and have to make due with this dinosaur. At least it still works. So leave me alone, unless you want to buy me a new PC. If a person has chosen not to upgrade, there must be a reason. So stop nagging. If my system were up to it, I would upgrade. I KNOW THE PLUGINS ARE OUTDATED AND POSE A SECURITY RISK.

Its bad enough using an outdated computer, but this nagging makes it worse. When I finally do get a new system, I am NOT GOING TO USE FIREFOX AS THE BROWSER.

由 bobk1000 於 修改

more options

I appear to have this solved now -

I am running 3.6.27 on a test laptop and, like previous posters, would like to decide for myself when and if I want to upgrade, and found this extra tab that started recently rather annoying.

If you set the key <plugins.update.notifyUser> in about:config to false (which is the default value by the way), it stops the behaviour once, then reverts on the next opening. Bizarre !!

But you can override this behaviour thus:

1) in your Firefox Profiles folder -- in XP this is <C:\Documents and Settings\[your user name]\Application Data\Mozilla\Firefox\Profiles\[your folder number].default> -- find the file <user.js>. If the file doesn't exist then make a new text file in that folder using Notepad, and save it as <user.js> (ie: NO .txt extension).

2) Inside <user.js> (open it by opening a Notepad window and then dragging the filename into that window) write (copy in) the two lines:

// Don't show plugins update tab on startup

user_pref("plugins.update.notifyUser", false);

Then save the file.

The first line is just a comment to say what the following line is for. The second line overwrites that particular preference line in about:config every time you open Firefox.

Works for me - hope you all find that helpful.

ADDENDUM -- 4th Sep 2013: Before posting the above, I had researched this solution for a friend (with a lowly laptop running Win2k) and, although the solution I posted had worked fine for me on my test XP laptop, it did not eventually prove to work for my friend.

I have now found the reason for that on my friend's computer and have corrected it for them -- Under the menu section " Tools > Add-ons" on their computer the "Java Console" was installed and enabled, which it was not on mine. Once that is disabled in the Add-ons list, after a reboot, the <user.js> entry described above will successfully stop the UpdateNagScreen appearing.

As before - I hope people find this of help.

由 denovo 於 修改

more options

If your computer can't update (like Windows2000) then we understand why you can't update. But if your computer is technically able to support the most modern version of Firefox, you should update ASAP. Mostly for security reasons: https://www.mozilla.org/security/known-vulnerabilities/firefox.html, but also for the modern web. Using Firefox 3.6 is as bad as continuing to use IE6, it's bad for the web, and you are holding the web back. If you don't like the UI of a modern version of Firefox, you can chance that easily, that's not a reason to stay on an out of date version of Firefox. We don't update you to "control your life" or be big brother, or else we'd force you to update with no choice behind it. We have updates to make life better for you and the web, and using old versions of Firefox is contrary to this. If you want to use old versions of Firefox please stop using Firefox and use a modern version of some other browser. That's better for you, your security, and the web.

more options

Hello, There is no problem for anybody to believe in fairy tales, conspiracy theories or monthly/weekly/dayly updating play. Do so if you wish. BUT Let everyone else CHOOSE if they want to be reminded to update or NOT. Hope you can uderstand that. Ivo Kisselov